"Render Device Lost" Fix for RTX


#220

So far, rolling back to RTX 2080’s earliest driver (411.63) has worked for me. Knock on wood, but I’ve been playing for multiple hours without issue.


#221

Let me know if that continues to work after more time has passed. What could be potential downsides to using older drivers?


#222

Is it safe to say that this is a problem on Blizzard’s end because Overwatch is the only game that crashes for me in this way?


#223

Yes! There is something in the game that makes the GPU unable to process TDR (2s by default) and then windows kills and reloads the driver.

In my case it happens at random times on two completely different (as hardware components) computers.

I suggest you limit the FPS to a value that utilizes your GPU at max 90% and if that doesn’t help you can increase the TdrDelay value to 6s or more.


#224

I’ve seen some people mention turning off TDR (whatever that is). Do you think that would help? Would increasing the delay be a better option? Also, I currently have my frames capped at 144 which shouldn’t cause any usage issues with my gpu. Furthermore, I keep an eye on my gpu temperature during gameplay and it never goes over 60-64c.


#225

TDR (Timeout Detection and Recovery) tries to detect if the GPU has “hang up” and tries to fix that - during the fixing period there is a timeout (2s by default) - in case the GPU is not able to finish the task in those 2s a timeout occurs and TDR will kill and restart the GPU driver and that is the Render device lost error you see. (I tried to ELI5 but if you want technical details, let me know).

Increasing the timeout to 6-8s might give enough time for the GPU to handle the work during the TDR check and prevent the reset of the driver. Also having the GPU at 60-80% utilization could also help but have in mind that the amount of work the GPU has to do is not constant and varies a lot.

I have limited mine to about 40% utilization and so far managed to play 6-7 games without TDR reset.

I am against disabling TDR - in case you do so and the driver crashes - you’ll be forced to reboot the whole PC as the driver won’t be reinitialized by TDR.


#226

How do I monitor my Gpu usage during gameplay, and what is the best way to reduce it? Thanks for the help so far. Also, could this issue be a problem with the Windows 10 OS?


#227

Following up… TDR delay at 8 sec still crashes with rendering device lost error.


#228

So I’m going to try some previously mentioned ideas to fix this issue, including:

  1. running a system file checker on my operating system to search for any missing or corrupted files.
  2. Change my gpu to debug mode.
  3. Change various settings in nvidia’s control panel, including: set power managment mode to prefer maximum performance, set triple buffering to off, turn threaded optimization on, and turn verticle sync off.
  4. Revert back to a previous gpu driver.

I’ll update once I’ve tested each of these out. I’m inexperienced with these things, so if any of the possible solutions I’ve mention could have negative side effects on my computers performance, please let me know.


#229

In case this helps, I get the crash every two games or so, but I haven’t gotten it when I play Practice vs. AI (at least not back when I tried it). I hope that narrows down the potential scenarios where this happens.


#230

I’ve done everything that I’ve seen, short of just chucking my PC out the window and it still crashes. I had a good 3 hour run last night where nothing happened but it crashed today as soon as I picked a toon


#231

Ultimately there is nothing any of us can do except wait for Blizzard to take responsibility and fix their poorly coded game.

It’s not a hardware issue as there are over 100 people on these forums alone experiencing the same problem each with different hardware.

It’s not conflicting software on our computer as even a fresh HDD with nothing but Windows and Overwatch continually crashes.

The problem is Overwatch itself.

But Blizzard refuse to admit they screwed up, they already have our money so they simply don’t care.


#232

The last blue comment said they were able to reproduce the problem, so they may be working on a solution as we speak. I just wish they would update us more often…


#233

Update on my end with an rtx 2070.
Playing on all low settings worked. Haven’t crashed ever since. Unfortunate with a card like this but this is the only way I can play until they fix it.


Rendering Device Has Been Lost
#234

How often were you having crashes before, and how long have you gone without a crash since changing the settings?


#235

Crashed every 3-4 games randomly mid-game. Not in the beginning or end like some other people.
Haven’t had a crash since lowering settings playing 3-4 hours a day. GPU temps at 60C.


"Your rendering device has been lost" w/ RTX GPU
#236

Hey all,

We’ve gotten a number of reports on this and we’ve fiddled with it on our end some. We need some more information on whether or not this specific step works-around this issue.

  1. Open your Overwatch installation folder (C:\Program Files (x86) by default)
  2. Right click the Overwatch application file and choose Rename
  3. Rename the file file to OverwatchTest
  4. Double click the application to launch the game

You can just reply in the thread whether or not this fixes the issue for you. Keep in mind that we don’t expect this to fix everybody’s issue since there are a couple different reasons you might be getting this error. If this does stop the errors from happening though, please post here so we know what the issue is.


Game crashes or freezes, new card installed
Rendering device lost
Overwatch has crashed in the graphics driver
Render Device Lost
Game Stutters When Opening Menu
Rtx 2080 render device lost
#238

Hi Drakuloth,

So far so good on my end. Played for ~ 4 hours without a crash.

Does that mean that I need to use the OverwatchTest.exe every time I want to play the game? If that’s the case, I’m assuming this would mean that the Blizzard launcher won’t work?

Side note, when I launched the OverwatchTest.exe, it re-created an Overwatch.exe.

Thanks to the team for digging into this.

Quick update on this: Still no crash on my end after 2 days.


#239

Could you explain why this is going to work and what’s going on the the background? Is it creating a fresh launcher, resetting some graphic settings?

Thanks


#240

This makes no sense. I haven’t had a crash for a whole week and all of the sudden the game crashed again. I guess I will have to try the “fix” as well. Although with how it took a whole week for the crash to appear again it is really hard to figure out if the “fix” will even work at all.