Rendering Device Lost

Rendering Device is lost. Crashes occur on a brand new RTX 2080. This is the ONLY game that ever crashes and has this problem. I have googled and googled and googled this problem. I have updated bios, graphics card to the latest drivers, chipset drivers, disabled every overlay and closed every program besides the app and overwatch.

My system:

Ryzen 2700x
RTX 2080 FE
16 GB of RAM
ASUS ROG Strix x470-F Motherboard

As you can see I have an EXTREMELY capable machine, able to decimate BFV with RTX On, Metro Exodus, etc etc etc. This is the ONLY game that EVER gives that error and crashes.

This has caused me to lose placement matches in the new role queue. Making me lose games and place lower.

I need an answer to this. I am prepared to submit a support ticket every day, tweet to blizzard CS every day until this is resolved. I am willing to try anything.

Hey, DemonicTaco!

This is likely related to the ongoing RTX profile issue that is causing these crashes after taking a look.

The forum post here:

If you rename the Overwatch.exe file and launch the game through this file it should prevent the crashes. If the game ever patches, you will need to rename the Overwatch.exe again and launch with the new renamed file.

Once we have a complete resolution for this, we will add it to this forum thread.

Okay thank you. I did as you suggested. I will update if it has crashed.

No worries. Hope it helps!

I get this alot on my 1060…

I tried this yesterday and after about 8 hours, I ran into it again.