"Render Device Lost" Fix for RTX


#231

Ultimately there is nothing any of us can do except wait for Blizzard to take responsibility and fix their poorly coded game.

It’s not a hardware issue as there are over 100 people on these forums alone experiencing the same problem each with different hardware.

It’s not conflicting software on our computer as even a fresh HDD with nothing but Windows and Overwatch continually crashes.

The problem is Overwatch itself.

But Blizzard refuse to admit they screwed up, they already have our money so they simply don’t care.


#232

The last blue comment said they were able to reproduce the problem, so they may be working on a solution as we speak. I just wish they would update us more often…


#233

Update on my end with an rtx 2070.
Playing on all low settings worked. Haven’t crashed ever since. Unfortunate with a card like this but this is the only way I can play until they fix it.


Rendering Device Has Been Lost
#234

How often were you having crashes before, and how long have you gone without a crash since changing the settings?


#235

Crashed every 3-4 games randomly mid-game. Not in the beginning or end like some other people.
Haven’t had a crash since lowering settings playing 3-4 hours a day. GPU temps at 60C.


#236

Hey all,

We’ve gotten a number of reports on this and we’ve fiddled with it on our end some. We need some more information on whether or not this specific step works-around this issue.

  1. Open your Overwatch installation folder, the default location is:
    C:\Program Files (x86)\Overwatch\_retail_
  2. Right-click the Overwatch application file and choose Rename
  3. Rename the file to OverwatchTest
  4. Double click the application to launch the game

You can just reply in the thread whether or not this fixes the issue for you. Keep in mind that we don’t expect this to fix everybody’s issue since there are a couple of different reasons you might be getting this error. If this does stop the errors from happening though, please post here so we know what the issue is.


Rendering device lost
Overwatch has crashed in the graphics driver
Game crashes or freezes, new card installed
Render Device Lost
Game Stutters When Opening Menu
Overwatch freezed without crashing
6% Loss Out issues
Crashing every time im in a game. tried alot of options and im stumped :/
Known Technical Support Issues - [Updated May 18, 2019!]
Nvlddmkm has stopped working and recovered succesfully
Rendering Device Lost
Rendering Device has been lost GTX 1060
“Rendering device has been lost! Application closing.”
Docked 50 SR, still won
"Rendering Device has been Lost"
Overwatch hard crashes?
Fix your servers
Rendering device lost in OW
I lost SR because my game crashed during a match in lucio ball
Removing leaver penalties in specific cases
OW crashing computer
Unfair SR drops after crash
Rendering device lost, new RTX 2080
Rendering device lost... Blizzard and NVIDIA support cant help me
Why am I suspended?!
Your rendering device has been lost
Rendering bug please help me
Rendering device lost
Render device lost + Game lockup crash
Rendering device lost error
Rendering device lost, please read
RTX render device lost
RTX render device lost
RTX render device lost
Rtx 2080 render device lost
Game Crashing Continuously
“Your rendering device has been lost. Closing application”
Rendering Device Lost
Rendering device lost
How about when my graphics card crashes i don't get banned from comp
Suspended for canceling queue
Rendering device lost. With rtx 2070
Rendering device lost... Blizzard and NVIDIA support cant help me
What's up with the "rendering device lost" issue?
Please fix your game so it's at least playable!
Rendering device lost! Application closing
#238

Hi Drakuloth,

So far so good on my end. Played for ~ 4 hours without a crash.

Does that mean that I need to use the OverwatchTest.exe every time I want to play the game? If that’s the case, I’m assuming this would mean that the Blizzard launcher won’t work?

Side note, when I launched the OverwatchTest.exe, it re-created an Overwatch.exe.

Thanks to the team for digging into this.

Quick update on this: Still no crash on my end after 2 days.


#239

Could you explain why this is going to work and what’s going on the the background? Is it creating a fresh launcher, resetting some graphic settings?

Thanks


#240

This makes no sense. I haven’t had a crash for a whole week and all of the sudden the game crashed again. I guess I will have to try the “fix” as well. Although with how it took a whole week for the crash to appear again it is really hard to figure out if the “fix” will even work at all.


#241

I don’t even know what my login details are… I’m so used to Bnet launcher!

I used my email as account name, it asked for an authenticator but nothing came up on my authenticator, and the manual authentication code didn’t work either.


#242

Update:

With the OverwatchTest method I have experienced my game freezing on me for 10 seconds before being able to move again. Before changing to OverwatchTest I have only had crashes to desktop.

What I find odd is that I have yet to crash to desktop during a custom game.

Edit: My game froze again in QP, this time 5 seconds.


#243

Should be the same dude.


#244

Overwatch asks for my login details, I enter my email and password.
Next it asks for the authenticator but there are no requests on my authenticator and the manual code doesn’t work!


#245

Hi Drakuloth,

This also seems to have fixed the problem for me. I have played about 4 hours on OverwatchTest.exe and i haven’t crashed once.

I was experiencing the rendering device error once every 5-6 games. Both my CPU and GPU remained at a stable 65 degrees C when the crashes occurred.

Previously i had noticed that the error usually occurred during big team fights or during the POTG. Unplugging my second monitor reduced the frequency of crashes but did not fix the problem permanently.

Specs: 16Gb 3000MHz corsair vengeance DDR4 Ram, EVGA RTX 2070 Black edition, an Intel i7 - 8700k and an Asus Z370 series MOBO.

I hope that this information helps!
Thanks


#246

Do you have an RTX 2060/2070/2080? Are you using the 417.71 drivers?


#247

Tried this method and still does not work for me. Instantly crashes when I join a game. Specs:

GPU:
Gigabyte RTX 2070


#248

The OverwatchTest method did not work for me. Instead of getting the “Render Device Lost” message, I just crash to desktop.

Specs: i9-9900K, Asus Maximus XI Hero Z390, 32gb G.Skill 3200 C14 Memory, EVGA RTX 2080 Ti FTW3
NVIDIA Driver: 417.71


#249

I have an RTX 2070 from Gigabyte (Gaming OC 8 G).

At the moment I am not yet using 417.71 but 417.35, if I am correct. I am a little hesitant on getting the latest drivers installed because my crashes already seem to happen less often than for some in this thread. My crashes, if they happen are once a day (It has never happened to me twice per day) which could be in the first match but it usually happens after a few hours of play, if it happens at all. The crashes seem to happen at any time during QP matches. At least for me it doesn’t seem to happen solely when there is a lot going on. It can even happen when it is just me and one other person on screen.

Update: I haven’t crashed yet with the OverwatchTest method.


#250

No results here… Still crashes after a few games.


#251

I have a rog strix 1080 and I still experience this crash… It usually happens while streaming, but happens when off-stream too… temps are normal, all drivers are updated, not sure what to do at this point… I’d like to note Black Out 4 has started disappearing every few games since their latest patch as well. It doesn’t leave any errors, the game just disappears…

specs: Ryzen 2700x, 32gb 3200mhz cl14 RAM, 500gb m.2 NVME, 1080 rog strix, X470F rog strix mobo