Season Journey and Achievement Bug [Solution]


Achievement or Season Journey window shows
  • Blank
  • some error text, e.g. [PH], [!!! Missing !!!]

Possible Causes

Possible causes are:

  • corrupted cached files
  • file access permission
  • bad firewall or router settings
  • other unknown reasons

Work Around Solutions

Method 1: Switching Region

Switching region may reset cache files. It may force data files to be downloaded, and thus fix the issue.

  • Switch to other region on the launcher (e.g. Europe if you were playing on Americas region)
  • Create a hero if no hero on that region
  • Create a game and open the achievement/season journey
  • Exit D3
  • Switch back to main region and retest

Method 2: Delete Cache Folders

This method works for most cases.

Follow the instructions in BOTH links (you can select Windows or Mac OS):

For Windows users, if it didn’t work for you, try deleting and Blizzard Entertainment folders as well:

  • C:\ProgramData\ (already included in the support links)

(Press Win+R, enter %APPDATA%, for example.)

Method 3: Run As Administrator Role

Sometimes, especially in computer shared by multiple users, the issue may be caused by file permission. Run the game as Administrator Role may solve the issue. Steps:

Method 4: Anti-virus and Firewall Settings

Anti-virus and firewall settings may also cause the issue.
Temporarily turn off anti-virus and firewall to verify.
Note that some routers have built-in firewall; you may need to turn off them too.

After you prove that the problem is at anti-virus/firewall, then you need to fix them.

How to configure router/firewall:

Other Methods

Some other players had solved the issue with their own ways:

  • set up DNS:
    Edit: (Links removed because of retirement of old forum.)
    No detail steps here because the original posters didn’t given any. You may try using Google DNS or other public DNS.

  • reinstalling the game. See the Advanced Troubleshooting section of this article for uninstalling game cleanly:

Extra Remark

If the screen is still error after trying above methods, try completing some achievements/objectives. It may help to trigger data update to your client. For seasonal objectives, you may reference this website: Diablo 3: Season 27 Journey Tracker
(Reference: see conversation in this thread.)

Good Luck !!!

:grinning: :grinning: :grinning:


Nice job, Maskraider! :beer:

None of these worked for me. Uninstalled completely, deleted all blizzard folders, reinstalled everything and on the European server I still cannot see the season journey achivements, only can see those on the USA server.

1 Like


Sorry to hear that.

I’d recommend you to enter a ticket to contact support as this is actually a technical issue.

If you find a solution, you are welcome to get back. I’ll add your solution to the topic.

I’m having the same issue, also tried everything without a solution, and whenever I try to open a ticket, it just tells me to come to the forums.


When entering a ticket, rather than inputting the text box,
I would rather categorize the issue > In-Game Issues > Technical Issue > Crashes > Contact Us

Then choose a communication channel, and fill in the form.

Or, use this link:
(You may be prompted to login.)

I have created a ticket as well as a forum discussion. Thank you very much Maskraider!

I have the same problem, write if you help.


Which methods have you tried?
If one method doesn’t work, you may need to try other methods.
Mind that you can change the language at the bottom of those support articles.

All tried, nothing helps.

I’m facing the same issue. Already tried everything that is explained in this thread without success.
Actually, on America Server everthing’s fine, only on the European Server I’m facing this issues since some days.
Is anyone from Blizz still investigating this issue?

Thank you very much!

That’s exactly what happens to me. I’m an EU player, and in the EU server it basically blows up no matter what I try to fix it. Jump to another server and boom, everything runs as intended.

My five cents. Below there is a screenshot that illustrates this bug.
In fact, this is a compilation of two screenshots: at the top it was made from my side, at the bottom - by another player who has this bug.

You can see that we are in the season in a group. At the same time, I have a button for viewing the seasonal journey, but the other player does not have it. And if he press shift + J, then an empty window is opened without quests of the seasonal journey.

As mvp of eu/ru technical support, I already know several people with this bug. The tips at the beginning of this topic do not help. Please fix this bug or give us an information on how to fix it ourselfs.


Adding Link to the Not a bug thread to this thread.

The missing button at top right seems something is broken to me. I’ve never seen this before.

I’d suggest running Scan and Repair tool first. And then go through the methods above.
If it doesn’t help, I suggest you to create a new topic because the title of this thread contains the word “[Solution]”; I’m afraid Blizzard will skip reading this thread.

I’m also facing the same issue since few days. Already tried everything that is explained in this thread without success.
Problem occurs when connected on European Server. On America server (same device, same acount) it works fine.
I’ve also opened a ticket to support, but did not get any solution so far.
I hope support will investigate deeper, as it is very anoying not to be able to complete this season journey…

1 Like

I got the same issue, the Window stays blank and i already did everything suggested in here; Problem occurs on the European Server, on the Asian one is works

After running a ticket with Tech Support where sadly (and even though they tried diligently) they couldn’t fix it for me, I’m stating my case: Season Journey blank on EU, tried all the steps listed here, opened a ticket, ran their connection troubleshooting aswell as deleting again cached folders, then tried the new fix they told me: new admin account to run the game and checking the HOST file for issues, but still persisted even repeating the connection troubleshooting guidelines a second time. They made a second manual trial, but it seems to be a technical issue on EU. They told me to post this here and that the devs are on it, so I’m hoping to hear from them soon.

“Run as admin” is Method 3. Does it mean that you haven’t tried all methods?
If so, try Method 4 and Other Methods (DNS settings, delete game manually and reinstall)

For DNS settings, I don’t have any detail steps because the original poster didn’t mention. I think you can use Google DNS or other public DNS.