New Celestial Mog disappeared

Just noticed the Celestial Observer’s Ensemble is no longer in my appearances. I bought it when it came out and was using it fine. In the Shop screen, it still says Purchased; but I do not see any of the ensemble in my xmogs. Gear that was already mogged to it was all reverted.

3 Likes

Have you filed a bug report?

1 Like

Just saw your post, I posted the same - mine is also gone

There is a Known Bug that our QA teams have been attempting to reproduce but have so far been unable to get it to happen in testing.

Occasionally, transmogs awarded from shop purchases or promotions will disappear from your collection. In some cases, only the full set UI disappears but you can still find the individual items in your collection. In other cases, everything is missing for a period of time.

These do reappear on their own, and with no need to make any changes to your game settings/files. It’s very random and that has contributed to the difficulty for QA to reproduce it. Every time they check, they’re unable to get stuff to vanish :frowning:

Sorry for the trouble, but sit tight - it should reappear on its own.

5 Likes

Venting a little here:

It’ll disappear again, and reappear again, and meanwhile if you want to use the mogs again you have to spend hundreds of gold to reapply them each time after already paying cash to buy the mogs in the first place. This can happen to all store mogs and has for years. Rinse and repeat until you just forget about them and don’t bother buying anymore mogs.

Yes yes I know feedback doesn’t get passed along here. I’ve already left mine in the appropriate places. Just setting expectations for the OP as well.

8 Likes

This happens to me like crazy. It is really irritating at this point!

4 Likes

No one agrees more than the QA folks who keep being asked to reproduce it.

I can only suggest that when it happens folks submit an in-game bug report and hopefully the occurrences can be used to track any trends that contribute to it happening.

4 Likes

I will do this the next time it happens to me.

2 Likes

So I purchased the Stargazer pack yesterday which has the transmog, mount, and pet. I applied my transmog when I purchased it yesterday and as of about an hour ago, the transmog has gone missing. My mount and pet are not affected. I did file a bug report in game.

2 Likes

Do you have any other store outfits? like the helmets or the Fey Dragon outfit?

I have those but don’t recall them ever doing this to me. Maybe I’m immune?

Those are affected too.

1 Like

Yes, but I’m trying to figure out if people who have this bug have it on all their store stuff or just this set.

So far I don’t have the bug on the previous store set or helmets. Am I immune? or will buying it get me the bug?

Usually whenever I encounter the issue, all of my store appearances are gone. Helm. Woolies etc.

1 Like

I just created a bug for this in game. Just now as it happened to me again.

Same thing here. You would think they could look at our accounts and see something similar happening to each one? Mine is gone and hasn’t come back. Also, I have the other transmogs that I purchased, just not the latest one so it is only affecting the most recent purchase.

Multiple people with the same issue is a good way for duplicating/reproducing the problem…

You might think so, but that’s not always true.

We can definitely see that it happens. That there is a bug is not in question. The QA team needs to understand why it happens before they can fix it. Since they cannot get it to happen in their testing - even when using example accounts provided by Game Masters - they’ve not been able to track down why so they don’t know what they need to fix yet.

This is one of the weirder bugs that I’ve personally seen. It doesn’t affect everyone, doesn’t seem to based on age of the account, or when the purchase was made. Then, without any intervention, it fixes itself.

If the root cause and fix were easy to identify, I promise it would have been implemented by now.

12 Likes

Most of my alts are still sitting at level 50 in full epics and azerite pieces… my mogs are often closer to the 1k mark >< It’s super frustrating to the point that I’ve just stopped using store mogs for the most part. My gnomes miss their woolies :frowning:

1 Like

Add me to said list, mine disappeared as well.

Observer’s Ensamble.

I can’t figure out how to reproduce it either. I have tried tons of things and there seems to be no real reason why it has come and gone 2 times today.