Soaring Spelltome Disappeared from Mount Collection

Hi, I just earned the soaring spelltome mount earlier today from completing the 7 mage tower challenges. I still have the achievement “A Tour of Towers,” but the mount has disappeared from my collection. Pretty disappointing since this was quite an effort to obtain.

Edit: It happened after I logged into my second account, I’m not sure if that has anything to do with it, or if it was just a coincidence.

Have you tried doing a /cast Soaring Spelltome macro to see if you can still mount it? There were issues with other mounts disappearing from the collection in the past and that was a workaround for some. It’s still a bug if it did disappear, but I figured I’d offer the suggestion if it could help you use it in the meantime. Also double-check to make sure your collection filters are all selected as well.

I did try that and it didn’t work sadly. The mount is completely removed. I can look it up in the journal and it shows as uncollected, even though my character is still mounted on it.

1 Like

Hm. So I logged into my primary account again and the mount was back in my journal. Then I tried logging into my second account and it is gone again on both accounts. So it seems it has something to do with multiple accounts.


Bugged for me too, all I did was login to another character from a different realm.

Having the same issue. Also have 2 accounts as well. I was logged in on both accounts when I got the achievement and mount. After relogging, the mount disappeared.

I really hope this isn’t the same issue as the disappearing store transmogs…

Same issue here, I got the achievement yesterday and after I relogged into the game the mount disappeared but it’s only the mount because I have the achievement and my transmogs too.

Yeah it just happened again when I switched realms also.


I think the problem is related to the xmog disappearing issue.

I logged on and my mogs were back; and coincidentally, the Soaring Spelltome is also back… Kind of annoyed if it’s the same problem because it’s been taking a long time for QA to replicate the issue to fix it.

Will pay attention over the next few days to see if they disappear at the same time.

Update 2:

Never mind. The mount only came back on one account, still missing from my second account (which was missing from the start). Seems to not be affected the same way as the store xmogs going missing.

1 Like