Trading Post - Known Issues and Updates

There are some issues that have affected the Trading Post and we wanted to provide an update along with where we are at in resolving them.

  • We are aware of an issue where the completion credit for activities in the Traveler’s Log is occasionally resetting. We are actively working on addressing this issue and expect to have it resolved this week.
  • Some players who complete the Traveler’s Log are not receiving the Ash’adar mount reward immediately in their chest at the Trading Post. We aim to have this resolved this week.

Thank you for your patience.


Please also fix some bosses not registering for 25 raid bosses. The first boss of ICC, the healing dragon encounter, the ship battle, and Lich king himself.


Ah, good to know. I can slow down on getting things done. :slight_smile:


I want to know where my Traders Tender is from

1 - Buying Dragonflight expansion
2 - Completing the Trading Post quest

I have reloaded, relogged, completely logged out for a couple of hours, deleted my cache and it still says I have 0 Tender and I am unable to get anything from interacting with the chest to get my reward from the quest.


Why does my total tender keep resetting instead of climbing toward the mount?

1 Like

My husband logged in, completed the quest, and opened the chest.

Got 0 currency.

Please fix :slight_smile:

He’s tried reloading, relogging, and swapping characters. Nothing has worked.


I did ICC tonight and all bosses counted for me. I did Dragonsoul, Ony, ICC and 4 bosses in Firelands for my 25. And the 2 Dragons for the /love the old dragons log item.

Can you also turn off toys and mounts around the area, or at least do some phasing?


Don’t thank us for our patience. We have lost our patience.

This is garbage.


This is what happens when the entire QA department in Albany unionizes

1 Like

log out, then log back in, this worked for me.

1 Like

I logged in and all my earned tokens are 0 now, lol I dont envy the folks working on this.


ya thats why i deleted my post ,it worked for me too.thank you i got my mount


I bought some things I shouldn’t of bought. Your refund button doesnt actually work…

what about the issue of not being able to collect anything from the chest? it just opens and closes and any quests dont give me currency either? also i have tried resetting my ui and nothing changes, tried waiting the 15 mins nothing, tried logging over onto other characters also nothing. can we please get a response about this bug?


earn 5k from AH is not giving credit :frowning:


also the meta achievement is calculated wrong saying i have 6/12

Don’t be a mechagnome and take a look see at the transmogs


thank Elune i got my treasures before this happened. :dracthyr_nervous_animated:

nice to see you guys addressing it …any bonus tokens you guys wanna throw in our chests would be amazing though :revolving_hearts:

1 Like

sounds like there will be patches to patch the patches tomorrow, friday and probably saturday.