Unable to claim Trading Post mount

Chiming in with a ‘same’ here; full completed bar, chest ungearable, message that says ‘You have collected all the rewards for this month’, no mount anywhere. :frowning:

1 Like

Add me to the list.

Completed progress bar. No mount, less tender than I think I was supposed to receive. Progress bar will randomly change from empty to full to empty to full on logging out and in multiple times.


I am currently having the same issue as well.

yep no mount but ive seen people riding it guess we are the beta test again they never have the bugs worked out before releasing anyhing


Same issue. Had only 100 trader cash in the chest, and no mount. Was supposed to be 500 trader cash and mount. Relogging, reloading, waiting… Still no mount or extra 400 cash.


Might as well add my name to the list. Put in a ticket already, but just got the standard reply sadly.

1 Like

I’m putting my voice into all threads about this issue until Bliz fixes this clown show roll out.

1 Like

Same issue.

Hello all. I’m here to add my voice to no mount. I did all the log off’s and on’s and jumped thru all the other hoops and still no mount. I even logged off overnight to come back today and still no mount. I hope Bliz is reading these posts cause I’d really like to have my mount. I just hope this wasn’t a waste of time.

Devs think they’ve figured it out


Same here. Just completed the required tasks for the Ash’adar, Harbinger of Dawn mount and only received 650 trader’s tender. So frustrating.

Add my name to the list. Didn’t even get my extra tender, I can’t interact at all with the chest.

Add me to that same list! Today makes 3 days that I have earned that mount and still nothing! Can’t claim any more traders token either! Blizzard I love you guys but this is getting old and we deserve some sort of bonus. But no we get to watch other people on there mounts enjoying them

Same issue here… Hopefully we’ll be rewarded.

Issue still occurring…

Thank God is not only me T.T

Yes, no tender or mount yet and done on the quests and finished the journal for the week according to it, tried logging out for an hour, reload ui, repair reinstall of the game, etc including making sure all addons were off. Nothing seems to be working so far. Hang in there everyone, hopefully a fix soon. Mine does not show that mount in the mount journal at all even as uncollected, it may be something else going on too. UPdate, after patch it is now showing up, so please do try again everyone. I think they fixed this.

Same here and adding to the many having problems with this badly coded BS. Only got 200 tokens when I finished the log last night and no mount. Now the chest does not even have the option to open it. The icing on the cake is that the mount does not even show up in my mount collections as collected or uncollected, like it does not even exist in the game. Guess I should have expected as much from the scuff patch day lasting longer with them saying “we will patch a fix for the trading post tomorrow” while the game was still down during the extended patch day, just to put the failed BS code into the game anyways just to appease the crowd, not caring if it was still broken or not. I bet if they waited that extra day, it wouldn’t be a problem like it is now. I also have attempted the many “work arounds” people have suggested, but still nothing. We shouldn’t have to do work arounds anyways. Guess we have to wait till Tuesday for a fix hopefully. I am seeing the downtime saying 7:00am PST to 9:00am PST for Tuesday, but we shall see if that’s the case, it hasn’t been for the last two reset days.

Side note, I get games have patch days that can last more than 2 hours, we should be happy they can patch and be back up in 2 hours most days, but having a known problem after being down for an extended amount of time, then just putting it into the game anyways, is just plan dumb. I would rather it not be put into the game to be worked on a little longer, than having a half completed feature that works for a small amount of people, and doesn’t work for most.


Same here completed bar and no mount. Please fix!