Trading Post Completion No Mount

Took some time but it finally showed up in the chest.


Having the same issue. 400 tender, no mount, and about 5 minutes later the bar reset itself to appear as if I’ve done nothing toward the monthly bonus reward.

1 Like

Having the same issue. Tried logging in and out, also waited a reset, nope. Opened a ticket, hopefully that helps…

If you are having an issue with the Trading Post, or the bar is resetting, or the mount isn’t showing, you need to file a Bug Report. Posting in Customer Support is not reporting the bug. Customer Support is a player-helping-player forum with Blizzard oversight and moderation. As fellow players we are unable to fix bugs. The SFAs who post here are not liaisons with QA who handle bugs.


Finished 1000 for the mount, got no mount. Did a couple more objectives on the list, no mount.

Can’t interact with the chest at all in Org or SW, so no more coins either.

Logged out for several hours, cleared the cache, disabled all addons, tried different alts, reset the UI, and still no mount.

I’m at my wits end. Just want the flippin’ mount that I earned already.

I submitted a ticket ingame that apparently didn’t go through just now. Tried twice. Also, the problem is on my other account, but for some reason, I can’t log in to the forums on that account. HELP please.


Tickets cannot help because the issue is a known and active one. Until the Devs fix it, GMs can do nothing on their end. You will have to wait and keep an eye on this thread. So please don’t get upset when they mark your ticket as resolved with the issue still standing - Devs don’t answer tickets and GMs do not fix bugs.


Same here took me all week to get this done and now no mount this is why i worked hard and I want my mount

You have a month to complete the event so there was no need to rush, but if you look at my post above yours, you’ll see it’s a known issue and they’re working on it.


It’s a bug. You need to file a bug report, not a ticket. A GM can not fix a bug. A GM is unable to award something without the Devs authorizing it. That is done through Bug Reports. As noted, Blizzard is working on a resolution.


Specifically, we do not have the functionality to award Trader Tenders, or any progress or rewards associated with that feature. Even if we did, it is unlikely we’d be able to help here, as that could impact any resolution that our QA and Game Developers are able to implement to help address the issue.

For now, it’s a waiting game. We have received all the reports about the various things that folks are experiencing and even if it isn’t specifically acknowledged in the thread that Bornakk posted, if you’ve seen it posted several times in the Bug Report forums I can pretty much guarantee that it is already being worked on.


Trading Post Completion No Mount same here what is the deal


Read the post right above your reply and you can see for yourself that they’re working on “the deal” :wink:


Could someone check on my collections and tell me if it is in mine as i cant find it anywhere and i cannot click on the chest to even collect the extra traders tender.

Not really. If it’s part of your collection you would see it or /cast the mount to use it. If it hasn’t yet been awarded, it won’t be displayed there.

One of the issues we’re seeing is that the mount isn’t immediately awarded as it should be. That is being worked on.

If you qualified for the mount by completing the Traveler’s Log, then you should receive it once the issue is resolved.


so you tell OP that you looked at his collection and it was there but telling me you cant look at my collection?

At the time this was originally posted the mount being missing was still an emerging issue. I checked for the mount and saw it, so let them know because it was likely an issue with looting from the chest, or one with their filters, as it seemed top already be part of their collection (something that was happening when the Trading Post first became active).

A lot of folks did receive it, it just took a little time for it to show up in their collection or, because of an issue with pulling items out of the chest, took awhile for it to be retrieved.

I can’t say with absolute certainty, but considering how these things are behaving, the OP’s issue likely wasn’t the same as what is happening now.

I did look at your collection, it wasn’t there. Which means it is almost certainly due to the current bug being looked into.

As these types of requests tend to snowball, and I wanted to discourage dozens of others who may also not have received their mount from making the same request, I wanted to provide details of what you can look for / how the system behaves, that you can look for (i.e. if it were part of your collection you’d see it or otherwise be able to /cast it).

I am sorry if you felt that I slighted you, Brisinger.


ok thank you for your quick response. I will wait until they get this fixed and check again. Thank you for everything


yea hope it gets resolved soon, was looking forward to getting it

So now today, all the tender that I had in my Trader account is gone. Me thinks they are going in the wrong direction LOL