Traveler's log reward random end reward

I finally finished the traveler’s log and was excited to go head to stormwind and grab that cat mount it told me I was completing it for.
Sadly the treasure that comes out of that chest only gave me 100 currency and no mount.
Is this like mythic + dungeons drop rate?
That cat mount being probably around a 10% drop rate/ chance to get?
Would have been nice to know that that reward was on a rng loot table like they do with Mythics since that shadowlands loot nerf, they did.
At this point I don’t really see the reason to run Mythics because running a full mythic dungeon and only to gain primal chaos is not worth it.
The joy of completing a dungeon and grabbing some gear at the end is the hallmark of an mmorpg.
Sadly it appears this is the way for the cat mount.

Alot of us had to relog to get the mount reward to show up in game, I hope this helps!

1 Like

Thanks, I will try to do that again. Crossing my fingers.

1 Like

Theres also more people that tried relogging and still didnt get it, me being onem even tried loggong out for 15-30mins and still didnt get it

To op, its a known bug. There is lots of posts about it on the bug forum, the place you should of looked at first before postings here

I just relogged and it’s now showing my progress back to 0 as if I never did it and the reward is that cat mount…
Should I re do the entire thing again?

I don’t even know how to check travelers log, that’s how much I care about trading post.

1 Like

Its in the same tab as dugg/raids preview.

I was about to make a ticket but at this point I am getting to the point of, why bother.

1 Like

I got that bug. Its a known one

Relog or logout and back in and it will fix itself.

Yeah … that didn’t work for me either… ah well i might check back tomorrow if I can be bothered >.<

Redoing the progress would require doing different activities than the ones you previously did as those would still be flagged as completed (e.g. if you used world quests to progress your bar entirely (hypothetically speaking) you couldn’t do the same again because that activity is marked as “completed” and you would need to find other activities to fill out the bar again.

This simply needs to be fixed on Blizzard’s end. It’s a really hot mess right now and it’s literally a coin flip as to whether or not you get lucky and complete the bar without issues or get shafted and have to wait for a bugfix.

Same, no Ash’adar but I did get 400 tender. While I was standing around in Stormwind searching through my mounts I saw other people in chat complaining about the same thing.

Step 1; Open Collections tab.
Step 2; Open Mounts tab.
Step 3; Click on big present box.
Step 4; Yell “Blizz iz the bestest EVER!!!”

Sarcasm aside; There is a bug, but I have seen this help.

I too opened the chest, only received 100 tokens, putting me at 1600 and no mount. Have tried relogging multiple times. Have tried logging on other characters. And I have checked my mount tab, and mail boxes. Nothing. When will Blizzard respond to at least say “We are aware there is a problem and are looking into a fix”?

They did.

100 tokens?

Pretty sure I got 1,000. And the cat mount.

Is it RNG for the reward ? Because that sounds like a truly terrible idea.

It’s not, that’s a bug.

File the ticket. Takes five minutes. If nothing else it’s a paper trail.

Update: I just got back on last night and the chest finally gave me the mount reward after all this time.
Thanks for all the replies.