Trading post chest!

3 days now and still have this issue, no word from Blizz?

I also just tried an Alliance Character and got the same results.

Same issues not being able to collect any trader’s tender from any source. Chest does the animation but doesn’t give any currency.

@Blizzard can you guys give us an update? I think most people would just like to know that you guys are aware of the issue and working on a fix.

Yep, I finished the goal in the traveler’s log and spent the total 2k I made. Left to 50 tenders. Anytime I stopped by the chest it was glowing and says it gave me tenders but none show up, I am still stuck with 50. Kinda a huge tease to say we received a tender and not show up in our currency to use.

I tried on multiple alts just Incase that would work. Nothing. I then on my main did all 1,000 points in a few hours. Thought maybe that was what I had to do. Nothing. I hover over the currency which is at 0 it says you have rewards in the chest. I logged off and on. I did everything I could think of. So I sent a support ticket because clearly this is a mass screw up.

I also talked to people who had the mounts. Nothing came of that. Seems to be random. I paid for one year if game play awhile ago and I am supposed to get 500 currency each month and after doing the quest it rewarded me the 500. Yet apparently you get it from the chest and thus I never received the monthly 500. So I think I am down 1500 trading post currency for no reason but I was unlucky.

Hopefully Blizzard will fix this and credit us who haven’t received anything.

Same here, completed all the activities for the mount says I collected all rewards… and all I was able to do was loot the chest but no mount only the tender / currency. This is rather disappointing.

1 Like

Had just successfully looted the chest about 10 mins ago - quickly spent the next 10 mins getting the last few coins to get the mount, came back and im unable to loot the chest at all - /reload didnt do anything other than prevent me from mounting up (even outside the TP area)

You’re not alone. It’s bulls&$t

My trading post chest isn’t interactable at all, despite there being several rewards I have yet to collect, including the final monthly one (the mount, I believe). I got up to 1700 Tender with the initial quests and then a few tasks, but after that it stopped working.

Hello. I can’t redeem any item from the trading post, I already have the mount, but at least the bow and cane, it won’t let me buy it. I thought maintenance would fix it, but no, nothing has been fixed.

Still unable to loot the chest at all after 7 full days.

I have done everything I can on my end, full reinstall even. Please give us an update for those of that have not been able to loot the chest at ANY point!

Just check the progress in Adventure Guide, it reset back to 0%. Got to 100% on Sunday but didn’t get the mount. Guess we gotta grind to 100% again!!!

Full UI reset does nothing in this case.
Did it and still doesn’t give me any extra from the box, like the mount this has to be fixed/patched by blizzard.

I bought 3 items last week: the bow, the ogre pet, and the see through horse.

Completed the 1000 point achievement and had to put in a bug report since the mount never came.

After the patch/fix I got Ash’adar late.

By the end of last week I had 150 tenders left.

When I went to the box this week nothing was reset however it says it is giving me 500 tenders when I open the box.

When I look I only have 150.

I have done this on my two level 70 toons same results.

It’s wild that this is still an issue.

1 Like

So I had the same issue as above, waited the 6 days for my ticket to be responded to only to have it say there is no fix.

Out of the blue I decided to make a new character on the opposite faction that I had been trying to loot the trading post chest from and it actually worked. I made a Vulpera and clicked the random name generator and was able to loot the chest in Orgrimmar. I was alway trying to loot the chest in Stormwind. the only thing that was not included in the chest was the 500 tenders from the quest since i did the quest on a different character.

Still bugged for me today. I just wish Blizz would let us extend the time we have to buy things from this first month :frowning: Seriously killing my motivation to farm for the trading post.

i think Blizzard DGAF about testing or fixing bugs anymore … what’s the point of having a bug report forums if Blizzard don’t reply. even if they say something like “we know about this but have no ETA on a fix” would be fine but it’s crickets form blizzard

The above posts were in February. Now it is March and we are having same issues again. Chest opens but gives no tender, currency saved in February = zero, Traveller’s log completed but no tender allocated. This means that the problem has been known for a month but not fixed and it is pot luck whether an account gets it or not. The worst is that there is little official information about this problem.

Chest was only accessible once for me for 500 tenders, after that, I cant interact with it at all…3 days now of not being able to click on it. Even log was not giving us the 100 tenders for each milestone on the bar.

1 Like