I just completed the 1000 travelers tender monthly for the mount. Not only is the mount no where to be found … but all of my travelers tender progress just resset … like wtf …is this some sort of joke?? Im being 100% honest here.

The progress doesn’t actually reset, it just doesn’t display properly. /reload fixes it for me.

As for the chest, it’ll let you open it and reclaim any rewards it failed to give you after relogging.


What Green guy said.

With that said, i do agree it shouldn’t happen though. Hopefully they get this fixed. Can’t imagine somebody grinding this from 0 to 1000 in one day, had a bad DC, and then that looked like it reset. That be a quit moment for them.

I relogged and still can’t get the mount. I opened a ticket all I can do is wait.


I reloaded ui a dozen times nothing is working and relogged

Naturally. Though I believe Blizz posted that they’re looking to have it fixed with the reset, so hopefully the Post’s growing pains are nearly over.

1 Like

Explain to me how i can complete the 1000 requirement not only did i not receive the mount but my progress then reset to 0 after a relog???

Because it’s bugged. When they fix it, you’ll get it. Maybe when you log for the night, it will register tomorrow. Yeah, I know it sucks, but you’ll still have your credit and reward when it’s fixed.

Yes it does suck lol

This is something I’m taking from the dev of another game, but I think it very much applies here:

“The content gets more testing in the 1st couple of hours of being live, than the entire beta cycle”


Well, it looks like it’s time for another MAINTENANCE! Get out your popcorn!

A great many people (including me) are having a problem getting anything from the Cache or showing any progress in the trader UI. Seems ok in the traveler’s log UI which is weird.

It’s all over the Bug Report forum with lots of angry folks. Hopefully they get it fixed. Be patient as i am trying to be. Good luck.

I assume you did check but just in case, the mount isn’t an object in the cache/chest it merely shows in your mounts window needing to be unwrapped.

Ahhh… good ole Blizzard. They never fail to disappoint, even when implementing a vendor.

Still, it’s nice to see that the Cartel Market - I mean Trading Post exists. I imagine that they should get all of the bugs worked out but August, maybe?

I wonder if they’re keeping logs of everyone who completes the traveler’s journal and is owed the mount, and their fix just sends the mount out to all the players.
Or if they’re going to announce its fixed, but tell us to submit tickets to restore the item.

same for me i finished the monthly and says i received all loot but i haven’t, tried re logging nothing, tried different toon…nothing put in a ticket.

A dozen threads about this yet no one bothers to simply look before ranting.