Not Receiving Ash'adar, Harbinger of Dawn

logged out over night and submitted a ticket but still no mount sadly :frowning: no tender either. when i log on it shows my bar being empty and then when i reload it shows that i collected the reward for the month which i did not. i think maybe thats why its happening? bc its confused and resetting my bar?

still no mount after 10 hours… Log in and log out doesn’t work.

Same here… opened chest got 400 tokens… no mount…

Tried to logoff for a while… no change…

I didn’t get the tokens or the mount. Logging out for a few hours and back in didn’t change anything.

same here this morning, no bonus and says Ive completed this month!

Thank you, Cksum! I can be pretty patient if I know someone cares enough to fix the issue. hehe So glad they are working on it!

Blizz has acknowledged this issue and are looking to have it resolved “this week” - Trading Post - Known Issues and Updates

Same thing there. I completed the journal for the month and no mount when I opened the chest.

Same thing, I completed my quest today and the chest doesn’t even glow

Same story as everyone else, completed, no mount

same here! :frowning:

Same, will try your fix. So far, nothing.

i didn’t get the points and the mount after complete the mounthly bar of 1000

Filled bar, went to chest got tender. No mount. logged off and stayed away about 10-15 minutes and still no mount.

Same as everyone else. I completed my the bar and went to the chest… no mount.

I finished the quest bar and nothing, I’ve tried the logout and back in trick and nothing. I’ve even tried exiting completely and logging back in and nope. This isn’t cool when you complete something and know people who have gotten the mount and tenders but you haven’t. C’MON BLIZZ CREW HELP US OUT HERE!

1 Like

Completed, waited, logged out for the night, still nothing in the chest this morning. I love this feature.

Logged out for a full 24 hours and I still have not received :frowning:

Same issue. Finished bar, chest gave 900 tendies and no mount. Was logged out for 30min and checked again, still no mount =/

Update: I now am also showing having Zero tender. Went from over 1000 to none

Same issue, the log out method did not work, bumping along with every other sap in here stuck in the no loot boat


Same issue. Only got Trader’s Tenders. No mount. Logged out for a half hour to try and fix it. Did not work. Guess I will have to put in a ticket.

1 Like