Not Receiving Ash'adar, Harbinger of Dawn

Same issue as everyone above - filled the bar, chest not available for all rewards, no tiger mount :frowning:
Edited to add: I am also short-changed 400 currency and I can’t find the rose corsage I bought either.

Still nothing this am. Automated response to submitted ticked. Resubmitted ticket… Wish a blue would address this issue.

I also haven’t received the mount. The chest cant even be opened for me. I finished the 1000 last night and read this post and decided to just try again in the morning but the chest still cant be opened. Also when I first logged in the progress bar was reset and showed no progress. It went back to full after refreshing the UI.

Same here, i did not recieve the mount! What am I suppose to do? (i logged out yesterday and logged again today and the mount still not earned. :frowning:

Really not much effort goes into Twitch drops. Pick a stream, shrink to taskbar, and go play WoW, or cut the grass, or go to work, or go to bed (what I do), you get the point.

Now, getting the drops can be a problem, it took 22 days for my Feldrake to show up. Not a good look for Blizzard, but has become what I expect. I am also having same prob with Ash’adar. Wife and I did quests together, completed bar at same time, she got the mount, I didn’t. That was yesterday evening, and I still don’t have the mount.

Blizz has acknowledged this issue and are looking to have it resolved “this week” - Trading Post - Known Issues and Updates


I had a ticket responded to that Blizzard is aware of the issues of not receiving the mount or traders tender and are working on a fix.

If it’s not working for you they’re actively working on a fix. Sadly i’m in the same boat so… Guess i’m waiting for a hotfix but, at least we’ve got confirmation they’re aware?

(UN-doing that last bit, didn’t read the post right above xD)


logged out over night and submitted a ticket but still no mount sadly :frowning: no tender either. when i log on it shows my bar being empty and then when i reload it shows that i collected the reward for the month which i did not. i think maybe thats why its happening? bc its confused and resetting my bar?

still no mount after 10 hours… Log in and log out doesn’t work.

Same here… opened chest got 400 tokens… no mount…

Tried to logoff for a while… no change…

I didn’t get the tokens or the mount. Logging out for a few hours and back in didn’t change anything.

same here this morning, no bonus and says Ive completed this month!

Thank you, Cksum! I can be pretty patient if I know someone cares enough to fix the issue. hehe So glad they are working on it!

Blizz has acknowledged this issue and are looking to have it resolved “this week” - Trading Post - Known Issues and Updates

Same thing there. I completed the journal for the month and no mount when I opened the chest.

Same thing, I completed my quest today and the chest doesn’t even glow

Same story as everyone else, completed, no mount

same here! :frowning:

Same, will try your fix. So far, nothing.

i didn’t get the points and the mount after complete the mounthly bar of 1000

Filled bar, went to chest got tender. No mount. logged off and stayed away about 10-15 minutes and still no mount.