Issues with Older GPUs

For the last few expansions, World of Warcraft minimum specs have required a Graphics Processing Unit (GPU) that is shader-model-5 compatible (DirectX 11.0 or higher). With the newer graphical features included in the Shadowlands Pre-patch, the game has ceased supporting all GPUs that are not compatible with shader-model-5.

We’ve discovered that a very small number of players are attempting to run World of Warcraft on older hardware that cannot play the game after patching.

At this time, we’re working on a solution that could allow the game to operate on some older hardware, at the lowest graphical settings, with some graphic features unavailable. We expect this solution to take at least a couple of weeks to develop and test.

We will let you know when this workaround is available. Thank you.


Thank you for the update! Is this related to why while creating a new horde character, trying to experience exiles reach I am unable to see the “boat”?

1 Like

Likely not, this involves people getting an error message when launching the game stating their hardware is out of date. The people affected by this can’t even get in game.


Thats is realy great to hear, thanks for the effort,its realy important that we can run tha game in older hardware,Im playng The game almost by the launch, and I ever played in low profile hardwares, only now I have the chance to upgrade my PC and play at 4k res, but I have a old notebook where I play when Im out of home.


I really hope that you guys find a way to make the game run in older hardwares, otherwise, i’d probably will stop playing.


Pois bem meus caros estou com o mesmo problema, o jogo ficou totalmente travado após a atualização, impossível de jogar. Gostaria de saber o que a Blizzard irá fazer, pois tenho 4 meses pagos ainda e não poderei usar este tempo já que o jogo não roda mais em meu pc. Poderiam ao menos congelar o tempo de jogo ou transferir para créditos na Conta do Jogo.

1 Like

It is regrettable that a Community Manager from a company like Blizzard from a response like this, “a very small number of players are attempting to run World of Warcraft on older hardware that cannot play the game after patching.”

Probably he didn’t see hundreds of posts reporting problems after the update, I saw posts from users with i7 with a 2080Ti with problems …Others with problems with crashes, slowness and more…

I personally before the update I run BFA with 2 (TWO) SIMULTANEOUS WOW ACCOUNTS WITH A CORE I5 2500K (TWO) that uses Intel Grafics 3000, after the update HE WAS NOT RUNNING NONE . And another garbage pc that I have here with the Pentium G2030 processor just for having the Intel Grafics 4000 runs the game I came to the conclusion that the Game started to block the cards by the driver and has no connection with resolution or technical issue, unlike tests in the passmark of an intel graphics 3000 to 4000 they are only 50 points (thing for laymen with less than 4% of graphical improvement). Boards with components that should technically run the game have been blocked and do not receive “authorization” to start the game. It is a lack of shame in the face, not a technical problem.

and then I ask the friends of the forum? was it or wasn’t it on purpose ???


unfortunately wow walks to a bottomless pit where the company itself is burying it there…

but probably the two bills that I pay every month are not so relevant, after all I am only part of a very small portion of consumers who play


Will this fix make worgen eyes look normal, or are the LED eyes displaying “correctly”???

1 Like

Thanks for the update.

We’ve discovered that a very small number of players are attempting to run World of Warcraft on older hardware that cannot play the game after patching

Hehe. :joy:
Thousands :slight_smile:


I can say that I’m one of those people with the 3D acceleration pop up message (and that tried everything possible) locking us out even of trying the new login screen, and that has old pcs. I sent an ‘exceptional ticket’ yesterday, got a response pointing out to this thread, that they we’re working on something that would let us poor PC guys try the game without some graphical improvements, but try the game at least.

At least they’re trying I’d say.

Yeah they’ve post the minimum requirements way back then, but figure out if we all could have managed new PCs with the pandemy and all the issues it had bring with it (lay offs, people losing jobs, even at Blizz the situation is hard to some as we saw).

1 Like

Ardrakume has sent a ‘workaround’ for those people with the issue. This will put your CPU working at very higher % than usual, but you’ll still be able to open the game (but very laggy). I’d advice this at least so you can grab the mail, AH, on all your characters. And wait a bit more for them to get up the update.

Include this on your Wow.exe shortcut’s properties (shortcut tab> ‘Target’ field) at the end, a space after the last "

Original poster: [Oct 13] Main Thread - Shadowlands Pre-Patch: 3D Accelerator Card Not Supported - #105 by Aopa-azralon


I still do not understand this. Let us say, a new expansion is coming and blizzard say hey! you need this later gpu to play the new expansion. Then i say ok, i cannot play the expansion. Is ok, i don’t buy it and play vanilla/cata/pandaria/legion/wod/bfa like i always play. But no, now i can’t even enter the game. So, if i have not the GPU required i will not be able to play the game and the zones i have always played?


It is because it is an overall improvement in the graphics for the game. It doesn’t matter what prior expansion that you are trying to play. It is for the the entire game. Although you are heading into the older zones, the character models, including yours, is using the newer graphics technology.

Just wanted to confirm this method. I was getting the 3d processor not supported by WOW as well. And now i can enter the game. It looks like im playing minecraft lmao but i’m able to play around with friends and stuff for now. Even did a BG :slight_smile:

Yeah, i suppose Arathi mobs have way more graphics than BFA Raids. They redo the entire game.

Its not the models themselves. It is the new technology they are using to render everything.

My laptop is exactly one WEEK old and I am having this issue with this update. W T>>F!!! this is a problem with laptops, it is wow’s problem to fix. Something is very wrong here.

DX11 / shader-model-5 is something like 10 years old. Extra credit to Blizzard to trying to support hardware that old but at some point it becomes counter productive to keep spending on outdated infrastructure for both end consumer and services providers.

Meanwhile, I suspect there are issues reported in this thread that are something else entirely.