[Jan 2024] Co-op Commanders reset to level 5

I have owned Raynor for years and have played him to Prestige 3 with 117 Ascension points, but when I logged in this afternoon he’s been reset to level 5 rather than 15 even though the page still says that he’s level 3 Prestige with 117 points. Half of the updates are grayed out because he’s level 5.


Same here. All commanders are “capped” at level 5.


yep me too but on kerrigan. i think it’s only for the three that come free because with mengsk and others it’s still my higher level


Same here. I’m back to level 5 on all the free commanders, Kerrigan, Reynor and Artanis.

Same here, I assume widespread. Logging out does nothing.

Same Her. I try to logging in many times. It does not fix itself.

This worked for me:

Blizzard Support - Deleting the Battle.net Cache Folder.

Hey all,

Thanks for all the reports on this. We restarted a back-end service that should resolve this problem. Please restart Starcraft II and check your commander levels again, they should be restored.

Edit: Latest update below

Same issue with Raynor, Kerrigan, and Artanis

I’m not seeing this fixed after restarting everything. Raynor, Kerrigan, and Artanis all still demoted to level 5.

Mine’s still not fixed, Raynor, Kerrigan and Artanis.

Similar problems, unsolved by restarting computer.

Same as everyone else. Have tried the reported steps to resolve and still not restored.

Same issues as everyone else. Raynor, Kerrigan, and Artanis all reset to 5. I played a single game on co-op with Raynor to see if that would reset the level and of course it didn’t.

I also tried deleting the cache, logging in and out, uninstall and reinstall, etc. but nothing has worked. It did say that Raynor was capped at level 5 unless i purchase.

I noticed this issue as well last night and it is still not resolved on my end, Kerrigan, Raynor, and Artanis are all capped at level 5.

My issue resolved overnight. I did go into the ProgramData folder and delete the Blizzard Entertainment folder yesterday, then restart my machine. When I logged back into SC2 though it seemed to have had no effect, Raynor was still 5. I submitted a ticket yesterday then logged back in today and Raynor is back to normal. I will post the fixes that the Blizz agent suggested although I’m not sure what exactly fixed my issue.

"Hello there ****! Tech Specialist Ektiledil here, and I’ll be the one reviewing your ticket today. Thanks a bunch for reaching out to us, hope you are doing well.

The issue with Starcraft II Co-op commanders reverting to level 5 can indeed be caused by an in-game bug, but often times it can be connection related. If you haven’t already, please try the following:

• Power cycle your hardware. This can help with some basic connection issues.

• Try a DNS flush, this should clear any saved cache and resolve basic connection issues.

• Temporarily uninstall Express VPN software.

• Try clean booting Windows. This will disable all applications running in the background and should rule out any possible software conflicts.

  1. Press Windows Key+R.
  2. Type msconfig and press Enter.
  3. Select Selective startup and uncheck Load startup items.
  4. Select the Services tab.
  5. Check Hide all Microsoft services.
    Note: Skipping this step may prevent your computer from rebooting correctly.
  6. Click Disable all, then Apply then click OK. And click Restart.
    • Try creating a new administrator account and test to see if the issue persists on this new account:
    • Try using an alternate connection such as Mobile Hotspot, if you have this option. This can help us narrow down the issue further."

Really disappointed, my friend was playing Kerrigan last night with no issues. today his character has been reset to level 5. he thought that was because he didn’t purchase the full campaign collection. So he immediately paid the full campaign collection but was shocked that was the game server issue. Now he ends up paying for the game but still has the level 5 Kerrigan all night…

1 Like

Likewise, I tried this fix and nothing worked. I submitted my own ticket because it seems that is the way to get this fixed.

Unfortunately, it is indeed a bug that surfaces a couple times a year.

If your friend just bought the campaign collection and hasn’t played the paid content more than two hours, they can ask for a refund here from their account (click the “Continue” button if one appears):


That is an automated system that may reject the refund. If it does, the rejection page will have a link near the bottom that they can use to submit a manual refund.

1 Like

I am having the same issue. It is frustrating. I’ve tried the recommended steps listed above, but it has not restored it.