Auction House Issues

Update on 1/16/2020 at 19:00 PST
Here are some additional issues that we have identified and are actively investigating:

  • When items are returned in the mail from the Auction House, it can incorrectly contain more stacks than the displayed maximum of 16. This makes it look like some items are not being delivered. You will know if you are experiencing this if a mail appears empty but can’t be deleted.
    • To retrieve the missing items in this scenario, take out all 16 of the displayed stacks, then close and reopen the mailbox to see the rest (you may need to repeat this several times).
  • If a character buys commodities in high quantities, they may not be able to access their mail.
  • The favorites list is not saving properly.
  • We have resolved some of the issues causing the “Internal Auction Error” to pop up, but it is still occurring and we are continuing to look into it.

We’re aware of and working on a number of issues with the new Auction House:

  • The Upgrades Only filter can show some wands and shields that are not upgrades.
  • While selling certain items, non-related pets will sometimes appear in the list of current auctions.
  • Players are sometimes unable to buy out an auction in which they are the highest bidder.
  • Sold auction rows can disappear from the Auctions tab.
  • Sold auction rows can display the wrong quantity sold.
  • There is no chat notification when an auction sells.
  • The Uncollected filter can show owned battle pets.
  • While selling a caged pet, the price columns are misaligned in the list of current auctions.

  • Some players have experienced attempting to cancel an auction that has bids enabled, but no bids yet, and receiving an incorrect warning that they will be charged an extra 5% penalty. This penalty message is only meant to be shown if there’s an active bid on your auction. If there is not an active bid, you can safely proceed with canceling, and the penalty won’t be applied.

We’ll continue to investigate all of the above and develop fixes wherever possible. If you’re experiencing any issue with the new Auction House, we suggest you first disable your addons and try again.

Thank you!

4 Likes

What about the internal error bugs when posting goods to the commodity exchange in a large quantity?

12 Likes

Not auction house but mail related which is affecting my auctioning. When I go to start typing another chars name and the list appears of toons no matter what one I click on it auto uses the top one. Which makes me have to type char name every time.

5 Likes

Any timeline on a fix for “Internal Auction Error” every time we try to post or scan the AH? It’s basically making any large-scale AH posting completely impossible.

6 Likes

I purchased a large quantity of linen - only received a portion of it, but was charged for the full amount.

After putting in a ticket - the GM couldn’t even find the transaction for the sale, even though my gold was taken and I had collected some items from the mailbox.

Both the GM and I put in a bug report for further investigation.

Not sure if this is tied to extremely large purchase amounts that may not have been anticipated.

I’m literally unable to post about 80% of the items I try and post. It goes through and looks as though it has accepted the posting and then the item is still in my bags. It’s been happening mostly with old world crafting mats like the Volatiles of all elements, ores, herbs, etc. I even tried just posting some current BfA greens to see if those would work, and they didn’t work either. I’ve tried logging and have tried multiple toons and it’s happening across all characters.

20 Likes

Think of it as a blessing in disguise. If you post large quantities to the AH and they expire, then not all of them are returned. It only gave me the first 16 stacks of the expired items. Ugh!

Using the new AH system also seems to prevent you from character transferring, so be warned of that.

7 Likes

So when I purchased more than 16 stacks of a commodity, the mail initially only showed 16 stacks. I had to then exit the mailbox and reopen the letter to get the other stacks.

Does that work for you? Or are they just gone?

What if you exit the mail UI and reopen the letter?

My favourites list gets wiped every time I relog.

9 Likes

Blizz may have created the “WoW Killer” all on their own. I can’t use the new AH.

4 Likes

I posted 4000 zinanthid before i slept, when i woke up its at 1990, yet there is no gold on my mail, is this also a known issue?

EDIT: Now it happened again, i reposted 1990, after checking for an hour its now at 690 without any gold in mail or auction sold notice

Someone might be exploiting the auction house, i sold a lot of stuff on tues/wednesday and it was fine. Someone mightve discovered a glitch to steal mah stuff

8 Likes

My mail just stopped working completely after i bought roughtly 160k tidespray linen(318k gold). After talking to a gm he was able to fix the mail, but i only received 13k linen, leaving me at a massive loss, i contacted them again and the last response i got is that i received everything i had bought! And that’s where i’m at right now, trying to at least get my gold back.

I posted around 360 or so Anchor Weed on the AH to sell. It is no longer there and nothing in the mail. I looked at the Anchor Weed listing and my herb is not even listed.

6 Likes

I’ve had thousands of G worth of sold auctions disappear over the last couple hours…and no gold shows up in the mail. How will blizzard fix this?

3 Likes

Yesterday, my main got dc’d in Northrend Dalaran after buying an item from the AH there. She was stuck in limbo for quite a while–I could log in on other toons, but not her. Today, I got the message that Northrend Dalaran AH was unavailable, but Org was working.

Losing items on AH isn’t acceptable, but I’ve never lost my toon in one before.

Yeah this is more than just a server mail lag, there was literally no auction sold on my AH listing when the items disappeared, there should at least be a listing on sold auctions for an hour in the AH ui. So i think this isnt just a mailbox lag.

1 Like

Yea, just noticed that the same thing happened to me. An hour ago I had 163 Anchor weed in the AH, now there is none. :unamused: Hopefully the server reset that is about to happen is a fix for it.

5 Likes

I’m having this issue as well, it’s been pretty annoying