[Main Thread] Version Mismatch, Region XX-07, Battle.net is Down for Maintenance - Can't Play or Login after Patch 5.0.0

I reinstalled my game. Now it is working.

Thx worked for me too.

I have had the same problem. Although I play at work, and need to back off. I’m an addict.
What is a good alternative to SC2. I like the fast paced strateg.

Just for the topic count: Same problem here NL (Europe).

Same issue. There’s not even a region to select. My only region showing is xx-07.

3 Likes

Hey, all! Thank you for your reports and for those sharing what’s worked! This error is typically caused by going to a region that had the update pushed, then going to a region that doesn’t have the 5.0 update yet. Sometimes, it will go away on it’s own, but I wanted to compile a list of what’s been helping other players.

  • Switch to the Beta Launcher.

    1. On the Blizzard Application, go to Settings by clicking on the Blizzard logo at the top-left corner.
    2. Under Settings, go to Beta.
    3. Click on Switch to Beta.

    To undo this, you can go to the same place on the Beta launcher and clicking on Switch to Standard.

  • Delete the PTR executable.

    1. On the Blizzard Application, go to the StarCraft II tab.
    2. Click on Options :gear: then Show in Explorer
    3. Under the Starcraft II folder, delete the StarCraft II Public Test(.exe) file.
    4. Try launching StarCraft II.

    If you do not have the Public Test file in the StarCraft II folder, try checking if you have the PTR installed and try deleting the file from there. If the PTR is not installed, please try the other two steps listed here.

  • Reinstall Starcraft

If there’s anything new that works, please feel free to share and let me know so we can get this added on here :slight_smile:

If the problem persists after these steps, please let us know. If you can include the region, it should let us know if the region may not have patched to the new version yet or if there’s something else we’ll need to look into. As of right now, we’re still awaiting for the CN region to receive the update.

1 Like

For me the PTR executable that i deleted was in regular starcraft folder i hadn’t installed the Public Test Realm version so didn’t have that folder.
The folder in program files /starcraft 2 had both the regular “StarCraft II.exe” and “StarCraft II Public Test.exe”

Similar problem for me - except my launcher showed v.5.0.0.80949 installed and that didn’t matter. The solution mentioned by DozedMenace to zap “StarCraft II Public Test.exe” fixed the issue, TY :d. Trying other servers, Scan & Repair, and rebooting did not help.
Fortunately I resisted the idea to R&R the entire game.
Very strange issue.
I had never once switched regions from American servers, however I was playing the game at the time when I believe the update was pushed out, and got the error “no servers available” when I tried to immediately play another match.

Strange! I’ll update the post above to include to check both folders. I’m not sure how that ended up there, but I’d assume that would definitely cause the issue if the PTR file was in the normal SC2 installation. Thanks for sharing :slight_smile:

same issue here even the patch is updated.

Anyone have solution?

This is fix. just deleted the “StarCraft II Public Test.exe”.

thanks everyone!

Same thing here but the issue is I lost the progress in the COOP. All went to 0!

Also in the regular folder here.

Only thing i can think of is maybe you have selected wrong server from where you normally use.

Deleting the PTR helped me, thanks :slight_smile:

delete Public Test.exe this fixed it.

i cant connect to online after latest patch, will not recognize region says xx-07 only

8 Likes

Try reinstalling the game. It worked for me.

reinstalled and still not working, it says battlenet is down

1 Like

same problem here… reinstalled also and no go. says battlenet is under maintenance but it was yesterday…