[Main Thread] Version Mismatch, Region XX-07, Battle.net is Down for Maintenance - Can't Play or Login after Patch 5.0.0

I can’t start the game anymore it just says there is a version mismatch, I understand that 5.0 has been released but I’m unable to update to it.

My launcher is still stuck on 4.12.1.80188, tried restarting launcher, delete game reinstall, full scan and also check update.

5 Likes

Hey there,

Can you try rebooting your PC and power cycling the network if you haven’t done that already?

If it’s still not updating try a full reinstall of the Battle.net app.

I just tried full reinstall of the Battle.net app and uninstalling game to do full reinstall again, still stuck on 4.12.1.80188.

Update: Fixed by switching to beta launcher.

I tried a full reinstall also and still not working says the same thing. I dont know how to do the beta launcher

go to setting, under beta, click switch to beta.

my friend is having this issue and i have ran the repair and switched to beta yet nothing has worked. We have restarted his machine a few times too. he did forget his password but reset it with no issue. When we log in all we get is cant play online then his region says xx-07

5 Likes

i was having same issue after some time reading and trying stuff i looked into the installed game folder and deleted StarCraft II Public Test.exe seems to have done the trick.

11 Likes

Can confirm I had exactly the same issue and deleting the Public Test.exe fixed it.

4 Likes

Yup removing the Starcraft II Public Test.exe makes the game work now. Thanks!

4 Likes

Hi, I’m also having this same problem already tried to full reinstall battle.net app, the game shows version 5.0.0.80949PTR is there a way to move to the “production” version?

I’ve been having trouble too yesterday but I just removed the Starcraft II Public Test.exe and it finally fixed it for me as well. Thanks all.

2 Likes

Hi, from where did you remove .exe file? I had to install the PTR version in order to launch the game but in doing so I lost all my progress in multiplayer and campaign so PTR is not a solution for me

Found it fixed, thanks

Started SC2 about 20 min ago and it ran the latest patch (5.0.0).

Now I can’t play the game - I keep getting the following error:

Game client version mismatch with selected region. You may be able to continue playing if you exit the client, patch from the launcher, and restart.

As far as I’ve heard all regions have been patched appropriately . I cannot play in the Americas.

7 Likes

^ This…Never seen this before now

1 Like

Same in Canada, mismatch, can’t login after downloading patch 5.0.0

2 Likes

Same here, cannot login. Tried repairing with no change and no change when I attempt to update manually.

Tried in Americas too, says the region is set to “xx-07” and I’m unable to swap it. Tried restarting pc, scanning files, checking for updates

3 Likes

Currently re-downloading, 2 hours to go. GG

Ok so I re-downloaded, and it seems to be fine, it logs in fine now, now to try and play it.

Same here.
I get " Version MISMATCH" Game client version mismatch with selected region. you may be able to continue playing if you exit the client, patch from the launcher, and restart.

I have tried all that i know and still nothing. This happened after the Patch 5.0.
I need HELP to fix the problem the patch created because i cant play at all.

Ps. I can play in the Asias Server because it uses the old patch but cannot login in the Americas Server.