Unable to move cursor in game (Workaround)


#1

WORKAROUND 1
-------------------------------------------
Enable HoTS in Accessibility:
System Preferences > Security & Privacy > Privacy > Accessibility
-------------------------------------------


WORKAROUND 2
-------------------------------------------
Disable Confine Mouse Cursor:
From within HotS Settings > Mouse and Keyboard
From the Confine Mouse Cursor drop down select ‘Off’
-------------------------------------------


ISSUE
-------------------------------------------
After today’s patch, I am no longer able to move the cursor in game.
It is not limited to the display of the cursor location; clicking moving the mouse and then clicking again does not change the location of the click.
I am able to move the cursor in the menu as long as the screen is ‘windowed’ or ‘windowed (fullscreen).’ If set to ‘fullscreen’ the cursor does not move in the menus either.
This issue persists with both an external mouse and the internal trackpad.
Basic troubleshooting; re-launch, restart does not resolve the issue.

Heroes of The Storm Version: 40.0
Heroes of The Storm Patch: 2.40.0.70200
OSX Mojave: 10.14.1
MacBook Pro Retina Mid 2014
GeForce GT 750M 2048MB
Intel Core i7 2.5GHz


My friend got a leaver tag for a HotS bug. Pathetic
#2

Same issue, clicking inputs works but the cursor won’t move at all.

Also on Mojave 10.14.1 on a mid 2015 iMac.
The patch didn’t fix the streaming client issue either, so the client is kind of a buggy mess as a whole right now.


#3

Same issue, mouse doesn’t move at all once game is launched. External or trackpad (have to restart just to get out of the game).

3.1 GHz Intel Core i7
16 GB 2133 MHz LPDDR3
Radeon Pro 560 4096 MB
Heroes of The Storm Patch: 40.0
OSX Mojave: 10.14.1


#4

I just wanted to chip in and say I too cannot move the mouse in game at all. Mouse works fine outside of the game. Neither trackpad nor external mouse are working. I am on Mojave 10.14.1 with a 2016 mac book pro. Only started after todays patch


#5

yea people report it on reddit too. mac version needs to be fixed ASAP


#6

Hi there!

This is something that we’re currently looking into at the moment. From what we’ve found the cursor does seem to work in windowed. While its more of a workaround than a fix, please switch to windowed using Command + M.

Doing some more research on this, the issue itself looks to be related to accessibility permissions. For that you’ll want to go to System Preferences > Security & Privacy > Privacy > Accessibility. If Heroes of the Storm is listed here, make sure it is checked. If the game is not listed here, you can proc the permissions prompt by checking the Disable OS Keyboard Shortcuts option in the Mouse & Keyboard settings of the game. This would need to be done in windowed mode.

If that doesn’t help, please post the version of OSX that you’re on. Will provided further updates as we get them.


Mouse doesn't work after update
No mouse control in game (mac)
Can't move mouse in game on Mac with OS Majave system and the new patch of Orphan
Mouse Cursor Broken
Latest update pretty much broke Mac Clients
Mouse not working - game unplayable
Mouse does not work after latest patch - MAC
Mouse frozen on a Mac (again) >:(
Mouse issues in game
Mouse bound bug? macOs
Mouse not moving in game for mac
Mouse and keyboard didnt work
Account seems corrupt, can't move in game or select anything just on that account
Mouse not moving after patch
Mouse cursor won't move on Mac ingame
Mouse doesn't work for Macs. Cannot play game
Confine Cursor Prevents all mouse movement
Mouse Cursor Not Moving In Full Screen Mode
Mouse doesn't work
#7

i’m on 10.14.1 - standard Mojave update. Windowed mouse works fine - I can play games but fullscreen mode, mouse still completely frozen.


#8

Same here. Reported this in the PTR bug forum a week ago. Ugh.


#9

Same. OSX 10.14.1 (18B75). Windows fullscreen seems to work.

Scratch that. Windowed fullscreen works until your actually in game.

Edit 3: Windowed fullscreen works with Confine Mouse Cursor set to off.


#10

I am having the same issue. I am on Mojave 10.14.1 (18B75). Can I get the hours lost on my stimpack returned because of this issue?


#11

I am having the same issue. Mac OSX Mojave (latest updates to Mojave and to HOTS). Playing in regular servers America. My mouse worked fine up until my game started. I play in fullscreen. Once game started I could not move my mouse at all. It would become nearly impossible to change to a different display mode while the mouse cant move. I tried leaving the game and rejoining - same issue. Then the team started saying they were reporting me, so I got 3 reports from that game on my account. I also didnt get any of the exp I would have from my 3 day boost. I dont want to get in trobule with blizz – please remove those reports. I know you guys have AI tracking them - it will not be smart enough to tell this was because of the bug on your end. Please make sure I dont get in trobuel with blizz on my account because the reporting system is so flawed. NOw I got 3 reports on me and lost my boost exp. Yall better fix this.


#12

Confine Mouse Cursor is the issue for me. It doesn’t work when enabled. It works fine when disabled.


#13

Same issue, please fix ASAP


#14

same issue, google for it for about 2 hr. Finally, I’ve found here. Please fix this.


Mouse issue mac
#16

your fix has completely fixed my hots. pls pin this post? maybe also on troubleshooting?


#17

I also have this problem on a mid 2015 MBP with Mojave 10.14.1.


#18

This happened to me and i fixed it. All you have to do is turn off those smart barriers under mouse and keyboard settings.


#19

Running newest Mac software btw


#20

using a 2017 macbook pro all latest updates and mine as well has been working fine until this patch and all accessibility was already okay not sure what else i can do. windowed mode just adds lots of lag to the point i would rather wait until this is fixed


#21

How can i fix it? Help! :slight_smile: