Mouse doesn't work after update


Need help -> iMac Mojave 10.14.1 , after latest update mouse in game isn’t working (can’t move or click). Keyboard works. Have to close app through app emergency exit.


Having same issue in fullscreen mode. The game doesn’t play well in windowed mode. lots of lag So I always play in fullscreen. Today after the update my mouse doesn’t work. Neither does the track pad.


Same here, mouse stop working on mac after last night update to these games:
Heroes of the Storm and Starcraft II patch 4.7.0


Mine as well. Same problem. Hope we can get this resolved. This Sucks !


Hey, all!

Please check out the thread in the Mac forums discussing this issue: Unable to move cursor in game (Workaround)


I am also having this issue. I have uninstalled/reinstalled but to no avail. Would love to see a resolution soon. Thanks!


Same exact problem here. It was NOT caused by the MacOS Mojave update, it was caused by the HOTS update which happened around the same time. (I know this because HOTS stopped working before I upgraded to Mojave). It’s basically unplayable until Blizzard fixes this. :frowning:


I am also having this issue . i have uninstalled and re installed the game to no success. Restarted my computer and reset my NVRAM and issue persists. can we get an update to fix this issue please? I am currently running Mojave. Game was working prior to me updating then my cursor stopped functioning in game, with my built in mouse or my bluetooth mouse.



It Works!!! Thank you man!!! lovU xD


Thanks for the fix, I have been uninstalling and reinstalling like crazy till I realized it was a global issue :slight_smile:


Works like a charm. Thankyou. It was driving me crazy


Worked for me as well. Now I can actually enjoy this game again! Thank you.


it Works!! really thank you!


Thanks for the fix!
2 weeks off => This bug made me realize hots was sucking life out of me, cortisol addiction is no joke, boys! It causes balding


2.5 days ago my mouse suddenly stopped whenever I launched Heroes. No issues with this before that.

I was excited to find this post since the I don’t have Discord on this macbook, and everything else was pointing me toward to overlay issues.

I followed the path to Security & Privacy > Accessibility and Heroes is the only app on the list at all, but it is grayed out and I cannot select it…

macOS Mojave Version 10.14.1 (18B75), MacBook Air (11-inch, Early 2014), 1.4 GHz Intel Core i5, 4 GB 1600 MHz DDR3, Intel HD Graphics 5000 1536 MB

I’m brand new and my account has an 8 day boost (I’ve lost 2 days of it now). Help, please!


Upon further research and review, I realized that I needed to “click the lock to make changes” just like it says in the bottom corner of the Accessibility page. Then I could check Heroes or SC2 or whichever app.

Sorry for the panicked / rushed post. Missing out on that boost was screwing with my head since I don’t want to have to wait over 500 seconds to queue for Quick Match anymore! (level 10 account so far)


I think it happened again for update iMac Mojave 10.14.2 , the mouse in game isn’t working. Keyboard works.


This is the only thing that worked for me! Was having the same issue in Starcraft and doing the same thing fixed it there too!


Thank You!!! Was installing and uninstalling like crazy!