Mouse doesn't work for Macs. Cannot play game


#1

I’m playing on a MacBook Pro. My mouse indicator does not work once the game starts. I cannot play the game because of it.


#2

I am having this issue on my Macbook Pro as well. First time launching since Orphea update dropped and the mouse won’t work. I can see it on the screen, but can’t use it at all. Won’t move, won’t click. It’s just wherever I rested it before launching the game. I’ve tried shutting down the game and the blizzard launcher and restarting. I’ve tried reinstalling the game. I’ve tried restarting my computer. I’ve tried a different mouse. Nothing is working. I’m pretty sure this is a blizz issue that needs to be fixed ASAP.


#3

Im having the same issue but blizzard seems to not give a damn about its customers as i already have asked support and twitter with 0 level of reply. so much for those of us that have been here since mac beta.


#4

I found this.


#5

This worked for me! Thanks!


#6

We have the main fix located Here. So you can still utilize fullscreen. Please note we have a Mac Technical support forums located Here.

Locking thread.


#7