App won't start on iPhone since patch 21.0

I’m getting this issue on an iPhone 12 Pro on iOS 14.7.1. After I updated to 21.0, when I start Hearthstone, it shows the Blizzard logo and then crashes after less than a second. I’ve tried restarting the phone and reinstalling the app many times now. Here’s what I’ve tried so far that all crash in the same way:

  • restart phone, open app → crashes
  • delete app, reinstall app, open app → crashes
  • delete app, reinstall app, restart phone, open app → crashes
  • delete app, restart phone, reinstall app, open app → crashes
  • restart phone, delete app, reinstall app, open app → crashes
  • restart phone, delete app, restart phone, reinstall app, open app → crashes

I’ve seen reports from numerous people on this forum with the same issue with different versions of iPhones as well as on iPads.

UPDATE:
I was able to fix the problem. Here’s what was wrong and how I fixed it (if any tech support are actually reading this, you need code to handle potential null values in this object since it’s possible to have a null value provided by the phone for whatever reason):

Alright, so I may have a solution for some of you. I have an iPhone 12 and the game wouldn’t start. After trying to start it, I’d see the Hearthstone logo briefly and then it would just take me back to the home screen. I dug through my phone’s logs and found out why it was crashing. It had a null value for the “device_region” being passed in as configuration data in a format that didn’t allow null values.

To fix it, I went to Settings > General > Language & Region. In Region, it already was showing United States, but I tapped on it anyway and it brought up a list of countries. I tapped United States again and it looked like it reset it. When I went back and tried to start Hearthstone, it fired up! Hopefully that’s the same problem some of you are having as well. I’m not sure how that got region got tweaked/corrupted/???

Now, if this doesn’t work for you and you want to investigate further, here’s what I did to find the error on a Macbook (Not sure about what to do on Windows):

  1. Start Hearthstone and let it crash.
  2. Plug your phone into your computer
  3. Open the Console app on your computer
  4. Select your phone under Devices
  5. You should see a list of messages. In the little bar above the messages, there are two options on the left: All Messages & Errors and Faults. Select Errors & Faults.
  6. I found a Fault (red circle in the Type column) for “hearthstone” (in the Process column)
  7. This was the error I had: Attempt to set a non-property-list object as an NSUserDefaults/CFPreferences value for key storedConfig
  8. In the object (which looks like a JSON object if you’re familiar with that), one of the values (the values are after = signs), one looked like this: "swrve.device_region" = "<null>"; Since these property-list type objects cannot contain a null value, this was causing the app to crash.

If you don’t have the same problem that I did, maybe this will help you track down what the problem is. Good luck.

1 Like

Same here brother
iPhone 12 ver 14.7.1

1 Like

SAME HERE! I cannot even open it.

1 Like

iPhone 7
IOS 14.7.1
Crashes whenever I try to open the app, right at the Blizzard logo, which is the first thing I see when starting the app.
I tried:

  1. Restarting my phone
  2. Reinstall the game

It just did not work.

1 Like

After 21.0 patch the app freezes every time.
When it’s queueing, when I play a card, when I try to see my collection.

I’ve done everything I could, but app does not work.

The screen freezes, the music continues, but I can’t interact with the game.
When I restart the app, it trys to reconnect to the ongoing match but never do it.

1 Like

Hey Devs, can we get any kind of feedback?
This is kind of ridiculous.

2 Likes

Yeah, it still hasn’t been patched. I haven’t been able to play Hearthstone on a fully updated iPhone 12 Pro since the patch came out. I can’t imagine why something like this isn’t a priority. There’s not even been any communication at all. Unless there’s some weird conflict with a setting or another app, I’d imagine a whole lot of people aren’t able to play Hearthstone on iOS right now. Probably not a good financial thing especially with a new expansion having just come out.

1 Like

It is baffling to me, as well.

1 Like

Doesn’t work for me either. iPhone 12 Pro. Stuck at “unpacking crates” and doesn’t patch itself.

I’m guessing the new expansion has totally borked something.

2 Likes

Mine just shows the Blizzard logo in landscape, then quickly turns it to normal and then kicks me back to the iPhone app selection screen. It takes under 1/2 second. And it’s not an issue with my account either. I can play Hearthstone fine on my Macbook.

I probably would’ve bought the United In Stormwind tavern pass like I did for the last expansion, but since I can’t play on my phone, I just haven’t played Hearthstone as much. And the tavern pass scales better when you play a lot more due to the experience bonus. So I probably won’t spend any money on this expansion because of this bug. Last expansion, I played enough to buy the last miniset and 95 packs from the new expansion with the tavern pass. I earn probably 50% more gold than I used to since they added the rewards path. So, since I’ve been happy about that change, I’ve been spending maybe $20 each expansion. I know I’m not a whale or anything, but damn, how many game developers would like players who spent $60/year on the same game?!

Just want to give this thread more attention because I’m experiencing the same thing on my iphone Xs max. Open app, show Blizzard logo for half a second, then force closes. It’s been like this for a week, pretty ridiculous.

1 Like

Patch notes for tomorrow were just released. I know they don’t generally include every bug fix, but our issue isn’t listed sadly:

  • Updated the Stealer of Souls animation to now only trigger if the card ends up in your hand (it does not trigger for cards that are Cast When Drawn, such as Soul Shards). The animation will also no longer trigger if the drawn card already costs Health instead of Mana (such as when you have two Stealer of Souls in play).
  • Fixed card text errors for Psyfiend and Florist (no functional change to either).
  • Fixed a bug where Prismatic Jewel Kit would trigger when effects returned a Divine Shield minion to the owner’s hand or moved a Divine Shield minion from the owner’s hand to the owner’s deck.
  • Fixed a bug where Seek Guidance (the Priest questline) would sometimes count the original Cost of cards, instead of the Cost actually paid for the card.
  • Fixed a bug where the Initiate Set version of Eye Beam did not properly display card art in the Collection Manager.
  • Fixed a bug where Reborn Rites, The Lich King’s Battlegrounds hero power, caused players to disconnect from the game server.
  • Added interactions between Pave the Way (part of the Paladin Questline) and Duels-specific hero powers.
  • Fixed various bugs in Book of Heroes Gul’dan and Book of Heroes Illidan.
  • Fixed a bug where Duels achievements were not tracking properly.
  • Fixed a bug where Witchwood collection achievements triggered even though the requirements were not yet met.
  • (Updated) Fixed a bug where completing all Book of Heroes installments would not display the proper achievement or give the proper award. All players who have already completed all 10 Book of Heroes will automatically receive the proper award of a Golden Standard pack at a later date.

Bumping because I have the same issue and haven’t found a solution

2 Likes

Thanks for the bump. Still not fixed here. I tried deleting some unused apps hoping maybe there’s some kind of conflict, but it didn’t help. I’m not going to wipe the phone and reinstall everything. I don’t have time to do that. I don’t know enough about iOS apps to really do more than basic troubleshooting.

Hey everyone,

I just wanted to chime in that we are looking into these issues with Hearthstone being unable to log in since the 21.0 patch. I don’t see anything new from the developers to pass on at this time unfortunately.

I wanted to see if we can test something I saw both here in an update from the OP and in another thread that helped. It is currently specific to Iphone users and may help out if this is the same cause for everyone.

  1. Go to Settings > General > Language & Region
  2. In Region, tap the country regardless of what it may say. It should bring up a list of countries.
  3. Find your appropriate country and tap it again to set the phone to it
  4. Load up Hearthstone and test if a problem still occurs

I’m curious if this helps or not so please share your experiences so we can pass them along. Thanks!

1 Like

Just wanted to confirm that doing as OP said, re-confirming the region, fixed the issue

I also changed the region and the app seems to be working again.

Thank you for finding out the problem!!! I was able to fix it on my iPhone.

I can confirm that changing the region and back again works, sometimes a restart of the phone is required.
However it appears this needs to be done after every app update as it is now the 2nd time I’ve had to do this.

Won’t start for me either. Gets stuck updating.

  • Tried reboot
  • region select

Hearthstone version: 22.0.127581

Model: iPhone 13 pro max
iOS version:15.1.1

1 Like