[Main Thread] Windows 19041 - Freezing for 5-10 seconds

After first optional patch I ran 10 hours without a freeze I got one. Then none since latest pushed update.

Experienced my first freeze on build 19041.508, with NVIDIA driver version 452.06 installed. Sound was disabled in-game and music was playing on an audio player.

I updated to 19041.508 and made sure I had all updates. I ran D3 again and FPS again dropped to about half of what they were on the 1909 builds I had been running. I went to open my video driver software however and got an error saying there was a mis-matched driver. I had the latest drivers prior to updates. So I went through and re-installed the latest update, and now I think FPS is slightly lower in some conditions, but seems more or less where it was. I didn’t do a full clean driver, but probably should have.

I haven’t ever had full freezes, just noted the FPS drop to about 50% of what it was going from 1909 to 2004. The 19041.508 build gets me almost back up to where it was.

I have not yet tried muting sound or replacing DLL files.

1 Like

I am still getting the freezes with 19041.508. This is a blizz problem not a MS one

1 Like

Was working fine with the first Build patch last week then they pushed another update and I am getting hit with 3x freezes a GR.

It seems like people are having some hit or miss behavior based on the most recent Windows updates. We’re working on the issue with Microsoft, and we expect that it will be fixed in a future build, but we haven’t gotten absolute confirmation that one fixes it yet. Once we get a bit more consistent behavior, we can give you all further instructions, but for now if you read recent posts you’ll find that some people are getting some luck with a more recent update.

1 Like

Having Spotify playing in the background, increasing the problem for me atleast.

No FMOD errors since the latest NVIDIA driver update, released in September.

Instead of 6 seconds of total unresponsiveness, I am now getting intermittent spurts of delay in gameplay, with errors in D3Debug stating “[BGS] |event=rich_presence_failure|”

I’m having similar problem as yours, now.
Up to 10 hours ago, my PC was fine, my D3 gaming was fine. I updated my NVidia driver 2 days ago, and nothing went wrong. The only update happened/installed within the last 12 hours on my PC was the “Security Intelligence Update for Microsoft Defender Antivirus - KB2267602 (Version 1.323.1608.0)”… as part of the automatic updating of my Windows 10 system.
Might that Security Intelligence Update be the source of problem to my D3 gaming, currently?

Opposite effect for me, back to freezing every couple of minutes since I installed the Nvidia driver 456.38

Not sure if this advice is of any use, but I installed 456.38 and selected ‘perform a clean installation’.

I was one of the first that posted this problem…and sadly the ONLY WAY I found to back to “normal” was rolling back to 1909 (did a full/clean install)

So, not even a single crash since I went back to 1909 build, (200+ hrs played)


Still seeing the issue today with:
Windows 10 64-bit version 2004 build 19041.508
nVidia 456.38 (on a 1070ti)
Latest Intel and everything else. (i7-9700k, z390-e)

Everything possible is up to date on my PC.

Per a post on the nVidia forums, I just tried updating to Windows 19042.541 through the Windows Insider Beta program. I am no longer getting the “Failed with 0x57 retrieving AppModel Runtime status for package Windows” error; HOWEVER, the freeze as described throughout this thread remains. So, this was not a solution (…but it did help with the aforementioned Windows error).

Like most others here… have done all the traditional stuff: BIOS updated, all drivers updated both manually (download from manufacturer website, Device Manager, update), checked via Restoro, and again through Dell. Uninstalled apps, ancient versions of .net, etc. Lost 2 hardcore characters to it before realizing that this makes hardcore unplayable unless you have a “guardian angel” friend playing with you.

1 Like

its time blizzard bit the bullet and put the janitor to work on updating the fmod version.

Funfact: there is no consistency between the libraries the game uses, x86-32 uses fmodex 4.34.20 while x86-64 uses fmodex64 4.31.4.

4.31.4 has issues going back to 2017

Another LoD HC toon bites the dust to this.

After clean-installing 1909, disabling Windows Update, clean install/update of all drivers on the fresh build, disabling as many configurable firm & software that suddenly change P-states, then setting all power settings to consistent performance, the game ran fine…

…for 2 days. Just long enough to convince me that this was the fix and go back to HC. Game had a stutter where it used to have 8+ seconds of freeze. Windows Event log looked good in both admin and app. So, with a regained trust, it was time to try a slightly higher GR… bam. Same problem, same symptoms.

AppHangB1 and AppHangTransient errors in AppLog.

Again, all other standard stuff done (RAMMap output analysis in Perfomance Analyzer with the Windows SDK, WAN latency tracked fine, all heat ranges tracked with HWMonitor without peaks, etc.).

So… although the 1909 downgrade and fresh build held brief promise, in my case, it was just another huge waste of time trying to band-aid a problem that is likely only solvable by Blizzard.

Maybe they just don’t have the inclination to fix this game in the face of D4 and the fact that it is a free-online access game.

I tried copying Heroes of the Storms’ fmodex64_4_44_23.dll and replacing D3’s fmodex64.dll. The change works for me and I no longer have the freezing problem.

I might need to try this. I was looking forward to pushing one last time but freezing has ruined any desire to. It wouldn’t be a big deal but a top 100 world clear is very attainable for me before era ends.

I know someone who plays Diablo 3 on a private server and they had the same problem. Then the community patched the problem itself and they have no more problems.
It’s sad how a billion dollar company like Blizzard can’t do that, but a small community and they are also on the current patch

What did they patch?
Maybe they could tell Blizzard what the fix was!