[Main Thread] "Failed - Network Error" with Battle.net Set-up file

Greetings, all!

We are seeing a large influx of reports of the Failed - Network Error recently. We are aware of the issue and our team is looking into this issue. This is a common error to occur when there is a problem with connecting to our patch servers. In the mean time, we would like to provide troubleshooting and workarounds for this issue and return you back to the game.

Note: This issue is an issue with the download file within the browser. If you are experiencing installation issues with the app, crashes, or other errors/connection issues, please create a new thread or contact support.

  • Try a different region link. If you are trying to download the US version, try the EU version instead and vice versa. This is because it will use the different region’s patch servers which can help with connection issues to the home region patch servers.

    • For Windows, try these distribution links. (Americas | Europe )
    • For MacOS Catalina, try these links. ( Americas | Europe )
    • For MacOS prior to Catalina, try these distribution links. (Americas | Europe ) These distribution links are 32-bit versions and will not work with Catalina.

    For MacOS users, please ensure to use the unarchiver and not another archive tool for the ZIP file.

If the problem continues, please try the following steps:

If the problem continues, please report here with a connection tests to our patch servers. Use the IP Address/Host name: us.patch.battle.net

24 Likes

This issue is also happening with our Diablo II installations. If you are running into issues with Diablo II, please do not use the distribution or regional links above.

Here's a list to all the possible installations using different regions

Diablo II

Lord of Destruction

If you continue to experience issues with Diablo II, please refer to this thread to report the issue. I’ve included a guide as well if you wanted to manually change the link on your own.

2 Likes

The Americas link worked great, thank you!

7 Likes

Could we have a link for Starcraft Anthology? I’m getting a similar network error message. TIA

1 Like

Hey, aafg69! Starcraft Anthology should run on the Blizzard Application now with HD mode turned off for StarCraft: Remastered. Just to cover all bases, here’s the link for the EU installation for Anthology! If you need this on MacOS, here’s the EU install link for Mac.

2 Likes

I’ve tried all of there while downloading i still get a network issue

@theredhead, could you provide the requested details?

1 Like

where do i sent it to

If you’re on mac, go to settings -> security & privacy -> firewall and click turn off firewall. That allowed me to download the initial zip file… worth a try.

So I’ve tried all the links and I keep getting this in a new window each time:

This site can’t be reached

www.us.battle.net ’s server IP address could not be found.

  • [Try running Windows Network Diagnostics](javascript:diagnoseErrors()).

DNS_PROBE_FINISHED_NXDOMAIN

I tried everything and nothing helps. Pleas do something with this.

Hi, I have just paid for a subscription and am having this issue. None of the links posted work. Can anything else be done?

Thanks

Still not working in Firefox or Edge on Windows 10.

I had to get my partner to put Battle.net on the external and then copy that to my computer. Still getting 8000+ms on WoW though

I was having problems updating so I went to uninstall and reinstall. Now I can’t install. I’ve tried the main Battle.net-Setup.exe as well as the alternative downloads in this thread for both Americas and Europe. These new links run for much longer before failing but they fail with the same network error. Tracert uspatchbattlenet shows 13 hops with 47ms ping on the last hop. Not too bad. I must assume we are just waiting for a fix?

1 Like

My internet is not that fast so I have been trying to download Warzone whilst I am at work or at night sleeping. Multiple times the download stops after just a few gigs. Why can’t it just auto-reconnect to resume the download? I would basically have to check it every hour to ensure its actually downloading. Incredibly frustrating, Origin and Steam both seem to be able to handle an interruption and restart on their own. Fix this.

2 Likes

I agree with you,im just using battle because of their games.other waise i would rather use steam

1 Like

So I repaired WoW, reinstalled WoW, deleted WTF, Cache and Interface, updated my drivers. None of that worked. I updated my PC and that worked.

Fix worked. I wish it had been a little easier to find. Just put in a new drive and tried a million things before this. Seriously–thanks, though.