[Main Thread] "Failed - Network Error" for Diablo II & LoD Set-up Files

thanks for the links

macOS:

DIABLO II
https://eu.battle.net/download/getLegacy?product=D2DV&locale=enUS&os=MAC
LOD
https://eu.battle.net/download/getLegacy?product=D2XP&locale=enUS&os=MAC

Thanx users (GODFL3X). Support you should at least try to do your job…

anyone have the download the DIABLO II and LOD in español(eu)?

try changing where it says enUS in the link for esEU. It worked changing MAC for WIN, to change the os

2 Likes

Thanks

DIABLO II in spanish: https://eu.battle.net/download/getLegacy?product=D2DV&locale=es_ES&os=WIN

LOD in spanish: https://eu.battle.net/download/getLegacy?product=D2XP&locale=es_ES&os=WIN

2 Likes

Thank you for your reports, everyone! We are aware of the installation issues. It’s the same cause as this thread for the Blizzard Application.

The distribution and regional links on that post will not work, however. So in the mean time, a different region installation should work.

Here’s a list of all the possible installations using different regions:

Diablo II

Lord of Destruction

If you would like to manually change the link, here’s how to do so.
https://{REPLACE_REGION}/download/getLegacy?os={REPLACE_OS}&locale={REPLACE_LOCALE}&product={REPLACE_PRODUCT}

{REPLACE_REGION}
  • eu.battle.net - Europe
  • us.battle.net - Americas (This seems to break most installations)
  • kr.battle.net - Korea
  • tw.battle.net - Taiwan
{REPLACE_OS}
  • win - Windows
  • mac - MacOS
{REPLACE_LOCALE}
  • enUS - English (US)
  • enGB - English (EU)
  • esES - Spanish (EU)
  • deDE - Deutsch
  • itIT - Italian
  • plPL - Polish
  • frFR - French
  • koKR - Korean
  • zhTW - Taiwanese
{REPLACE_PRODUCT}
  • D2DV - Diablo II Base
  • D2XP - Lord of Destruction

The title on this thread has been renamed. Please let us know these suggestions and links do not work for you.

Thank you for your patience and understanding! I hope this helps with any configuration you were looking for. I will update the other thread with this information as well for our Diablo II installations :slight_smile:

2 Likes

Any chance you have the links to the Frozen Throne as well? I’m having this same problem on my PC

None of the links seems to be working for me.

@Commandojoe, the Warcraft III Classic game has been merged with Warcraft II: Reforged. Could you try the links on this thread instead?

@BarristerCat, would you be able to try an alternative connection to see if this helps? If a different region link does not resolve the issue, we may need to check on the connection to the patch servers. Could you include a traceroute and pathping test to us.patch.battle.net?

Copy and paste the text file created and paste it between two ~~~ like so:

~~~
Traceroute/Pathping Here
~~~

If you have issues pasting here, use Pastebin and post the end of the link. (ie. 123456 for pastebin.com/123456)

Thanks GODFL3X. I tried disabling all sorts of stuff even opening ports. Glad to know it wasn’t on my end. PS: “You’re welcome for doing your job for you!” pure savage man

@ BarristerCat: Remove the initial www. from the url address and it will works.

Bro’s I’ve literally been playing the last 24 hours, been grinding and I logged off like 4 hours ago, went for a walk and went to log back on and it says I’ve been disconnected from battle.net and to reconnect.
I’ve uninstalled, reinstalled, used same keys I got from mobile order in blizz shop, and I can’t for the life of me get it to work.
For some reason it reverted back to 1.14b, so I uninstalled, did it over, finally got patch for 1.14D and it still ain’t working. Please help, pissed!

Yo can u please help??

@inflxence Probably a temp ban for creating/joining too many games. If you join more than 20 games/hour they view you as a bot and ban you. It’s a pretty dumb system that the bots avoid so it pretty much only penalize the legit players.

bruh WHAT lmaoooo that is so gay. So because I do chaos/Baal runs, I get a temp ban

Pretty much, doesn’t make sense to me either. They don’t care enough to do something about it

That is the most insane reason for a ban I’ve heard. Literally grinded to 86 for what :woozy_face::woozy_face::woozy_face: and it’s a 2 week ban I assume?

there’s no way to know really can be 1hr,24hr,72hr or 2 weeks I think.

That is absolute cheeks omg lol. Thanks tho man!

Replaced the links to remove the www. seems that some of those links were causing issues like “site not found” due to the issue. The site may still give the site not found error, but it should still prompt the installation. If you experience any issues with the links please let us know!

This thread is intended to track issues with the Diablo II set-up file installation. If you are experiencing this issue, please refer to the post above to grab a different region’s link for your preferred language.

If Diablo II is already installed, this thread is not the correct one to report on. Please refer to a more relevant or create a new thread.

If you are experiencing issues with the Blizzard Desktop Application’s set-up file, please refer to this thread.