Windowed Mode - resizing quits WoW

I play in Windowed mode. When WoW opens, I drag the window to the size that works for me. As of 9.2, if I even drag the window size a little (smaller or bigger) WoW immediately quits.

I had to:

  1. Launch WoW
  2. Set to full screen
  3. Set to windowed mode
  4. select a screen resolution
  5. hit apply

That gets me in the game as a workaround, but I would like to be able to freely resize the window as I have in the past.

I disabled all addons, still no go.

MacBook Pro (15-inch, 2019), 2.3 GHz Intel Core i9

Any thoughts?

12 Likes

Having the same issue. Always play in windowed mode. If I try to adjust the size of the screen, it instantly crashes.

Also, I have multiple monitors and when trying to maximize the window, it moves to my non-primary monitor… which happens to be a TV hooked up to my computer. Ugg.

I also disabled all addons and restarted. Issue persists.

Playing on a 27" imac, Retina 5k. 4.2ghz quad-core intel i7. 32gb ram. Radeon pro 580 8gb.

4 Likes

I’m experiencing something … potentially related?

Issue

Game client becomes non-responsive after being resized.

Details

After dragging to resize the game client, I can no longer interact with the client with my mouse. Everything else continues to function appropriately. This also affects the client pre-world, e.g. in Character Select.

Non-mouse functionality continues

  • Keyboard continues to work (that is I can in fact move around and such via keyboard), I can access the menu (esc), and so on
  • People in the world continue doing whatever they’re doing
  • Audio still plays

UI stops responding to mouse

  • I can no longer move using the mouse
  • UI elements no longer respond to my mouse (e.g. buttons do not highlight)
  • I cannot interact with the Mac UI components of the window - that is, I cannot resize it further, close it, minimise it, and so on. Interestingly, the Mac UI minimise/maximise/close buttons still highlight during mouseover, despite being non-clickable
  • I need to close the game by right-clicking on the dock icon, and select “Quit”
  • If I move my mouse in and out of the window, it swaps back and forth to the WoW gauntlet cursor, but if I select a different application’s window then return, it stays the generic Mac mouse cursor.

I can left-click switch between application windows, but that really appears to be all I can do with my mouse.

Steps to reproduce

  1. Grab a corner of the game window
  2. Hold down the left mouse button, drag to resize

Expectation

I can continue to resize the window and release at my convenience, and the game continues to function.

What actually happens

Across ~6 attempts, the window stops resizing after about 1-2mm, and becomes non-interactive. During a single attempt, I was able to resize a few inches before the window became non-interactive

System details

  • Mac mini 2018
  • i7 + 32GB RAM
  • Radeon RX 580 eGPU
  • Monterey 12.1

I’ve posted a bug report:

4 Likes

Same here. We have two 16" 2021 Powerbooks. Both have the same problem. If we move the window or resize the window the game crashes.
Obviously a major bug

1 Like

I’m having the same issue - exactly the same, so I won’t rewrite it all - on my Mac mini. It was working perfectly until yesterday.

Mac mini (M1, 2020)
Memory 16 GB
macOS Monterey 12.2.1, fully patched

This is a problem for me in particular because I have an ultra wide monitor. The pre-set options for window size only allow me to make the window proportionally smaller, which means I get a long, squat box to play in if I choose anything less than full screen - and full screen or near it absolutely kills my fps.

1 Like

Howdy!

Thank you all for taking the time to report this issue to us in such detail, that is always extremely helpful. I can confirm this is clearly not working as it should and our developers are already on the case to find a resolution here. For now, the best possible workaround would be using the in-game settings to change your resolution, playing temporarily in Fullscreen or not changing the window size until this issue has been resolved.

We will update this thread when we have more information to share.

7 Likes

An interim workaround for setting the size you want, if you know it is to do the following:

  1. Enter the game and set it to Windowed mode if it is not already set to that mode and then exit the game. If you normally play in this mode and it is already set, skip this step and proceed to step #2.

  2. Open your config.wtf file (located in /World of Warcraft/_retail_/WTF/) and search for the following line:
SET gxWindowedResolution

If present, change the two values in the line to the resolution you wish to use for the window. It should look like this (example shown is a window 1600 pixels by 900 pixels on a 1080p or larger display):

SET gxWindowedResolution "1600x900"

If the SET gxWindowedResolution line is not present, create it at the end of the config.wtf file’s contents and save the file.

The next time you launch the game after making this change it will use the resolution you created for the Windowed mode.

Search your config.wtf file for the following line:

gxAspect

If it is present, it likely shows as follows:

gxAspect "1"

Change the 1 to a 0 and you’ll be able to freely resize the window both horizontally and vertically. I assume you are intending to do a picture by picture setup, in which case you may wish to just use the steps above (the workaround to the resizing problem in this thread) to set the window size you want, presumably 1920x1080 on most typical ultrawide displays that do 3840x1080. If yours is a different resolution and you want half of the screen to be WoW and half available for whatever you need, do the workaround steps and for the first part of the resolution just use half your display’s native horizontal resolution.

4 Likes

This was the perfect solution for me, thank you for taking the time! I was able to set my screen to 2300x1300, which gives me room for slack along one side and means I don’t have to swivel my head around to see my minimap or chat windows. :slight_smile:

I have also experienced this.

Same here. iMac Retina 4k, 21.5inch 2017 model. 8 gb memory. Radeon Pro 560 4GB card.

Monitor is LG 32inch.

Never had a problem with this before this current update.

1 Like

Bump. 2019 Macbook Pro.

1 Like

This is still happening after today’s update. Will Blizz give us a refund of payment for the week or so we’ve not been able to play? Doubt it somehow …

Maybe Bliz is trying to make it so hard for Mac players that they bail on the game - leaving the field clear to no longer support Mac?

I’m pretty pissed off just now …

1 Like

This. particular issue is annoying but it’s not one that keeps you from playing. Just don’t resize window (or resize it out of game by editing config.wtf)

The state of their mac support is a travesty but it’s no surprise from a company that’s been phasing out mac support for over a couple years now. I’m grateful it even supports mac at all still. We’ll see how long that lasts though.

most of the hard crashes that generated reports showed the kernel panics originated in the windowing system

it’s not just resizing, there’s a bunch of new weird things with the windowing system, like prior to trying to resizing it and crash the game goes non-interactive … forcing it to crash is actually a good thing because you don’t have to reboot

this isn’t one thing,

Definitely some issues with GPUs and they’ve been going on for quite awhile.

Just looking to bump this thread - still crashing if window is resized. Trying to be careful, but every once and a while I touch the edge of the window while jumping to another app, and it quits out of WoW.

Bump. Experiencing same issue still on 3-23-22.

1 Like

So this went from crashing the WoW Client when I try to resize to not being able to resize at all and not crashing and losing the mouse pointer and not being able to click anything within the WoW window and having to quit or force quit WoW client from the dock.

This is on a MacBook Pro Apple M1 Max with macOS Monterey 12.3.

2 Likes

Everything was fine yesterday, when I tried to log on today, I am having this problem. If I try to resize, window becomes unresponsive.

My issue is I 2-box frequently and when I open a second instance of Wow (TBC), the window size is always 50% smaller than the first instance, so I always have to resize the second window to make it large enough to play.

I see no followups in this thread from blizzard … I assume it isn’t resolved? seems odd after a month. Also odd that it shows up suddenly like this. Was fine after the weekly reset yesterday, this afternoon no good.

2 Likes

This started happening for me just a couple of days or so ago. Nothing has changed on my end other than WoW updates since well before the problem started. Can’t really add any detailed info that hasn’t already been posted by others - other than to say that I’m running 10.14 Mojave, so it can’t be blamed on a particular OS. I doubt that it’s a problem with GPUs or drivers either - too many differences on user end between all of us for that to be the case.

Changing resolution to a specific size is barely workable at a practical gameplay level for me and “Just don’t play in windowed mode” is not a viable solution, not even temporarily. Like many others I have more than one account and often have multiple instances open - for example to run more than one character during RP events, or when running content to level alts.

2 Likes