This item is no longer available in AH

Despite AH telling me there are over 500K of them for sale. I can’t buy widowbloom. Please fix tyvm. I can purchase other herbs without issue.


Bump, I am also having this issue


It’s specifically [Widowbloom] @ 14g 50s and a few other commodities that I’ve seen around the Discords that are stuck at a specific price and can’t be bought out above that price.

I would guess it’ll automagically resolve itself when their expiration time hits, even though the auctions don’t appear to actually exist anymore. But it’ll likely just happen again with some other item until the bug is fixed.


I’m trying to buy a stack of anything (widowbloom), and keep getting that same error. Only way for me to acquire items is by buying 1 at a time. This needs immediate attention.


It seems like there’s 2 widowbloom stuck at 14g49s, can’t buy anything higher than that now.


I’ve noticed that if you back out to the search window after you get the error message, you can buy whatever the bottom price total is by clicking the lowest price auction when you click back into the buy window.

1 Like

The same thing appears to be happening with Cosmic Healing Potion right now.

1 Like

I am also experiencing the same issue with trying to but stacks of any commodity item.

1 Like

Not working for me. PLEASE BLIZZ FIX THIS!

1 Like

Can confirm. There is a listing of 34 First Flower at 2g30s blocking all purchases at that listing and beyond…creating a major artificial scarcity and holding the price underwater at the same time.

Also Cosmic Healing Potion, listing of 200 at 6g49s. All purchases at that listing and beyond are being blocked by this bug, keeping prices artificially locked down.

Basically, you have to wait until people post more at that price or lower to purchase. It’s wreaking absolute havoc for buyers, crafters, and sellers. Honestly, this is almost as economy-damaging and critical as the bugs yesterday that shut down the AH, and it’s been around ALL DAY. It’s infuriating to those of us with significant resources invested into the affected markets.


I can confirm that this is currently affecting sale of several commodities in the AH. Marrowroot, Widowbloom, and First Flower were definitely affected. I tried the suggestions in this thread to only purchase 1 at a time, that worked for about a dozen and then the Auction House would freeze up where the sale window was just spinning and the only way to stop it was to close the AH window.

This sounds like a software bug to me.

1 Like

Also having this issue. has totally killed my main income source

1 Like

I’m unable to buy any Tome of the Still Mind on the AH, getting the same “This item is no longer available” bug.

1 Like

That’s the thing, It’s killing those of us who have heavily invested in these markets. But a lot of people are like “oh well, screw goldmakers, cheaper for meeeeee”.

The problem there is it’s actually creating an artificial scarcity for buyers in the case of crafted items as well. People can’t buy the amount they need, and sellers are starting to pull back because the price point some of these things are stuck at is almost at a loss.

This is a HUGE issue affecting everyone.


I’ve been seeing the same issue on multiple mats and on the Flasks of Power since midday PST. The exact behaviour seems to depend on whether someone has been suckered in by the low bid at the top of the listings and how many items you try to buy. It happens to my account on multiple toons, even AFTER I did a Scan and Repair. I have also noticed in the last hour that some of the listings show as having 49709 days to go.

1 Like

Ok so, there’s some really odd behavior going on here that has me concerned that gold might be being generated out of thin air, or buyers are paying more than they agreed to pay in the UI.

I’ve noticed some interesting things while I was attempting to mini reset the price of Widowbloom, since from what’s show listed, there’s a very quick 3g profit on each unit. Using Widowbloom as a specific example. These auctions seem to be locked:

  2 @ 14g 49s
737 @ 14g 50s
  1. People are regularly posting quantity of Widowbloom @ 14.5g and 14.49g and, if you’re quick enough, you’re able to buy it. Seems normal.
  2. However, if I have Widowbloom listed at the 3rd lowest price (like 17g), for some reason it sells, and sells in very odd quantities, not in quantities that would consume all 739 before it.

This shouldn’t be possible.

This is entirely hypothetical, but my concern is that what’s happening behind the scenes is something like this (keeping in mind that there are 739 locked that can’t actually be bought)

  • Someone lists N quantity for 14g 50s, which brings the total below that price to 739 + N
  • Someone buys N + R quantity of Widowbloom. N quantity at 14.5g gets sold completely from the person who just listed it, and R attempts to be sold out of the 739 remaining. But since those auctions don’t actually exist, it “dips” into the next lowest auction, which is the one at 17g.

So if this scenario is accurate, one of two things is happening:

  1. Gold is being generated out of thin air for the seller, because the buyer is paying 14.5g, but the seller gets 17g for their items – or:
  2. The buyer is actually paying 17g for R quantity of items, even though their confirmation dialog only told them it would be price (N + R) * 14.5g – which is bad for the buyer.

I’ve stopped buying and relisting for the time being I have no idea whether this is actually doing something unintended behind the scenes that is completely transparent to the users.


I almost wonder if those postings were from people who have been banned, had their accounts locked due to yesterday’s bug, or are maybe from another region and their posting somehow slipped through to the wrong region’s AH. So then the game bugged out and the listing is stuck in purgatory…it’s still there, but can’t be purchased, and it thus permanently blocks all of the listings behind it.

Regardless, I’ve had to completely stop selling pots (my main source of income) because the prices are being prevented from rebounding or fluctuating into profitable territory.

On the other hand, as bad as it sounds, I’m having to instead spend my time sniping up mats at their also artificially lowered prices and just plan for whenever this thing is fixed. But I’m sure that’s driving the gatherers crazy (as evidenced by the fact that they aren’t exactly posting some of their mats in high quantities anymore either).

It’s also sharpening my math skills I guess. As it turns out, I will know exactly what ANYTHING minus exactly 34 is (thanks to having to rapidly calculate in my head what’s available at that very second minus the block point (the listing of 34) for First Flowers. Lmao). It’s like memorizing multiplication tables all over again, only waaaaay worse.

I am on the Khaz Modan server. Am trying to purchase 1 Masterful Jewel Cluster from the AH and it is telling me the item is no longer available. However, the AH shows there are over 13,000 of the item available. I defaults me to the very first item on the list. When I try to go further down the list to by the 1 item at a higher price, the AH is then trying to make me purchase all the items before it also amounting to over 6,000 items. I just need 1 not 6k.


So, interesting development…I got curious and posted a stack of Cosmic Healing Potion beyond the blockage point.

It took forever, but it did actually sell…while all the lower priced items and the bugged listing remained.

This tells me that some people are able to purchase beyond the block point, but most can’t.

Also, I’m not getting the chat notification of “A buyer has been found for your auction of Cosmic Healing Potion” for those sales, which is odd. I have to manually look at my sales log to confirm the sale.

So now I really have no idea what’s going on, and I, too, am stopping all AH activity until this gets fixed.


semi update from my end. was able to purchase 5k widowbloom but couldnt purchase 1k 5 seconds earlier. still hate this bug

1 Like