Main Thread - Error when joining or making lobby

Hi, when I try to join or make a lobby in the arcade I get one of two errors. One saying there is a temporary error in your request, the other saying I need to upgrade my copy of starcraft2. I have had legacy of the void since release, was playing it earlier this afternoon without problems. Others are having the same issue that I’ve asked about.

Update: The issue seemed fixed around 10 am central, but the issue is back. Some games seem to not have this problem, but it appears the majority of them still do.

126 Likes

Same here. I can’t seem to make a custom lobby for a 1v1 melee map either. It won’t stream any map data. The message that pops up is " Error: There was a temporary problem with your request. Please try again." I’m on NA if that matters.

20 Likes

I am also having this issue… not sure why it would say to upgrade the current version when it was already double checked and is in fact up to date!

13 Likes

Same here. Unfortunately, I can’t connect to any of the custom games I usually play. It’s also the only reason I really log onto SC2…so, great job Blizzard. Shooting yourselves in the foot as usual. Hopefully this is just an actual error and not some money grabbing tactic.

13 Likes

Same here. Any ETA to mitigate the issue?

9 Likes

Same here, I get a GLOBAL_TIMEOUT error when trying to start a custom game. I’m able to get into a co-op game though. Please help!

7 Likes

This is the error I get.

https://imgur.com/a/N2gfwBF

Just thought I share some of the stuff I have tried so far:

  • Tried joining a lobby - No issues.
  • Tried creating a lobby on US West (via US server) - Error at ‘entering lobby’.
  • Tried creating a lobby on Australia (via US server) - Error at ‘entering lobby’.
  • Tried creating a lobby on KOR server (logging on to the KOR server) - No issues.
  • Tried queuing for ladder / co-op - No issues.
  • Tried restarting SC2 - Issue remains.
  • Tried ‘auto join’ feature - Issue remains.
  • Tried multiple different maps - Issue remains.

At this point in time, it seems that the issue is probably on the server (or at least Activision side) rather than the game.

========================================================================

[UPDATE #1]

I actually got a time out when queuing for co-op. It was fine when I did the 2nd time.

My suspicion is that Activision may be changing some of the server settings, etc. The possible plus side would be more efficiency. The possible down side may be a reduction in no. of hosting servers hence such issues.

Though take this with a pinch of salt. They are just hypothesises, and I could possibly be making wild assumptions.

========================================================================

[UPDATE #2]

Seems like the issue is fixed. Though we will probably never know what happened.

========================================================================

[UPDATE #3]

Seems like it is working for some, and not working for others. I wonder if it has to do with each person’s location. I am creating from US. Is someone creating from outside of US?

1 Like

It was working earlier today, but just recently, I get a GLOBAL_TIMEOUT when creating a lobby.

5 Likes

Seems the issue still remains.

I love how there is still no word from blizzard on this at all.

7 Likes

Same here. “There was a temporary problem with your request. Please try again.” I have tried a few times over the last hour.

5 Likes

Same issues here. On Mac mini m1. I tried to set up a lobby and get a timeout error. WTF Bliz/AV?

I believe activision wishes the worst Christmas of 2020

8 Likes

Maybe everyone needs to flood them with support tickets to get their attention?

4 Likes

how do u do a support ticket?

Yea same issue for the last couple of hours. Seem to be US issue, when i login to Europe it works fine.

2 Likes

I was able to get into one game but now I’m unable to play… “the game server timed out when creating the game”

It’s been nearly a day since this issue started (11pm tuesday ET) and Bilzzard still has not even given a response.

1 Like

I’ve experienced the same issue with a friend. On US server, I could create a private lobby when alone but when my friend was in my party, the Global_Timeout error occured when trying to create a lobby.

We tried the EU server and it was working…

i am having the same issue since 9pm yesterday

Send in support tickets to get their attention. I’ll do my part.