ULTIMATE Reducing Input Lag Guide (SIMPLE) 🤓


#1

What is Input Lag?

Fundamentally, input lag is the time between the moment an input is made, and what appears on your screen. High input lag is bad, while low input lag is good.

An example of high input lag would be if you swipe your mouse to the right, but it takes 1 second for that action to be reflected on your screen. Hence the reason why it’s called input lag.

Input Lag & Frames Per Second (FPS)

  • Higher FPS = Lower input lag

Basically, higher FPS gives your monitor a chance to “retrieve” the latest information and images from the game, making control inputs feel more responsive.

It is generally recommended to have higher FPS than the refresh rate (hz) of your monitor (refer to the previous paragraph).
Example: If your monitor has a 144hz refresh rate, it is recommended that you have 200+ FPS.
Also, doing so leaves a “cushion” of space in case of any sudden FPS drops in-game.

"Measuring" Input Lag in Overwatch

  • Enter the Practice Range and press CTRL+SHIFT+N, which will bring numbers in the top-right corner of your screen. The farthest number to the right is the SIM number (which is seen as: number ms). Basically, a lower SIM number means lower input lag. Ideally, you want to have a SIM number of 10 ms or lower.

Recommended Settings for Reducing Input Lag

  • Set resolution to a maximum of 1080p, or lower for more FPS.

  • Set render scale to a maximum of 100%, or lower for more FPS.

  • Always enable fullscreen.

  • Disable full-screen optimizations: Locate: overwatch.exe> right click>properties>compatibility>check “disable fullscreen optimizations.”
    Read more here: https://old.reddit.com/r/Overwatch/comments/6sdn4s/if_you_play_overwatch_on_windows_10_consider/

  • Disable V-sync.

  • Disable FPS restrictions (and then set it to 300 FPS).

  • Set shadow details to low.

  • Enable reduce buffering.

  • Disable triple buffering.

  • Disable ambient occlusion.

  • Disable local reflections.

  • Disable dynamic reflections.

Other Settings/Changes for Reducing Input Lag

  • When running Overwatch, go to Task Manager>Details>overwatch.exe>Set Priority>High. You will have to do this each time Overwatch is launched, unless:

For Overwatch to be automatically given high priority each time it is launched, do the following:

  1. Open a Notepad (type Notepad in the Windows search bar, click on “Notepad”).

  2. Copy and Paste the following into the Notepad:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\Overwatch.exe\PerfOptions]
“CpuPriorityClass”=dword:00000003

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\Battle.net.exe\PerfOptions]
“CpuPriorityClass”=dword:00000005

  1. Save the Notepad as a .reg.

  2. Overwatch will now automatically launch as high priority. Done.

  3. (Optional) Consider referring to this good Reddit thread + comments: https://old.reddit.com/r/Competitiveoverwatch/comments/4vz5sh/cut_my_input_delay_in_half_and_loving_it/?utm_content=title&utm_medium=front&utm_source=reddit&utm_name=Competitiveoverwatch

  • Feel free to adjust any other changes, video settings, etc. that may reduce input lag in Overwatch.

Credits & Sources

Forum Users:

  • Trollypops
  • Knslyr
  • Dayman
  • Gelectrode

Reddit Users:
u/LovableContrarian
u/ChefLinguini
u/likechan

Websites:

  • Esport Settings

Note

The purpose of this post is to assist all types of Overwatch players in understanding how to reduce input lag in Overwatch. As such, please suggest any changes to the post, such as if there are inaccuracies, mistakes, etc. Thanks! :slight_smile:

EDITS: Added additional instructions for the Notepad (Windows Registry…), changed “disable reduce buffering” to “enable reduce buffering”, added an ideal SIM number of 5 ms.


Lowering Input Lag
RTX 2080 TI i7 8700k
80-110 fps on i3 8350 OC @4.2ghz, GTX 1070, 99% CPU usage, 50% GPU usage
RodHoag cant hook
New Player Problems
The input lag is annoying
Just Got PC Overwatch! Tips?
High maximum input lag
Do I need 140Hz to playing Mercy?
#2

I have done this and I can vouch for how much it helps.


#3

Yes, reducing input lag is a massive change. Hope this guide covers everything about reducing it! :slight_smile:


#4

It helped in Widow 1v1’s a lot.


#5

You can certainly feel the difference on hitscan heroes, but also projectile heroes. : )


#6

Actually looking back at the reddit post it should be

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\Overwatch.exe\PerfOptions]
“CpuPriorityClass”=dword:00000003

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\Battle.net.exe\PerfOptions]
“CpuPriorityClass”=dword:00000005

Without the “Windows Registry Editor Version 5.00” the .reg file fails to run.

Other than that, fantastic post that helped immensely!

:grinning::+1:


#7

One more setting to add to “Recommended Settings for Reducing Input Lag” is ‘Local fog details’. Setting this to low helps fps while having very little impact on graphics. Highly recommend setting this to low (the lowest) setting.

For the reg edit file for overwatch here is what each number at the end does
2 = normal
3 = high
4 = real
5 = below avg
6 = above normal
Here is my old fps guide with some troubleshooting steps, if you find anything good for your guide add it to your own.

For those wondering about gsync check this video. Jump to about 13:15 in the video and look at the left side of the chart. Top 400 fps no limits vs 142fps limit with gsync and vysnc enabled the input lag is very close. Basically this means with a in game fps limiter, you can run gsync with almost no input lag. Watch the whole video for more info.


#8

This post should honestly be pinned. Even reduced input lag by 2-3ms offers a significant improvement to gameplay.


#9

So question:

My SIM number jumps around, usually averaging around 11.3 to 12.6, but it jumps around to 20’s, 30’s, 40’s and sometimes higher.

Does this number need to stay consistently around the lower numbers or are jumps normal?

Edit: One other option apparently. Windows 10 includes a “Game Mode” option in settings that apparently attempts to force a steady 60fps onto games when being played even when overidden by in game options. Turning it off apparently benefits you more.

Settings > Gaming > Game Mode > Game Mode On/Off (toggled on default, toggle off)


#10

Ideally, you want to have it below 10 most of the time.


#11

I also found these steps also increase FPS and lowerinput lag in the games I play including Blizzard games and other triple A titles. Specific to Nvidia GPUs. I know these work on the 1060/1070/1080 including TI modles. I imagine it works for older cards too.

Make sure your power profile in Windows 10 is set for Maximum Performance.

In the Nvidia control panel…
make sure the following are set to (and if this doesn’t help you can always click restore later):

Disable Ambient Occlusion.
Anisotrphic filtering set to application controlled
Antialising Mode = Application controlled.
Turn off Antialiasing Transparency.
Maximum prerendered frames = Application controlled.
Power Management Mode = Prefer Maximum Performance (VERY IMPORTANT)
Preferred refresh rate = Highest Available
Shader Cache = On
Texture Filtering - Anisotropic Sample Opt = On
Texture Filtering - Negative LOD Bias = Allow
Texture Filtering - Quality = High Performance
Threaded Optimization = Off

Disable game DVR and any overlays like twitch / discord.

Additionally / Optional but gave me a huge boost and more colors

Adjust desktop color settings (from witin NVidia control panel)
Choose “Use Nvidia settings” and leave all of them on Default. For my monitor I increased Digital vibrance by 10%

One thing to note, if you’re doing this on a Laptop/Notebook it’s possible some of these options aren’t available due to the nature of it being a Render device. It’s completely fine and you can skip over that part if it’s not available in the NVIDIA control panel.


#12

Not sure about


#13

I haver use these settings.
Sim 6-9 ms


#14

Thankyou so much for this!


#15

this didnt work for me my in put lag is still 9 to 12 my specs are
GTX 1050 2GB
i5-7300HQ CPU


#16

Is this still an accurate guide?


#17

Being a widow main i have put in insane number of hours…like every day for a year or more. When I don’t have input lag I can easily get 30-35% or scoped crit accuracy as widow and average 30+ headshots a match. When i do have input lag, it’s hard to get even a few headshots. I personally have had the best luck with many things default. Balanced windows power mode, BELOW NORMAL priority for overwatch. Almost default bios. I prefer hyperthreading off, optimal power for Nvidia, and threaded optimization off. I can get 400 fps (you can unlock it in settings.ini file) and mostly maintain that or at least maintain 300fps and still get massive input lag. The mouse movement is what suffers the most. It is just so de-synced from the game itself it’s very hard to click on heads. It’s ridiculously easy for me to click on heads without this… I’ve tried windows 7, 8.1, 10–many versions… there is no clear cut answer and it’s pretty inconsistent.


#18

i have 1080ti, 240hz monitor, 8700K, and 3200mhz ram. Anyone wanna try to fix this issue add me on discord Lewison#5464


#19

Are you over clocking your 8700K? what Power supply and Motherboard is it?

Couple of tips, mainly windows.

Make sure Windows Power profile is set for Maximum Performance. this will help push your CPU to the maximum it can minus AVX offset.

Make sure All Windows updates are installed / Up to date
Plus GPU drivers too.
Check for a bios update too for your Motherboard.
Is the Monitor G-sync capable? personally never heard of a 240hz G-sync monitor, I use an ASUS Swift and set G-sync to 165hz (oc mode) I also setup the Geforce applet to allow G-sync in Window mode and full screen mode.

You could try dropping down the refresh from 240hz to something like 144hz and see if the input lag goes away too, just to see.


#20

isn’t G-sync just bad? worse than having it off? Mine is a freesync model (alienware aw2518 or something), but I don’t enable freesync or g-sync. I know with newer drivers you can get g-sync to work. So you actually run it at 165hz because you find that it has less lag than 240hz? huh… I’ve tried 144hz before and custom resolution with 200hz and sometimes the 144hz swap midgame does seem to help but it’s only very temporary. My 8700k is not overclocked. corsair 850W I think or 750W and gigabyte z390 pro motherboard.

Also, another user and I who have done insane testing/research both seem to like Optimal Power for nvidia settings… have you tried that before? And obviously you are disabling HPET. Are you changing everything from IRQ to MSI mode? MSI tool makes that very easy (so you’re not sharing IRQ’s).