After the Last Patch, cannot open game on MAC

@Fidibus worked for me as well <3
Blizz guys should pay ya!

Thank you very much. Blizzard should be paying you.

Crashing here too. 10.13.6 – “Heroes quit unexpectedly” right after launch.

Someone at Blizzard should drop a few hundred thousand gems on this dude. Worked 100%. Thanks Fidi!

1 Like

Worked for me too. All hail Fidibus!

Thank you for the workaround, Fidibus!

We added it to the bug report. :slight_smile:


Change Computer Name
This just worked for me. Thanks Fidibus!


Can Confirm.

Fidibus’s workaround works!

On an iMac Pro 10core running 10.13.6

Personally, another possible solution (it worked for me) is inside the game, under options, change the server that is connected, unchecking the “Choose the best server” option and select any one of them.

The game was back to normal at the same time!

Hope it helps some people!

how are you going to choose a best server if you can’t open the application… I think you got the wrong thread mate.

1 Like

10.14.3 and not running.

What computer name should I put in?

This also worked for me! Changed the hostname, then changed it right back to what it was originally, an the game suddenly launches & works.

The game still doesnt work for me after the last patch. What hostname should I put in? I’m not sure what I have to do. Thx :slight_smile:

It worked! I love you Fidibus lol

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

WOW! you’re a hero!!

Same issue with last patch for StarCraft II.

Same fix! hostname change.

A post was split to a new topic: Heroes of the Storm Crashing

Same here, the change name on preference repair my game too…

Thanks a lot !