After the Last Patch, cannot open game on MAC

After the last patch, game won’t open on MAC. Will say “Heroes quit unexpectedly”. Scan and repair and rebooting the computer did not work.


Same problem here xxxxx


I’m experiencing the same exact problem after the latest patch. Scan/repair/reboot did not solve the issue.


Hi all,

We’d like to gather some info about the Mac OS version that’s being used, for those that are experiencing the launching issues. Please let us know what Mac OS you’re currently on.

You can check by clicking the Apple icon in the top left and selecting About This Mac.

If you haven’t done so already, update the Mac OS to the latest version and try launching the game again.

Same problem for me. Im on Mojave 10.14.1. I will message you code during crash

Currently on 10.14.2.

Currently on 10.14.3 (18D109).
Updated the OS, but unchanged. Still can’t open.

1 Like

Hey, all!

If updating to the newest macOS version did not help, please navigate to the following location and delete the variables.txt file

User/Library/Application Support/Blizzard/Heroes of the Storm/

Please report back if this helps. Thanks!

I copied and pasted to “go to folder” and it didnt work. Is this the correct location name?

The User will be your MacOS User name, you can manually navigate to your Library if needed.

the “support” file under “heroes of the storm” folder is a package. When I click on the “support” file, terminal opens up. How do I access files within to delete it?


It sounds like you are in the Heroes of the Storm installation directory. That would be the wrong location.

I’ve updated to the latest OS (10.14.3) and deleted the variables.txt file and the error still occurs.

In “library” there exists a “application support” folder but no blizzard hots or battlenet folder after that. In the “shared” folder I found a “blizzard” folder that contained a “heroes of the storm” with two folders in that “Maps” and “versions” neither of which have a file that says “variables.txt”

I cant update to the current Mac OS because I’m using a 2011 Imac. Im running 10.13.6. I had no issues until the latest patch. Is this the problem? If so, can it be fixed?

Thanks for trying, everyone!

If you could please collect your system files and email them to with the Title: Heroes quit unexpectedly [14623] we can look into this further.

MacOS version 10.13.6 crashes too. Deleting the variables.txt file did not work. I will email you the system files you requested.

Same. Mac-- Mojave. Tried all the options. Emailed techinfo with my specs. Hope it’s fixed quick!


Same problem here, also emailed techinfo. Tried scan&repair, updating, reinstall, and the stuff mentioned here. Nothing worked so far

Same here on. 10.14.3 Tried scanning and fixing. The launcher recognized there was an error, said installing fix, but then it didn’t do anything. I thought maybe ez fix, but same problem as before. just instacrashes