S-19 Group Join Bug

Attn: Nev, Mandy, Christine, Sandra, Lisa, Beverly, Sherman, Greg, Bob, Tom, the-other-Greg, and other awesome and wonderful staff at Blizz

Can we please make this a priority to fix. I been telling folks to follow the steps found here:

When the above doesn’t work I send them back and tell them to also kill the “Blizzard Entertainment” folder. As a test when they re-login, I check friend list and clan list. I have them type “test S-19” in clan chat and a whisper to me. This is to verify that they have a leaf indicator in the clan member list, in clan chat and whispers. Next, I send them a party invite while they are in the lobby. Many of them succeed only to have it fail less than 30 mins. later. I had 12 people that I was coordinating with to get them up to 70 and get them through the majority of the first 4 chapters of season journey. However, multiple folks in my friends list (in other clans) said they were also having the same issue.

I start a solo game and clear the easier/quick bounties. I then want to invite 3 more to help speed through the remaining bounties. However, some players who were in prior games with me, they have the leaf in clan listing and/or friend list UI, they pass the whisper test, but they can’t join my game. The party invite fails a split second after its sent. I’ve had other people drop to the lobby invite me and others (all have leaf indicators), and then can’t start a level 70 T1, T3, T4, T5, T6, T7 game. Everyone has cleared T7 and GR30 solo.

Before anyone points at the bug report forum. I’m bringing this to the attention of the community because lots of people in-game were having trouble with the group join bug. This caused some of my friends/clan mates to just log off in frustration. Some decided to just play solo because they wasted 30+ mins. with one group trying to get around the bug. A full reboot, disk clean up, defrag, and the steps at the top of this post had no effect.

Side notes:
1 - I’ve requested that D3 be ported to Linux as a 64-bit native Linux game client. I’ve also requested that the D4 dev team release a 64-bit native Linux game client for Diablo 4 and release it at the same time that they release the Windows version. I’m an advocate for gaming on Linux. However, I don’t use WINE or other translation layer software. It is intermittent bugs like this group join bug that could be indistinguishable from other incompatibilities/bugs. Because I don’t use WINE I’m forced to play D3, and any other Blizzard games, on a dedicated Windows 10 install. I really want to get rid of the Windows 10, free up that hard drive space and game on Linux (natively).

2 - Since many are forced by this bug to play solo please add an off-line mode to the Windows version (and Linux version) of the game. I can understand that resources may have been pulled away last season in preparation for BlizzCon. However, this is killing the fun.


This is a known bug and has priority to be fixed. Thanks for bringing it up.


Thank you Matthew for your quick reply.

What a mysterious exchange

According to my experience, go to Hero selection UI and re-select your hero will solve this problem.

I will test this tonight… previously I’ve closed the game and restarted to fix this.

Return to hero selction UI, switch to another hero, and switch back to your prefered hero, probablly will solve this problem, I tried again and succeeded.

As the bug has been outstanding for 10 weeks it doesn’t seem like the priority is particularly high. Also, the Bug Report thread hasn’t received a Blizzard update / response in weeks.


I wanted to give an update on this bug -

We have multiple folks looking at this bug today between the Diablo team and the Battle.net team.

As soon as we have some info, i’ll be sure to share it, but i first wanted to assure everyone that we’re on it.



This only works if there’s more than 1 player in the game. If there’s one player in the game and the host has the level 0 bug, they pretty much have to leave that game. This sucks in situations like when you found a rainbow gob and wanted to invite your friends.

Honestly, nobody should be allowed to leave the office until this is fixed. Not even Bobby Kotick.

You cannot have a 10+ year old multiplayer game with FORCED ONLINE PLAY that doesn’t even have functional group joining.


Diablo III was released in May 2012. It’s 7.5 years old.


Good to know! :smiley:

If I could make a suggestion… Maybe stop starting new season on Friday nights? Maybe Tuesday afternoons instead?
Just an idea! :stuck_out_tongue:

Nevalistis already explained why they stick to Fridays…


Ha well… so the community dug its own grave hey?!
Thanks Meteorblade for digging that old post!

Bugs happen… and I don’t expect developers to be working on weekends… I mean this is America, you never known, but I hope for them they don’t! :slight_smile:

Oh well… godspeed, squash that bug!

This bug has been outstanding for over ten weeks now. It didn’t happen on a patch day or a season start / end though. It was after a scheduled maintenance on the 10th September, which was a Tuesday around a month into Season 18.


Ouch… :open_mouth: :disappointed_relieved:

1 Like

I really appreciate this Matthew Cederquist.
I have no doubt that you worked hard to get the Bnet Team to understand they caused it.

Perhaps with the main culprit in place (Bnet Team), you guys in Diablo team may find the code bugs soon enough.

Also, perhaps when future Bnet Services code is implemented the Diablo team may have a look at it to see if it is compatible.

1 Like

This has absolutely nothing to do with the Bnet services bug or join bug.

1 Like

You haven’t join the workforce yet? Or at least you are not a computer programmer for sure!

Making a software release on Friday night is generally a bad idea, because if will be at least 60 hours before any fix can be started to be worked on…