Warning:- dont upgrade tier set with socket

Upgrade it how ?

AQ Tier doesn’t have upgrades.

Literally trolling.


um… yeah, it does… if you’ve got the rep.

Hope they fix it soon.

Sockets and any tertiary stats should carry over after the catalyst is used. It worked that way in SL.

1 Like




No. AQ items don’t upgrade.

How do you even upgrade this ? The rep was required to just “BUY” the piece. Honored for a Breastplate.


It is 100% not how it worked on the catalyst in Shadowlands.

It is also expressly not how the blue post said it would work now.

1 Like

The SL catalyst didn’t destroy sockets so common sense would suggest that the DF catalyst wouldn’t destroy sockets. Also, blizz literally said it shouldn’t destroy sockets.


the dragons outside the raid.

surely my brain isn’t that fried…

I tried trying to find the items… and i can’t.
maybe i am broken.
i have no idea what was being upgraded.
i’ll just accept that i’m wrong about everything, and we can move on with life :smiley:

1 Like

It seems like the add a socket from the vault item is the culprit this time, which makes sense why it would have been missed on PTR testing.

1 Like

just found this thread (it’s in CS, which is why I didn’t notice it)

1 Like

Because you keep the ability to upgrade the piece… it is only logical it would keep other attributes like sockets and gems.

Same. It’s supposed to keep tertiary stats and enchants/gems/added sockets I was bummed

Completely incorrect. Creation Catalyst preserved item level, tertiary stats, sockets, and upgradeability.


yeah we kind of established that a day ago :smiley:

You only lost things you personally added but rolls on the item upon looting like terts and sockets are a part of the item code rather than an enchant. It’s how some people got two of the same item in raid rolls this tier.

Why are people like you commenting on things you have no knowledge of? Sockets and tertiaries stay with the item when you convert it to tier. It worked like this ever since they added the feature in shadowlands.

I find it interesting how many people are arguing with the OP about this not being a bug when he put in a ticket and Blizz said it was a bug.


Jill, run for that house!

1 Like

I should probably look this up but how exactly do you convert an item into a tier set or whatever we’re supposed to be able to do?

I dont think this dude is trolling, just one of those internet kids thats OK with spreading false info and confusing people. Makes looking things up hard sometimes cause theres always somebody like this that just spews whatever words come to mind. When called out its just “:laughing: maybe idk”

Literally an NPC/Bot, i dont believe a real person is like this


probably cause the neck isn’t an actual tier piece, and coders fubar’d it.

I did a M+ helm with +Avoidance and socket, lost the gem and kept the stat and socket as it’s supposed to.