Warning:- dont upgrade tier set with socket

Considering this is only the second catalyst?
Yes.

12 Likes

ok, i’ll go back to sleep

:upside_down_face:

i guess i don’t understand this system… with previous item upgrades, item enhancements have always been lost.

Not sure why you’re so adamant on being against this. The previous catalyst (the literal only thing to relate this to) carried over sockets. Below is the blue post confirming sockets should be carrying over.

Q: What secondary stats (Haste, Versatility, etc.) will be on the items made by the Revival Catalyst?

A: The tier pieces all have specific secondary stats regardless of what item is put into the system, only the tertiary stats (Leech, Speed, etc.), and sockets carry over.

6 Likes

/has a flash back of Mr x with “x gonna give it to ya” playing in the background

:dracthyr_uwahh_animated:

2 Likes

For real!?!?! The horror!!! :rofl:

1 Like

It literally never worked like this are you trolling right now ?

4 Likes

i guess you missed the part where i acknowledged that i could be wrong… ?

and by “never”, you mean “the past 2 months”. right?

No, I mean never.

Catalyst and item upgrades in Shadowlands didn’t remove tertiaries or sockets.

8 Likes

i can’t recall a time when upgrading a piece of tier hasn’t removed enhancements.
(i missed most of sl though)

…but again, i already said i could be wrong.

if this is how things work now, then i learned a thing.

1 Like

Every expansion with upgrades possible ever. I was 4/4 upgrading tier with Valor in Mists and if it was Warforged, it stayed Warforged.

Like do you not play this game ?

This guy’s just a sorry troll.

As he keeps being told yet keeps doubling down.

5 Likes

I didnt play the last 3 xpacs.

I just upgraded item to tier same time as my brother and his socket stayed and mine didnt.

Support said it was a bug and I wanted to give a heads up that its a known issue so others dont lose the socket like me since it cant be fixed.

Just wasted my weekly vault prize on it. Oh well.

I feel like this is deja Vu. Didn’t this exact same thing happen during the Korthia patch back in SL?

1 Like

What happened in that patch was people being able to destroy their Domination gems by inserting a new one over it.

1 Like

Tertiary stats and enchantments are carried over, or at least they were in Shadowlands. I never got around to putting sockets on gear that allowed it so idk how that worked in SL, but considering the socket items should work on tier gear I would expect the socket they grant to carry over as well.

2 Likes

how am i doubling down?
i say “ok, i could be wrong”… and you’re like “omg no, you’re wrong”… uh… yeah?
i just said that?
did it break your brain that someone is capable of admitting they were wrong? :laughing:

upgrading items from as far back as classic has removed enhancements.

By continuing the post and insist it ever worked like you pretend it did when it never has.

Stop trolling dude.

Now you’re literally just making stuff up. This is literally doubling down on being wrong.

4 Likes

You can re-socket the new tier item though, right?

1 Like

You have any idea leech/avoid works the same way?

As a Jewelcrafter, I’m okay with not fixing this bug. :wink:

2 Likes

at least it’s been reported… there are no similar posts in bug report forum

i’m amazed people aren’t rioting over something like this.

go get a piece of tier from… idk, AQ. Enchant it. Upgrade it. See what happens.

1 Like