Linux users unable to log in, WOW51900328/329 error after logging in

I posted this on the other thread:

If i had to bet money on it, the TLS header data will contain GNU TLS header and likely they are blackhole’ing that. Nice to know customers as getting screwed on this. I get you have to defend DDoS … but seriously.

Upon thinking, this botnet is likely using GPL libraries and thats what they thought the solution was. Blizzard knows damn well plenty of people use linux, they can see WINE versions from the client data (hell the anti-cheat even detects linux and still runs anti-cheat on linux), this is short sighted on their part. Maybe call a network engineer before you make knee jerk reactions.

Re posting here for people not following the large one…


If I was a company hiring DDoS protection and found out that’s the way they are “protecting”, i’d seriously ask for a refund.


Half my AddOns went out of date since launch, I had to reinstall them this week. Completely agree and hope you get everything up again soon!

Assuming they hired an outside company, yes I’d raise holy hell with NOC manager over it and get my money back…

But we are assuming that, this also could be in house techs too… we don’t know

1 Like

Another linux user unable to login, here. Fuel for the pyre


throw me on the pile, i’m having this problem too.

1 Like

I’m also affected by this. I’ve been losing my mind trying to make it work this whole time. Was very excited to get back into Classic but this DDOS business has hurt the overall experience.

OpenSuSE Tumbleweed (up to date)

I know my other friends using Windows are able to get in, but… This is borderline absurd. Attempting to mitigate a DDOS attack by performing DPI blacklisting for anyone that doesn’t use Windows is just nuts.

Tried cycling all of my network/interim equipment as well to see if it was just a stupid DNS cache issue, but the problem remains.

I know that that Linux isn’t an “officially” supported OS, but Lutris/Wine worked with the client for as long as I can remember. Is there nobody from Staff that could at least acknowledge this and see what could be done?


Yup, instant magic on my Win10 laptop. They &%$"%&$listed us >=/ Now I do demand compensation.

1 Like

I had the same thing. I was able to log into my work laptop (linux) and played for an hour or so earlier today. Thinking all was well, i wanted to switch back to my desktop (also linux). Nah… been screwed since.

I am running NixOS w linux 4.19.40 and wine 4.6 staging. login just hangs forever after selecting server then disconnects. I have no windows computer to compare with, I might try to spoof headers or something to see if its really just linux traffic being filtered

1 Like

please hit us back with the results

I’m working that angle atm too…report your results.

Me too. Linux user on wow since vanilla. I seem to recall this happening once before and getting fixed, many years ago. As of now it’s still borked for me.

Edit. Debian Sid using wine staging



Character: Mariaorsic
Classic Server: Mankrik
ISP: Spectrum (Charter Communications)

Running Lutris in Ubuntu

Patch 3.3.3 there was an issue I helped solve, it was wdlap.dll…It effect wine/windows users… I had a win patch in a few hours.

Blizzard later fixed it with 3.3.3a … I still have the emails from the programmers exchanging logs from that incident. I lol’d remembering that.


Anyone else affected try and use the WoW companion app? Seems like even from a mobile network, it kicks me off of that as well.

Edit: To expand, I can hit the character select screen of the app, but it does the same sort of behavior from the desktop client, times out to the login page. Guessing same behavior.

1 Like

still down
Realm: Arugal OCE
OS: Arch Linux

still a no go after power-cycling the whole network.
Realm: Faerlina
I use arch btw


Hmmm, there was a blue post earlier asking people to stop using cellphone hotspots to play… I wonder what the chances are that the ddos is the product of an android virus and we are being blamed by association.

The b . net app works fine for me, chat works fine so I at least can explain to friends I can’t connect to WoW. Can’t seem to complete connection (connection stuck at SYN_SENT - TCP link not open, so TLS negotiation can’t occur yet at least for this tcp link …)