Linux users unable to log in, WOW51900328/329 error after logging in

Same thing here. I got in briefly a few hours ago, but back to the error.

Realm: Bloodsail Buccaneers.
OS: Arch, Lutris
Error: WOW51900328

1 Like

I am sorry, but this is not being performed by a Kali system. It might have originated from one as a controller… but this is a botnet attack likely of Windows/Android/Mac/IoC devices. Also, all of the tools on Kali are also readily available on any distribution.

3 Likes

Absolutely those tools are available on other distributions. I’m just suggesting it may not have originated from windows-based machines. It could easily originate from a host of devices. Would never implement Kali as the one and only distro to use if you want to perform black hat operations. Also, could use any version of Linux including your own homebrew as a controller. So not…sure…why…we needed to clear up Kali…

1 Like

Can an admin please address this issue? At least a comment saying they are doing something about this =(

5 Likes

from the previous post, it comes across as if you/others are saying there a bunch of kali “bots” causing the attack instead of wording it in a way saying launched from a linux based os

Complete systemic purge of Lutris and all Libs did not solve the problem post re-install.

Manjaro 4.19 w/AUR packages.

1 Like

Can’t confirm a solution, but my attempted reinstall did through an error this time. My “esync” wasn’t set… What this means is beyond my own knowledge. However, the error had a simple guide and easy guide to setting it. From what I gleamed from this guide it appears that the esync limits the number of files your computer can have open at any given time. My defaulted to 4096… the guide suggested two hundred thousand and something (it said that was the new standard default for systemd, or something to that effect)… if you don’t hear back from me soon, you can assume that following this guide bricked my system, lol.

Realm: Stalagg
ISP: AT&T
OS: Ubuntu 18
Client: Lutris
Error: WOW51900328

Worked until today. Now I can’t connect to any server after logging in with no issues. “Netstat” run while trying to connect to the realm shows “syn_sent”, and it gets left hanging…Firewall behavior.

I would find it to be a real shame if Blizzard decides they don’t want our money…

2 Likes

Sorry for confusion everyone, I was just mentioning in previous post that the software available to stress test servers is included in Kali linux among others and would not be surprised if it originated from a linux-based system. For those that were confused please refer to my previous statement.

Also, Malrun thank you for update on purging and reinstall - that’s helpful to know saves me from doing it. Also, Shift, I hope your system isn’t bricked bud

1 Like

esync should be local only and not effect your online gameplay that much if at all in this case as its more directed at the CPU. Esync itself is enabled natively for WoW in Lutris. If you are using this you can test by simply entering the config and clicking the slider under runner options. It should be noted that esync itself is about removing the Wine overheads rather than about your network connections.

1 Like

I ran a Wireshark on the client… to destination/from destination server (IP redacted)

So the basic stream here…long log simplified.

TCP IP connect > SYN/ACK starts Key exchange > Main Logon server accepts > TLS1.2 stream open to game server… > String of 10-15 ACK requests (connection) and TLS Client Hello Strings (attempting connection) > Re-attempts MANY times… Fail

No SYN packets from Game server AT ALL… I’m not a master network tech, I held a CCNA a long time ago, but in my analysis of the data I have (multiple run attempts) that this is classic black hole. Just drop the connection with no connection attempts made from the server.

We are being blackholed. Sorry to be the bearer of bad news (run wireshark to see).

13 Likes

You are correct. This is my analysis as well. I believe we are being packet dropped as of this time.

3 Likes

Thanks for the information. That’s exactly what I thought was happening. As it stands I don’t think there’s any solution unless they add a whitelist.

3 Likes

Ubuntu 18.04 - Lutris/Wine
WOW51900328

Windows PC on the same network working fine.

Unfortunately, I now lost all of my addons and settings doing it. Guess its time to update them anyways if the game will come back for us! To quote a wise individual in this thread before though… “No Tux, No Bux”

3 Likes

Guess that means we’re expendable

1 Like

I was able to log in earlier today…once around 4PM MDT IIRC. I thought that the DDoS was a bigger problem as have yet to been able to login since that one time. I don’t know if this is the same issue or not?

I should have stayed in Zuldazar as everything was just fine there - was able to do a quest, move inventory around… until I tried to boat to Boralus (instance not found) and tried to fly to Nazmir where I got disconnected and can no longer log back in.

Gentoo Linux ~amd64 app-emulation/wine-staging

Never ran Wireshark to scan Lutris, thank you for the idea. Has been a long time since I’ve played around with it. I’m getting the same string of 6 ACK requests that try to connect and fail - repeatedly and then it disconnects with the error. Not a network guru or hacker but can confirm what you are seeing on my end with Pop!_OS and Lutris

2 Likes

Currently copying the files to my Windows work laptop, will try once it’s done and report my findings.

Welp, no luck with my reinstall. I’m still stuck at the same spot everyone else is. That said, setting my esync hasn’t bricked my pc… yet, anyways. So that’s a plus. Imma try digging through some config/log files to see if there is anything that could possible be changed. Still got a couple hours before beddy boo time and no westfall knolls to slaughter.

1 Like