Linux users unable to log in, WOW51900328/329 error after logging in


#1

Has anyone else had any problems with being unable to log in under Linux? There were quite a lot of us in the other thread: 9/8 - WoW connection issues. I thought it would be a good idea for anyone new coming here to see this thread and post if they are having similar problems.


Sept 8th-12th 2019 - WoW connection issues / WOW51900328
Linux Login Solution 2019-09-09
Blue Response please to Linux users being Blacklisted
Sept 8th-12th 2019 - WoW connection issues / WOW51900328
WoW Companion App stuck on Connecting after 8.2 update
#2

I mean Im getting the same error, but on Windows 10. I think it’s just a general issue.


#3

Yup, Lutris/Wine – Arch

Server - Westfall
Error Code - WOW51900328
ISP - Comcast


#4

Seems like a lot more Linux/ Litrus/ Wine users having the issue compared to Windows/Mac users.


#5

Pop!_OS and Lutris cannot log into any server including retail bud.

Unfortunately I see a server list but am unable to log in to any of the servers I use. Same type of WoW error.

WOW51900328

Apparently this means I am a hacker and am blacklisted :slightly_frowning_face:


#6

Can confirm, getting error WOW51900328 running on Ubuntu 18.04 via Lutris.


#7

Manjaro with Lutris
My guess is we are being blacklisted with whatever DDoS protection services they are using. Great stuff, blocking real customers.


#8

Solus with Lutris, same problem.


#9

Running Ubuntu 18.04 LTS with Lutris, No problems until today when i tried to login for the day. Realm: Remulos Char: My current name.
Getting the Common WOW51900328 error.


#10

I’d like to add, I was on at 730pm config’ing addons …and everything was well…since 930pm its a total mess.


#11

Server - faerlina
Toon - Tsochicken
Error - WOW51900328
os -Ubuntu 19.04
wine version - 4.15
dxvk version - 1.3.4
ISP - ATC - Fiber

been playing all week without any issue till this weekend

I’ve cycled my router, no luck. was hoping to do some questing today but its looking like I won’t be able to :frowning:


#12

Ubuntu 18.04 lts using Lutris.
Retail-Draenor
Classic- Mankrik
Error-WOW51900328
Can’t log in to either retail or classic. Just started today.


#13

Same here, Lutris on Arch


#14

I have a weird feeling there’s going to be an issue with this unless a whitelist is implemented. I say this because I was having this issue from about 4pm est - 5:30pm est. I finally got into the queue at around 5:30. Next thing you know servers are being DDoSed around 6pm. Around 7:30pm the DDoSes stopped. but were all back to getting the same WoW error.
Edit: The whitelist would have to be account based and not IP based because I assume most of us are using VPN’s


#15

WOW51900328 running on Debian via Lutris. I can share my pcap’s of my sync packets going out and not being returned (sync/ack). Most likely being dropped on your end when they arrive.


#16

Can confirm on Linux side. Will install windows on a laptop soon to verify traffic. If found to be true I will send out to the major Linux websites and get the word out. No point in subbing what we cannot play. People should be warned before they try as current information points to WoW being playable as such in Linux. I know many are just like me and would rather unsubscribe than install Windows to play, just will not happen outside of this test.

EDIT

Manjaro - KDE 4.19
Lutris Wrapper Client


#17

I believe your account is probably “flagged” right now so It probably won’t work on Windows either.


#18

Trying a complete removal and reinstall of the wine prefix now… I had used the lutris world of Warcraft classic installation installation link, and was going to try the world of warcraft retail installation link this time. However, the retail link is currently not working. I’ve read through the retail installation guide’s docs a little and it appears that some of the files can get corrupted. It requires a funcky copy and paste job to easily fix… Long story short I don’t have a working windows copy of world of warcraft to get those files from so I’m trying a complete reinstall instead.

Maybe the lutris installation was compromised. The only other thing that changed this weekend for me was that I opted in to using addon scripts (started making some macros). Maybe something was hidden in the installation? I didn’t even think to check my addons folder for addons that I didn’t myself install.


#19

Linux Mint 19.1 Cinnamon + Lutris
Cannot connect to any Realms
WOW51900328


#20

No Tux, No Bux