Sept 8th-12th 2019 - WoW connection issues / WOW51900328

For people following, on the linux thread we are getting duplicated Wireshark results on the blacklisting of the client connection…

If someone has the knowledge i’d love to have this confirmed on a Windows or Mac effected system.

1 Like

No one said it’s Linux users only, we’re saying some people are illegitimately being blocked, and as it happens all the linux users are part of that group.

3 Likes

Venatic @ Sulfuras

WOW51900328 Disconnects after realm selection

Verizon ISP

Yeah, I haven’t seen a single linux user that it is working for. Would be nice if we could get some feedback from other linux users.

1 Like

People without issue don’t know that there is a positive case to report. We’re biased in here otherwise we wouldn’t be here.

1 Like
1 Like

Yup, instant magic on my Win10 laptop. They &%&$listed us. =/ Now I do demand compensation.

(Eeep, i was quoted! lol)

I have 2 Win10 PCs. One works and the other does not.

On the one that will not connect I have done just about everything but reinstalled WoW and Windows. Same error on Classic and Retail.

I run WoW on Pop_OS via WINE / Lutris through a Comcast connection.
I’ve been experiencing this error since the servers first crashed approximately 9 hrs ago. Seems like no one else in my group of friends is getting it.

I have power cycled my router (not that there is any problem with my home network); I’ve also tried renewing the IP on the host machine (not that there’s a problem with the internet connection on the host machine); ran the file checker on the blizzard launcher; and I’ve also attempted reinstalling wow. I can confirm that this is affecting Clear Linux with wine as well as ubuntu (no surprise). I can also confirm this is affecting all three of these machines even though only 1 of 3 were online in wow at the time of the attack.

Windows 10 laptop… NO luck here,… I wanna play, but nope. Been fine all week, but now that I have time TO play… yeah.

Able to select server, but get disconnected after sitting at login dialog.
Server: Bloodsail Buccaneers
Error: WOW51900328
OS: Ubuntu 18.04

1 Like

Any chance you could run a Wireshark (free open source network traffic recorder) as you try to connect.

I’ve compiled a few captures from multiple machines/Linux versions and would love to cross-ref a Windows box.

1 Like

Still getting the same WOW51900328 error after trying to load into my character list on MYZRAEL realm classic, been unable to for the past 8 hours now. See many people on my server online and its becoming pretty irritating that some are allowed to play while others are blocked out.

There are also entire countries like Malasya and some ISPs being blocked. Im in Mexico and not a single person using TotalPlay (2nd biggest ISP) can connect to battle.net - using a VPN allows access without a problem. whoever was in charge of fixing this during the weekend just straight up banned a bunch of IP ranges, DNS and connection types to block the ddos. This needs to get fixed tomorrow morning, its ridiculous.

2 Likes

So I tried using tunnelbear to connect to both classic and retail and it worked. Blizzard is blocking my ISP (Verizon) for some reason. Hopefully they’ll refund a few days of gametime because they made the game impossible for us to play.

3 Likes

aww man, I ain’t payin’ extra, that’s insane, come on, Blizz’!!!

OS: Manjaro KDE 5.2 Kernel
Realm: Grobbulus
ISP: Spectrum & VPN (Same error w/wo VPN/firewall)
Error: WOW51900328

Same here, Mexico got TotalPlay which is a huge ISP blocked entirely, vpn and other providers work fine

Been experiencing the same error for the past 8 hours (also a *nix user fwiw)… guessing someone pulled out the banhammer against a slew of ISPs & connection fingerprints in an attempt to mitigate the DDoS, and we’re just collateral damage. It’s absurd for a company this size.

OS: Fedora 30 (running Lutris/Wine)
ISP: Spectrum
Error: WOW51900328 *

Edit: Should also note VPN does not help - guessing it’s more likely Linux being targeted.

It is absurd.