Dark Portal to Outlands not working

I found some posts from March that posted about the Dark Portal not working when trying to go to Hellfire Peninsula, namely this one saying it was a known issue with a link to an article.

However, that article doesn’t show up for me and it’s still a problem. I have talked to Zidormi so that Blasted Lands are in the correct time (green portal), but it still doesn’t work. What can I do?

3 Likes

Hey man,

Since that was a temporary issue that has since been resolved, the related article was deprecated. That said I’d like to know if any error pops up when entering the portal, or if the character just goes through it like it’s not there.

As a note please be sure to dismount and walk through it instead of flying. I have seen a few cases of players flying through the top of it not procing the instance change. Walking on the ground should resolve that.

Definitely post any screenshots you have of the portal not working if possible. Example: imgur*com/abc123

2 Likes

I just fly through as if it’s not there. I tried walking through, that didn’t work either.

Here are some screenshots.

imgur*com/a/FT354tV

It should be noted that when I went back to do this, I had to ask Zidormi to go back in time again even though I already asked her to do that a few hours ago. Not sure if that’s supposed to be happening, but thought it might be worth noting.

Hmm, I logged into the character and tested this. Same thing happened! I’ll move the thread over to our Bug Report forums.

Thanks for reporting this.

5 Likes

still not working.

just noticed it because of the event daily that has me go kill a mob on the HFP side of the dark portal. i can’t get there from the blasted lands, but i can use the portal on the HFP side to get back to a capital city

3 Likes

Just replying to say it’s not working for me either.
I’ve talked to Zidormi to get the old zone so the portal is green, I’ve tried flying through the portal and I’ve tried walking through the portal to no avail.
Tested it today on this character, Moon Guard 3:30-3:36 server time.

1 Like

Still not working as of today, 10/25/19. Tried walking as well as flying through…

Still not working 11/24/19. I have seen people go through it, but i am unable to on my characters. Restarting doesnt work. /reload doesnt work. Please fix this.

Not working for me either. It works in the “new” zone to take me to Draenor, where it locks me into the first zone there. I’m going to try completing the quest to see if it resolves the issue.

This is ridiculous that this has not been fixed. This has been almost a year since it’s been reported. This type of customer support is why your company loses players. You need to fix bugs in previous content zones too when they arise. I report them all the time in game when I find them. Apparently it’s a waste to do so if it’s never going to be corrected.

2 Likes

Issue still occurs (Jan 2020). This is unacceptable considering how many portals were removed in a patch this expac including ALL the portals to Hellfire Peninsula which previously existed in the mage trainer area of EVERY major vanilla capital city. I concur with the above poster. Not fixing things like this shows a real disregard for the player base. Farming to try and complete my looks collection is already painful enough with the amount of boring walking through raids I’ve done literally hundreds of times before on my account (mostly before looks collection was added) without the added annoyances of being unable to get around quickly because Blizzard either removed the portals or in this case just leaves them broken.

Steps taken that did NOT resolve this:

-Tried walking through on ground mount instead of flying in with flying mount
-Tried dismounting and walking through on foot
-Tried relogging

I still find myself sitting for a minute or two trying to figure out paths to places I would have been able to get to in my sleep (and quickly) before the portal removal and I guess I had better commit to memory never to try and use the old dark portal now too.

1 Like

Bump. Fix this PLEASE.

yep, still not working :frowning:

1 Like

STILL NOT WORKING! 2/21/2020…fix it FFS

Have you guys tried taking the portal to Shattrah City from the portal rooms?

not working 3/23/2020

This is very embarrassing for blizzard i’m sure.

1 Like

Wasn’t it made clear years ago that the dark portal itself would be disabled ever since the iron horde invaded?

It no longer works because it was intentional ever since warlords of draenor began.

2 Likes

Still not working, fix this.

4/21/2020 still not working, this article sums up bfa

Would love to, but unfortunately after my faction change, the portal room is not supporting anything. As well as cannot get the quest line to unlock said portals. So I’m stuck in a loop of unforgiving.