Classic TBC Prot Pally Threat Issue

@blizzard please stop working on stuff for the in-game store for a moment and fix this bug…


I thought this thread may have been a joke but it’s not, it’s a bad joke. Somewhere between Saturday morning and now, something happened. A blue post would make me feel a little better knowing that it’s being looked at.


none of that helped me at all, i re logged trying to “temp fix it” atleast 6 times per instance today, my 0-1k threat per consecration is border line unplayable, they need to blue post it and fix as soon as they can i was on the final step of kara attune :frowning:

1 Like

This isn’t even a dungeon specific issue, I’m getting close to no threat from it in world or dungeon. Just ran the most miserable shattered halls of my life. I watched a ranged mob sit in 3 consecrates and I never passed up heals on threat. Targeted him and tiny threat had him in dbl digits for me.

Guess I’m done with tanking for a bit, thanks Blizz!

1 Like

We really need a Blue post acknowledging this. It’s a major issue.

Is Consecrate all of our threat? No. More like 30% depending on the pull. But 30% is a huge deal, and it’s way more noticeable in places like Black Morass where the adds spawn and just walk through your consecrate with 0 threat generated. In other dungeons, it may not be noticeable if you’re tagging everything with Avenger’s Shield at first, so PUGs and even guildies are thinking ‘well gee, I haven’t seen these problems with pally tanks in Bot, Mech, etc.’

Need a Blue to acknowledge the bug and then need a fix ASAP. It’s like playing half a character atm.

1 Like

This would explain a lot.

Do any of you guys have a mage alt? I’m wondering if the issue is the way the game assigns the threat from a ground effect like consecrate to the player. If that is the issue, then this should be affecting flamestrike as well. Some testing there might clear things up.

Flamestrike ground effect causes threat. But so does consecrate sometimes, I would probably need to test flamestrike long enough to give it a fair test.

If we can get enough people to test flamestrike threat and confirm it affects that too then that is good evidence towards my hypothesis that the game is somehow failing at assigning threat back to the player when damage originates from a ground effect spell. If that isn’t it then it must be something specific to the consecrate ability.

I was wondering why my threat was randomly just non existent. Made for a real embarrassment on the first boss in Kara this week. Which should NEVER be a problem since he’s undead.

1 Like

“Working as intended” As a pally tank I am not enjoying Conc being useless. Especially with the 2 set of Righteous/Libram…

That would explain the random threat loses in the second half of SP on my pally last night.

Same issue here. Hopefully this gets fixed since the only reason I’m playing Prot is because I can tank easily in dungeons…

We’ve been working on this issue since it was first reported Saturday night, and this morning we’ve now found a good way to reproduce it so that we can continue toward finding a fix (hopefully).

Thanks to everyone who reported it with details!


thank you!!!

The bug is from dying inside of TK dungeons, as soon as you are forced repsawned the trigger happens and ground effects no longer cause threat

Hi Kaivax,

My group was able to reproduce this bug pretty consistently last night. Through experimentation, we also discovered that the bug itself is also tied to Righteous Fury. When Righteous Fury is on, Consecrate generates no threat. When it is off, Consecrate DOES generate threat. Dying while Righteous Fury is on is the cause for the bug, at least for us, and it didn’t matter if we were in an instance or not.

The temporary fix for this was to have the tank exit the game client and wait for 60 seconds before opening the game client again and coming back. That fixed it every time.

I hope this helps!


The problem is just dying itself with RF active not TK dungeons. Ran Kara last night, died and consecrate no longer generated aggro causing my mage and warlock to die on trash a few times. Logging out and back in after waiting upwards of a minute fixes the problem until you just die again. My brother and I ran a Heroic Shadow Labs and after my first death after relogging my consecration generated no aggro again which made me close the game and relaunch after every single death.

I have noticed this as well, even when I pass somebodies threat it takes multiple second for the mob to actually register me as the top threat and go after me, it is confusing the crap out of me provoking righteous defense uses or me chasing mobs who just simply dont acknowledge threat for a little bit, pulling me out of position…etc.

I don’t think it is. I’ve wiped in Mechanar and had no issues with threat the rest of the dungeon. Meanwhile, I’ve not been able to do a BM in 2 days because I generate no threat on the portal adds and the priest healers just rip them off me with 3k heals.