AMD Radeon 7000 Series Constant Crashing

1 month old 7900 XT. Randomly in game, screen goes black (usually during a dungeon pull or something significant). Drivers crash, black screen resolves itself, goes to desktop after 10-15 seconds.

Happens frequently. I have tried literally EVERYTHING HUMANLY POSSIBLE to resolve this issue.

What gives? Game is borderline unplayable because I’ll end up griefing my groups.

3 Likes

I have this same problem, same card. Happens in other games too. The only fix I have found for this is to use the AMD Driver Cleaner tool to completely uninstall all drivers and AMD’s app, and when you reinstall click the other options button and do a driver-only install. Something about their app or the postprocessing it does is causing this, and it fixed it for me 100%.

I’ve tried literally everything man. That worked for about a day and a half before crashes started again.

2 Likes

So I was having the same issue I read in another forum that going to C:\Program Files (x86)\World of Warcraft_retail_\GPUCache and delete the files in that folder. It so far has worked for me.

This worked for 2 days for me, then the crashes returned. I swear the issues came with patch 10.1.5

There’s literally nothing that will fix this issue outside Blizzard or AMD.

You can reinstall, disable this, disable that, enable something there, uninstall something here. Reset OC, disable EXPO I can go on and on and on.

There is no permanent fix. Nothing we can do.

3 Likes

My wife had this same issue with her 7900xtx. She would constantly get a “driver timeout” issue several times a gaming session. This is apparently a relatively common issue with AMD cards that I wasn’t aware of.

On a side note, somewhat related or unrelated. I am unable to start wow using Directx12 and an AMD 6700s. The only solution is to run wow in Directx11. This could be something you can try to help fix the crash.

1 Like

Doesnt work for most of us, seperate issue. This issue many of us are having is specific to DX 12 and started specifically with patch 10.1.5 and after. Would love to see some more news / updates on this issue as it seems to becoming more and more common of a problem for AMD users with every patch.

At this point I’m trying to duplicate the issue. It is indeed random, however here are some hot spots where crashing seems to be consistent. I have never crashed in the Raid as of writing this. I have also never experienced crashes prior to 10.2.

As of writing this, after the first crash, no crashes will happen for the remainder of that Instance. If I do dungeons back to back (e.g. DOTI —> BRH) I will experience a unique crash in that new dungeon (same play session).

Open World - Valdrakken. Standing AFK by fountain, 1 crash, has never replicated.

Dungeons: not listed = never crash

  • Dawn of The Infinites - Guaranteed Crash. Most often in the “Open Sandy Zones”, this goes for both halves of the dungeon. This crash never occured during 10.1.7.
  • Black Rook Hold: Before first boss, and during small goblin area before final staircase. I also had an event occur in BRH that caused a total driver failure and PC crash.
  • Everbloom - After first boss or turning “right” after the start of the dungeon, narrow hallway area before second boss.
  • Throne of Tides - It has happened twice, can’t recall area, think it was one of the two “straight” hallways.

My PC is fine, components are fine, drivers are updated, fresh install, etc. I can play Cyperpunk on Ultra for 7+ hours straight, same with Huntshowdown (which has a jank engien btw). I can stress test the PC for multiple hours. There is NO OC present on my PC outside my EXPO/XMP profile (yes I’ve tried disabling this). Nothing works.

MY crashes happen within Arena instances but doesnt seem to be specific to any arena map, has also happened in valdrakken once. After a crash it doesnt happen again until a computer restart, tho when the driver crashes FPS drops occur and choppyness.

Howdy!

We are investigating a possible driver issue with AMD GPUS that impacts the game’s ability to launch with DirectX 12.

The first step I recommend is to clear the shader cache following the steps Here.

Then launch the game with directX11 API:

  1. With the Battle.net desktop app opened and WoW selected click on Options
  2. Select Game Settings
  3. Find WoW and check the box for Additional command line arguments
  4. In the new box enter the command for the desired DirectX version:
    -d3d11
  5. Click Done to save.

NOTE: With DirectX 11 FPS may not be as high as expected, you can lower graphics quality settings to counter this until the issue has been resolved.

Thank you.

2 Likes

This issue doesnt apper to be related to the one your refering to, many of us dont have issues starting wow with dx 12, only having issues the driver crashes while using dx 12 randomly during gameplay. DX 11 has been the only solution that has worked for us and this has existed now since patch 10.1.5. Since that patch things have gotten worse with other dx 12 issues that have popped up aside from the ones were having.

Prior to playing on patch 10.1.5 these issues for me never once occured and there was never once a driver crash using my 7900xt. I had many months of gameplay and hours without one issue. Then 10.1.5 released and i started having gpu driver crashes regularaly, at least once every other day sometimes more. These issues have never occur in any other game on dx 12 eve nto this day.

1 Like

The game launches fine, myself and thousands of other players seem to be experiencing the game CRASHING randomly, with the GPU driver failing/restarting.

Please read my original post for clarification.

Keep having the same issue, ryzen 7800 x3d, gpu 7900 xtx, tried with dx11, keep crashing during raid.
Got the error CAECB385-D29B-462D-8F3E-4DB4AB32D1F1 when the game just close

Would love to see some sort of update on this issue, its been a problem for many months now.

2 Likes

this has been happening to me since i got my 7900xt in march. happens in classic and wrath as well. its about a 1 day a thing now were game freeze, black screen, then recovers shortly after. reported it many times with amd’s tool.

classic and retail also failed to load in dx12, were dx11 worked. dx12 did work just letting it load but took a few mins. never cleared gpucache

It’s likely on the AMD driver end of things or some incompatibility issue between the driver and Windows. Another example of games doing annoying stuff like this: The last time I played OW2(dx11 game) with an AMD card earlier this year, almost every single time I’d boot the game, it would spend the first 2-4 minutes compiling shaders where my CPU usage would be like 80-100% on a 13600kf. After it was done, the game ran like butter. It had been like that for months after some specific driver version. Oh and the game would take like 30-60 seconds to fully close out from RAM if you watched the task manager.

Blizzard might be able to implement some workarounds on their end, but what would be the point if AMD fixes it soon. Not trying to sound like a downer, but AMD cards are only around 16% of the GPU market(steam hardware survey) and it might be a lot of expensive work on Blizzard’s end to code in and test some workarounds.

We have a PC in the house with a 7900XT, so maybe I’ll test this all out on it.

1 Like

I wonder if it’s a general Blizzard game issue because I’ve never had this happen with any other game.

Play more games then, I remember seeing similar issues across the board with AMD cards when I was using one. Just google AMD shader stutter and you’ll see an almost innumerable number of posts about it across many games and all the way up until today. Obviously, games that do a large chunk of shader compiling at launch are going to feel it more when you launch them, but I’d rather deal with that than when games have to build them constantly on the fly while playing.

In terms of WoW, OW2 and D4, I don’t think any of them really share any core rendering thread code.

2 Likes

This issue has not occured in any other game since i got the card a year ago, the only game that has a driver crash has been WoW and only while using DX 12. This issue started with the release of specifically patch 10.1.5, it never one time ocurred prior to this patch. Since then there has been an influx of forums posts related to the issue.

Im not saying the issue couldnt possibly be an amd specific issue but what i am saying is the issue seems to be isolated to specifically AMD and WoW and only during patch 10.1.5 and after. Something changed that cause this issue to start and with enough reports id hope its something blizzard could work with or send information to AMD about such issues. But we cant rule out the possibility that the issue is on blizzard end either, considering using DX 11 this patch came with memory crashes as well.