Compiled 10th Anniversary Achievements Tips / Issues / Bugs

Is it possible that some of the regular achievements are bugged now because of the 10th anniversary release? I’m unable to get the “Crash the Party” achievement for the heart of the swarm campaign, is it possible that neutral buildings now count towards that achievement? How do you use the level editor to verify/confirm that theory?

Is it possible that its bugged so that cheats permanently disable achievments for the campaign? I used tooktheredpill to reveal the map, and then loaded the save, which is the same thing that has prevented me from earning any WoL 10th anniversary achivements - I was able to earn them fine until I used the cheat (and yes, I did load a save that had never had cheats used before completing the mission)

What usually makes Crash the Party tricky are a couple out of the way Missile Turrets.

In the lower right of the map is a small base that has two turrets, one of which is on high ground so ground forces can’t see it. Also, near the east-most entrenchment/gate, there is a single turret that is also on high ground.

As for cheats, it’s hard to say. There’s a couple theories out there about how to undo them, but I’ve never experimented with them enough to find out exactly what happens after using them. If you confirmed that all structures, including those out of the way turrets, were destroyed with a cheat, it’s possible that it is interfering with the achievement.

In this case you can open the mission in the editor, then open the Trigger Module. From there you need to find the triggers, variables, etc that govern the achievement. Looking at the Crash the Party achievement trigger, it’s only counting enemy structures. But, the way the trigger is coded it’s a bit interesting. I’ll have to do some test runs to see what the code is actually trying to do.

EDIT: All good. Everything seems to work as it should.

That certainly helps. I was FAR too frustrated with the “Disintegration Doctrine” achievement. I can’t stand the “speed run” style achieves as it is, but this buggy achieve had me steaming because I knew that I had satisfied all of the requirements with time to spare. Utilizing the information from the video, I was able to “earn” this one by leaving a structure until after Narud’s defeat. Thank you (because this bug sucks)!

“Disintegration Doctrine” unlocked after I killed the Raven at the 11 o’clock AND 1 o’clock corners of the map.

I had to retry the mission a few times because of the very structures that you highlighted, the cheats helped me find them.
The score screen shows how many structures you killed, so I know I got them all.

it won’t let me post images, but I uploaded a screenshot with proof to postimage.cc / Pvwx9ynq

Really not sure why I did not get the achievement.

1 Like

Just to be sure, you are playing it on Hard difficulty, correct?

Yes, I was playing it on hard.

To the German and Polish speakers out there, are either of these fixed?

From understanding, there is a minor bug (we haven’t tested extensively yet) when you use cheats. It is possible that loading a previous game will still allow the cheat to remain enabled (thereby disabling achievements).

PS: A side note which is the link you posted does not lead to an image site, but rather a scam / trojan website. :frowning:

[UPDATE 24 AUG 20] A new patch has been released addressing all the rest of the bugged achievements.

I have updated the first post to attempt to cover most of the concerns, etc so that it is easier for anyone to just look through it rather than scroll through comments. Please tag me if there is anything else I need to amend.

Hidden Victory doesn’t register for me. I even finished it without warping anything in (not even probes or other DT) but still does not register.

Can you describe more regarding:

  • Which campaign the achievement is in?
  • Which mission (maybe a rough description of the mission)?
  • What is the achievement?

There are simply too many to recall, haha.

And at this point in time, there are many who have gotten the achievement, so it is more likely that you made a mistake somewhere. Or the bug wasn’t patched heh heh heh.

Hey Kyrie!

I tested out the new 5.0.3 Disintegration Doctrine. Raven’s Auto Turrets still fail the achievement.

I suspect that because they are classified as structures, and that Bliz didn’t exclude them in 5.0.3, it’s intentional. It may now be less of a bug and more of a tip to make sure they are all destroyed before defeating Narud. Especially any in the 11 and 1 o’clock bases because 1) they are dark in color, and 2) they are under the dark Void Clouds, making them difficult to see.

The description for this one was changed with 5.0.3:

Destroy all Protoss structures before activating a 4th Temple…

“Hidden Victory” achievement:
Complete the “Legacy of the Void - Amon’s Reach” mission by constructing only Probes and Dark Templar on Normal difficulty.

As I have attempted this a few times already, - including one time where I built nothing and just used the 4 DTs that you start with - I am very sure. There’s no mistake.

Update: Actually, disregard this, for some weird reason, the notification didn’t show up but the achievement now registered.

Same issue with “I’ve Fallen and I Can’t Shoot Up” achievement:
Complete the “Unsealing the Past” mission by construction only Probes and Colossus on Normal difficulty.

Update: Actually, disregard this, for some weird reason, the notification didn’t show up but the achievement now registered.

If you press ‘esc’ to skip cinematic, you might have closed the achievement notification as well.

Struggling with this one. Thanks for the tips, will report back.

Having trouble with “Purification”.

The Core Matrix didn’t even take shield damage when I tried it and it still didn’t count.

Also, some SoA abilities like Solar Lance still trigger fail conditions for “Templar’s Charge”.

Through test maps, it’s been confirmed that the three SoA abilities aren’t failing the achievement anymore.

I’ve created a test map that will alert the player in real time about what is causing that achievement to fail. If you want to try it, it may help you figure out what’s happening and where during the mission.

Thanks - got it. A ton of saving and reloading. But managed to get it with maybe 1 second remaining on the timer!