Compiled 10th Anniversary Achievements Tips / Issues / Bugs

There’s been a couple reports that it will fail the achievement. I’m going to look in the triggers to see what the situation is.

UPDATE: Confirmed, losing structures in the cinematic does fail the achievement.

What sloppy triggering. It literally takes a few extra conditions max to make sure you’re actually counting the right things. It’s not hard.

This is a AAA game company? I could have created these achievements on a weekend.

2 Likes

Dude take a chill pill, they are doing the best they can with limited team size that Activision has given them.

I, for one am actually pretty impressed with all the new content they gave us with the resources they had.

What are you impressed with? The fact that even after the bug fix patch a bunch of the achieves still have rookie programming mistakes that even high schoolers wouldn’t make? The fact that we’re always the beta testers instead of patches/games working out of the box? The fact that random forum posters have to literally find the flaws by going through the editor themselves even though the team has made dozens of achievements by this point and should ostensibly know how to program them by now?

You can be easily impressed if you want, but Id rather retain the ability to think for myself.

3 Likes

My reply had nothing to do with Blizzard, or the team size, or my thoughts on the new content. It was to find an answer for SoulFilcher O.o

Edit: Unless you didn’t mean to quote me.

In my opinion he misclicked, while he reacted to Gradius.

1 Like

Oh! Good point!

I mean, the editor updates are really impressive, but damn, who worked on the achievements? :face_with_raised_eyebrow:

1 Like

Having issues with Templar’s Charge achievement (don’t lose any units). Just completed it for the 3rd time. I literally saved after every single fight and counted all my units and I am 100% certain no units or structures died other than interceptors. My spear abilities are chrono surge, orbital strike (which I did not use), nexus overcharge, shield overcharge, reconstruction beam, and time stop. Don’t believe these are any of the bugged ones. I also tried getting all resource pickups, did bonus, and destroyed all enemy units and structures. I used carriers, corsairs (used disruption web) and arbiters (used cloak and recall).

Edit: also I am on brutal

I heard that doing the bonus invalidates the achievement.

The bonus doesn’t effect it. That was a hypothesis near the beginning, but with the research and playing that people have done, it’s confirmed not.

I made a test map that reveals both when the achievement fails, and what caused it. If you want to give it a try, it may help you figure out what’s causing the fail so that you can avoid it in the real mission.

Templar’s Charge achievement:

Use void rays only.
Don use cariers because you will lose interceptors witch are units.

Just got it after day of trying all kind off things

Thanks for the link. I still can’t identify the issue. I did confirm that corsair D Web, arbiter stasis, and arbiter recall did not cause a trigger.

The test map tells you what the issue is. The only event that can fail the achievement is if something of yours dies. (With the exception of the three SoA abilities bug.)

So if you didn’t get any popup messages during the mission (and you did get the conformation message after the end-mission cinematic), nothing of yours died and you met the achievement criteria.

Came back and realised there are still issues haha.

Is there a quick summary for me to update the first post?

Hey Kyrie!

Bliz did fix 5 of the bugged ones. A 6th fix was attempted, but there turned out to be a secondary bug that was hiding:

WoL:
FIXED - Contract Saviors
FIXED - Band of Brothers
FIXED - Thanks for the Advice

LotV:
FIXED - Annihilation Now
FIXED - Warp Incomplete
ATTEMPTED FIX - Expert Phase-Smith, Perfect Templar - Interceptor deaths has been fixed. However, there is a secondary issue with three of the SoA abilities. (Explained in my Bug Report thread below.)

A New Bug List:

After the first patch, I made an new bug list for anything that was still an issue/a new issue. These are only those that have bugs or clarity issues, not so much those that are just trickier to do: 5.0.2.81102 Consolidated 10th Anniversary Achievement issues

A Video:

For Disintegration Doctrine, I made a video for both Bliz and the players. It breaks down at a technical level why it’s so inconsistent. However, players who are only interested in the demonstration can jump right to 6:50. https://youtu.be/VyEwm_0l3T4

A Test Map:

I made a test map for Expert Phase-Smith, Perfect Templar. With so many people having trouble with it, I inserted real time alerts that pop up on the screen for when and why the player fails the achievement. That way, if they were missing something, they could correct it when playing the real mission. Expert Phase-Smith, Perfect Templar Troubles? - Test Map

2 Likes

C’mon blizzard please, fix these achievements.

How hard can it be to QA such basic things and fix them in under a month…

Yeah, meant to quote Gradius, my bad.

1 Like

I have updated the first post to cover all the new “bugs” with instructions on how to overcome them.

For anyone else, please let me know (and tag me) if the first post needs editing.

For Big Spear Diplomacy, of the six SoA passives, the culprit is confirmed to be Reconstruction Beam. The other five passives are safe to use.

1 Like