Main Thread - Movement keys sticking since last patch

Mouse: Logitech hero 502
Keyboard: Logitech G610
Uninstalled razer and Logitech software, didn’t solve it. Sent file.

1 Like

Maybe it has something to do with power management settings. Try this:

still having this problem, was playing for years til this newest update gave me this problem, only happens in overwatch, i dont usee any third party programs, is the only thing that starts up too


I am using a Logitech G502 mouse, I have reinstalled the software but still have issue. I have tried a brand new Microsoft Ergonomic keyboard, and I have tried two different DELL L100 laptops. This all started with the patch last week (not the patch from yesterday)

Having the same issue with keys sticking when they are not stuck. Thought it was my keyboard and went out and bought a new Corsair and it is doing the same thing.

Hey folks,

Around when this started, we implemented a new setting for mouse pointer precision. As far as we can tell there’s SOMETHING going on with some kind of mouse incompatibility with these frozen commands, so we’re trying to gather info on what works around the problem to see where the issue lies. We’re still gathering data, which is why we’re asking these questions. They’re not so much intended to be “fixes” as help us answer the question of what to look at for a cause.

Can you try turning on the High Precision Mouse Input setting?

This setting can be accessed by:

  1. Opening your Options on the main menu or in game menu
  2. Choosing the Gameplay tab at the top
  3. Scrolling waaaaay to the bottom to enable High Precision Mouse Input

Let us know whether or not this works for you. We’re also curious if other mice work around the problem, if you have different mice available to test on.


im on to my third game after enabling this feature, seem to have fix the issue. ill let you know if im wrong.


It does fix the problem, but the “crouching bug” becomes an issue for me when I turn it on. By the way, I use a Logitech g203.

It does work!! Thank you so much! I was so frustrated and angry because of this, I even thought i had broken my new gaming gear ;n;

1 Like

I run the built in keyboard on my Dell Laptop, and I run a Black Web Gaming mouse. I thought my laptop keyboard was breaking! I didn’t have these issues when the high precision patch rolled out. However, with this newest patch for Mercy LTE (limited time event) I noticed it like craaaazy! I ended up constantly just spamming my inputs to make sure they would receive the stop command every time. This have never been a past issue.

Also, the patch in between the high precision and the mercy one started this “stuck command” issue for me. So idk what’s going on there.

same here…

I turned ‘Hight Precision Mouse Input Setting’ on and my movement keys work fine, for now at least. I played few Arcade Mode and Quick Play games and haven’t faced any movement bugs since I turned on the mentioned option, the game runs smoothly.

I am much obliged to the support and the community for the help.

Interesting information, thanks for that all.

For those of you who this work around fixes the problem for:

We need some information on your mice. Can you please reply to the thread with the following:

  1. Mouse Make/Model
  2. What DPI setting you’re using
  3. What mouse polling rate you’re using
  4. If you turn off the High Precision Mouse Input setting and try lower polling rates/or different settings, does it fix the problem?
  5. If so, what DPI/Polling rate fixes the problem?

All this info should help us reproduce the issue a little easier and see where the point of failure lies

it seems to work so far

It workes and I have had no problems since I did this change for over a week ago when I posted this solution on the forum. (Enabled the setting)
For info: I use a Logitech G502 with no software installed.

Worked for me, no problems since enabling it.

Didnt work for me. Enabled the setting, still the same issue (even more). But im pretty sure the problem accured from my new Razer Blackwidow. I uninstalled Razer Synapse but not difference.

1 Like

It worked for me! I have a HyperX Pulsefire FPS / HXK-DM01 mouse. Thank you so much for this info!!

  • Razer Deathadder Elite Overwatch Edition (hmm…)
  • 800 DPI
  • 1000Hz
  • High Precision stuff not turned on, just got my behind up to google the issue today.
  • Dunno what fixes the problem, should be your job to figure out tbh.