How did people go about fixing "not logged in as an admin"

I am having the same issue.
Until it’s been fixed by Blizzard, I’ll run the game by launching : Heroes of the Storm\Support64\HeroesSwitcher_x64.exe"
But I have to enter my credentials every single time :frowning:

3 Likes

Just wanted to add that I’m having the same issue and have tried all of the troubleshooting tips. Was playing just fine last night.

1 Like

This actually worked for me lol. Thanks very much!

I’m having this same issue, did you found a solution?

1 Like

I’m having the exact same issue, tried every solution proposed by Blizzard including completely uninstalling the game and Battlenet and all related folders. It won’t let me install anywhere or on different drives and all other Blizzard products are working.

2 Likes

I’m having this issue too, have tried everything, reinstalling battlenet, restarting PC, run as administrator, can’t update & install
Only HotS, any other game worked fine
The only thing that worked is running Heroes of the Storm from the directory
C:\Program Files (x86)\Heroes of the Storm\Support64\HeroesSwitcher_x64.exe

5 Likes

I have this issue as well, unfortunately I uninstalled already so can’t try running the game directly. Won’t allow me to install back, either.

4 Likes

I had the same issue. Unfortunately I uninstalled and launcher won’t install on any drives.

1 Like

The solution for me was this: Endless patching - #15 by Skelgarer-1963

but I have a error on Heroes of the Storm folder, only change name to create a new one… I lost all my config but now I can update or install

Same problem here. My account has admin priv’s. Tried running as administrator. Tried rebooting. Tried scan and repair. Tried uninstalling (which worked!) and reinstalling (which didn’t!). Tried installing into another directory. Tried installing SCII - started without issue in the same parent folder.

Haven’t found a solution yet. Guess I’ll be playing some non-Bliz games for a while.

2 Likes

I hope this gets fixed today… already uninstalled game to try reinstalling so I can’t access it at all.

1 Like

Ok, I found a fix. The clue was about the Documents folder. Assuming it’s the same problem, there’s the “Heroes of the Storm” folder inside your Documents folder that won’t update permissions. Even after trying to give it permissions, it says it requires permission from Desktop<user>

First off, try renaming the folder and then installing Heroes of the Storm. If it still doesn’t work, follow the steps below.

  1. Go to your Documents folder and try to delete the “Heroes of the Storm” folder

  2. If it doesn’t work, you will need to download “Ultimate Windows Tweaker” from here:
    (It won’t let me link, but Google “Ultimate Windows Tweaker” and it should be the first or second link)

  3. On the left side of the “Ultimate Windows Tweaker” application click “Context Menu” then at the top bar under “Desktop Context Menu 2” there is an option to “Add ‘Take Ownership’ Option To Files And Folder” which you need to enable. Apply the tweaks.

  4. Go back to your Documents folder and right click and click “Take Control” then delete the folder.

  5. If it doesn’t work, you will need to go into the folder and select all the files and then right click and “Take Control” and then delete the selected files.

  6. When the windows dialog comes up saying a file can’t be deleted, “Skip” and apply to all future occurrences.

  7. There should be a few folders left. Repeat steps 5 and 6 over and over with all files and folders until the entire folder can be deleted. After all folders inside the Heroes of the Storm folder are deleted, you can delete the folder itself.

  8. When the folder itself has been deleted, you can install from Battle.net launcher.

Good luck everyone

14 Likes

Thank you so much! I was playing today and stopped for a bit and when I went back had this issue while it wanted to update. Tried uninstalling and that just meant I could install for the same problem. Renaming that folder worked!

Thank you! This worked for me too :smiley:

Renaming the folder in Documents did the job for me. The big question is why did it happen?

Played a game. Left the game. A few hours later… had the problem. The only thing unusual was that I left the keyboard at end while our nexus was burned down and I was dead. Didn’t come back for about 20 min.

This worked for me. Thanks! I literally deleted every other folder, had no idea this one existed.

This finally worked! Thank you!

just what the eff blizzard, why the was this folder so locked down out of nowhere? pulling some microsoft store bull right there! fighting for control to delete a folder on your own computer is the most annoying thing to deal with, such a garbage practice from any software company, blizzard you’re slippin.

Hey everyone,

Thank you for your continued reports here. Please refer to the post that I’ve linked below for the latest information regarding this specific issue: