FPS issues, 1-3 FPS - Citrix Software

SOLVED: Citrix was causing problems. I uninstalled Citrix as suggested in the posts below, and issue went away.

I cannot play at all. I’m getting 1-3 frames per second, even at pre-game hero select screen. In-game is about the same.

The game has run flawlessly for the last couple of years on my computer. I have not made any recent software or hardware changes. I have not made any changes to my router or ISP. I have a hardwired connection to my router, so it isn’t a wireless issue. Internet speed tests show there are no issues with my connection.

All other games, including Blizzard games running through Battlenet work fine.

I have tried closing all non-essential background processes, but this did not help.

I have reinstalled the game, updated my BIOS, updated my video card drivers, flushed DNS, uninstalled game & deleted all profile data, re-installed to a different hard drive, updated router firmware, and even cursed at my neighbor’s dog (I was irritable and figured it couldn’t hurt). Not sure what else to do.

Is this a regional issue or something else? I am located on the gulf coast in North America.

1 Like

I think I might have the same issue. Just started for me as well. I’m on the North East. Tried a bunch of stuff as well. If it helps to know you are not alone.

1 Like

That’s four people have posted in 24 hours saying they have the same issue. Please fix this blizzard. Im in Oz.

I am experiencing the same. no change in ISP, hardware, OS and drivers all updated. Cannot get past the character selection the lag is so bad.

North America
Windows 10
OMEN 30L Desktop GT13-0xxx
Microsoft Windows 10 Home

  • Release ID: 2009
  • Version: 10.0.19043
  • Build: 19043
    Intel(R) Core™ i7-10700K CPU @ 3.80GHz
  • Clock speed: 3792Mbps
  • Description: Intel64 Family 6 Model 165 Stepping 5
    NVIDIA GeForce RTX 3080
  • Refresh rate: 84Hz
  • Driver version:


Still no improvement on my end.

System info, just in case someone needs it to help troubleshoot:
Windows 10 version 21H1
Intel I5-6600K
Nvidia GTX 1070
Router: Asus RT-AX92U

My issue is fixed. it was on my end had a misbehaving service on my machine

What did you do lasttomato? What was the service?

Its called App Protection Service by Citrix (unrelated work software)

I’m using Windows 10 (windows update says I’m up to date).
AMD Ryzen 5 3600
16 BG ram
Nvidia rtx 3060
Modem is Huawei HG659 Home Gateway

in task manager what does the network tab display? is there anything using the network? is it wired or wireless?

sorry i can’t find the network tab in task manager. i have citrix for work too though, and i can see App Protection Service. did you just stop it?

Hi everyone. For both lasttomato and I it was a program called Citrix. lasttomato seems to have found a part of Citrix that was causing the problem for him. I just uninstalled citrix entirely and the problem went away instantly. Hope this helps everyone.

Thanks for nothing Blizzard.

Confirmed - Citrix was the culprit.

I also noticed that Citrix made an update recently (10/14/21) on my machine. This coincided with the start of the lag issues in HOTS.

Thank you, everyone.

1 Like

Same!!! :smiley: Guess we all work from home bros.

Hey everyone,

Thank you all for taking the time to report the sudden FPS trouble in Heroes of the Storm, as well as posting the solution of disabling or uninstalling Citrix software. I have updated the title in hopes that this will help others find the solution here. :slightly_smiling_face:



Is there a solution for this other then uninstalling Citrix?

1 Like

I found the solution, uninstall Citrix and download the previous version. 2109 is the problem. Link below (just remove the spaces)

https:// w w w .citrix.com/downloads/workspace-app/legacy-workspace-app-for-windows/workspace-app-for-windows-2108.html#ctx-dl-eula

1 Like

Thank you!

For some of us, uninstalling alone was not a solution as clearly we installed it for work purposes.

I haven’t played for a whole week… tried everything else, uninstalling graphics driver, uninstalling game, repairing game.
So weird it only had problems with HoTS, other games/browsing was unaffected.

1 Like

Citrix forums have shown other games to have issues as well, but it does seem to be only a select few.

Just remember to turn off Citrix automatic updates / update push notifications in the advanced settings to keep the 2108 version. Cheers!

I cannot like this thread enough. With more and more people working from home a lot of companies are using Citrix and it doesn’t play well with HOTS and several other steam games at all.