Can't buy gems, just shows an empty box

This is how it looks:


Logging initialized.
[INFO]-[BNL_Browser]: [20190821T07:48:32] {3670} INF: setting background color ‘0’.
[INFO]-[BNL_Browser]: [20190821T07:48:32] {3670} INF: first page load completed
[INFO]-[BNL_Browser]: [20190821T07:48:32] {3670} INF: Navigating to ‘about:blank’.
[INFO]-[BNL_Scene]: [20190821T07:48:35] {3670} INF: received shutdown message from client.


Logging initialized.
[INFO]-[BNL_Browser]: [20190821T07:48:39] {2da8} INF: setting background color ‘ff002650’.
[INFO]-[BNL_Browser]: [20190821T07:48:39] {1fa8} INF: setting background color ‘ff002650’.
[INFO]-[BNL_Browser]: [20190821T07:48:39] {1fa8} INF: first page load completed
[INFO]-[BNL_Browser]: [20190821T07:48:39] {2da8} INF: first page load completed
[INFO]-[BNL_Browser]: [20190821T07:48:39] {1fa8} INF: Navigating to ‘LINK REMOVED FOR POSTING’.
[INFO]-[BNL_Browser]: [20190821T07:48:39] {1fa8} INF: Navigating to ‘#0’.
[INFO]-[BNL_Browser]: [20190821T07:48:39] {2da8} INF: Navigating to ‘LINK REMOVED FOR POSTING’.
[INFO]-[BNL_Scene]: [20190821T07:48:41] {2da8} INF: received shutdown message from client.
[INFO]-[BNL_Scene]: [20190821T07:48:41] {1fa8} INF: received shutdown message from client.



[0821/] Failed to launch GPU process.


[0821/] Unable to move the cache: 5
[0821/] Unable to move cache folder GPUCache to old_GPUCache_000
[0821/] Unable to create cache
[0821/] Shader Cache Creation failed: -2
[0821/] Failed to launch GPU process.
[0821/] Failed to launch GPU process.
[0821/] Invalid URL passed to CefBrowserHostImpl::Navigate:

Still same for me. Empty box. Saving me money though I guess

Hey gang :wave:

If you’re getting this blank box for the in-game shop, let’s try these things… first, try removing then re-adding your payment method:

Payment Methods

Try clearing the app cache too:

Deleting Files

Please also try running Heroes of the Storm in administrator mode:

Administrator Mode

Best of luck in your adventures :slight_smile:

Tried all these just now @Metalagon . Unfortunately still same issue.

Same, did the things, still a blank box.

Hey there,

Would it be at all possible to test a different network? Such as a mobile hotspot, wifi cafe, friend’s house, or similar. This will help verify if the problem is related to the network or software on the PC.

@Kaldraydis Coincidentally I actually just had new internet service installed today and same issue right now. :frowning:

Edit: I haven’t tried purchasing on my account on a different computer though but I don’t have one available to try.

Nope, no option.

Now I think of it, my home security system was compromised by the Chinese a couple months ago, and I got (globally) blacklisted by my Internet provider. After things were fixed, they reported me okay again, but it appears (some) US based providers haven’t taken me off their list. (I’m in/from the Netherlands)

I also play Ultima Online on a US server, and they had to contact their own US based provider to get me removed from their blacklist.


If it is some kind of ISP issue you should be able to work around it by running on a VPN - I didn’t see any account level issues that might be causing this. Can you test on a VPN?

Do you have any suggestions for a trusted easy to use and free one, just to try this? (Especially since Zaiko also has the same problem as me, but I doubt he has the same story)

I mean, I’m a customer trying to give you money for a game (you kinda already abandoned), don’t tell me I’m the one who’s having to jump through all kinds of hoops to get this issue fixed.

If it’s indeed the ISP issue I am referring to, then it is out of my hands, as my provider has already cleared me, and it is working for everything in Europa. I can’t ask your US ISP to trust that my Chinese AliExpress security camera has been thrown in the trash. You’ll have to tell them that you trust me, if this is indeed the problem.

Sorry if I sound (passive) aggressive, but come on, 15 years ago if I had payment issues with Blizzard (or any gaming company for that matter), I could still actually call you, and someone would actually try and figure out what’s going on, and/or at least offer me a solution for my specific problem with HoTS. (I added money to my blizzard account yesterday no problem to buy a SC2 coop commander, I just can’t buy anything in HoTS). I already spend at least 2 hours deleting and reinstalling stuff, looking for information, posting here, and just spend 10 minutes looking at VPN’s before I wondered why -I’m- doing this.

Either you want Zaiko and myself as (HoTS) customers, and you figure out why ISP’s are preventing us from accessing your store and spending money, IF that is the problem to begin with, or the money is just not getting spend.

Again, sorry, but I’ve just had enough of this. For 10 minutes (after already having spend at least an two hours on this) I slavishly sat here figuring out how to use VPN’s and which one to get before I realized I 1. wouldn’t accept this from any store “irl”, and 2. I don’t -that- desperatetly want to play “Probius”.

Again again, sorry, this is no aimed at you personally, but I would have asked for your manager and scolded him, but this is the internet and I can’t.

1 Like

Yeah there have been plenty of other threads about the same issue with the gems and the leaderboards. It’s not you @JCShooter

I’ve seen quite a few people give them logs as you did and haven’t seen much of a response to that. If there was a way to just buy the gems outside of the client this wouldn’t be an issue. You think they’d want our money but not that bad I guess haha.

Here’s links to other threads where others have same issue as you and I. You won’t find any fix on those threads though :frowning:

1 Like

Hey y’all,

This is something we have sent up to be investigated but the problem is that there appears to be multiple causes and can be difficult to pin down.

If closing background programs and uninstalling Razer Synapse (temporarily at least) doesn’t help, then try using the legacy version of DirectX 11:

  1. With the desktop app opened and WoW selected click on Options
  2. Select Game Settings
  3. Find WoW and check the box for Additional command line arguments
  4. In the new box enter the command for the desired DirectX version:
  5. Click Done to save.


You did it! For me at least, the issue of not being able to purchase gems was fixed by simply closing Razer Synapse (didn’t need to uninstall it). Crazy!!

It works now and was able to finally buy some gems


No progress for me.

@Zaiko Nice! Lucky you.

Hey JCShooter,

Based on everything you have tried and your unique situation, it may be best to create a support ticket and include your MSinfo so we can analyze this issue.


Done. Lalala, I need to type more than 20 characters.

I cannot purchase any gems either because of just an empty box. Blizzard - please help.

Having the same problem too! Not just here in HOTS but in StarCraft 2 as well!

Edited by Blizzard - this topic is being locked as this is an old post which was bumped. Please create your own thread or contact support.