Update on 15.6 Issues

Hi, i cant log in on EU. ( Android and PC )

Man, i still have the bug on the decks.
The ones with 1golden and 1normal, end being tagged as 28/30 every single time i restart the game.

1 Like

I have the same bug. I posted it here but we didn’t get a developer response.

Post the screenshots links without www

I play Hearthstone almost from the beggining and it’s the worst patch you’ve made. Golden cards, roaring Torch, you broke the game. Hope you’ll compensate that terrible patching. Really a bad timing to miss a patch as many people are losing interest for the game…

1 Like

Battlegrounds mod: Manastorm buffs not only mechs in Bob’s inn, but mechs of her enemy (at least summoned microbots)

Amazing golden cards isn’t the top priority. Not being able to play decks and having a broken game far exceeds any other issues. When I need to play (this is my resting game on my phone generally) I end up playing Kobolds and Catacombs single player and Tavern brawl to finish quests. I’ve never seen the game this broken before. The game has always worked in the past, despite bugs and being annoying and relogging, but never making a person do busy work just to play a deck. Even worse on a phone if you go to standby, then spend 3-5 minutes yet again fixing your deck to play, so just don’t play.


There’s another thread on that issue. It sounds like if you concede at any point—even if it’s turn 12 and you’re staring at lethal—you don’t get credit for the quest (which IMO is a bug).


Every single time I open friend list and tap one of friends to read messages game crashes. That problem makes it impossible to reply or read messages…

iOS 13.1.2
iPhone X


With Brann on board I played Primalfin Lookout. The first card I discovered was a triple. After that triple was merged, the second battlecry wasnt triggered by Brann. Otherwise double battlecries continued to work.

Why do I get the idea that making us wait a week for what should have been a hotfix is all about money and profit margins?

Having an issue on mobile, specifically android where players names and current rank are not displayed during the match.

Attempted a uninstall/reinstall fix with no luck. I am also experiencing all other bugs listed above, plus this one if it could be added to the list. Thank you!

  • tried to upload a screen shot to here but wasnt able to.

Unable to login into phone. Pc version working properly but there is still like battle net issues. I mean battle net app on pc says “Page not found”. But hearthstone runs. On my phone I am not able to login at all.

Can’t replace daily events!!! When it will be fixed?

over 24 hours and my decks still show incomplete and if I remove the missing card and read it, I can play the deck, but when I log back in later I have to do it again. it is affecting Gold cards

I’m kinda surprised how much I rely on squelch. I’ve tried playing a few games without it and I just can’t stomach it.

I 'm missing card in the collection both golden and not, also I’m having problems with deck building and my own decks as other already pointed

I have two daily quests that say, “PLAY 3 games” as a certain class. However, it only counts towards my quest if I win the game. Please revise.

1 Like

This could be a hint to what’s going on to people’s decks. I have one deck without golden cards. While I can play the deck, it reports there are more than 30 cards in the deck. So there is some fundamental problem that goes beyond decks with golden cards being unplayable.

tomb of terror 6 COMPLETED encounters updated quest of terrors SHOULd qualify for this:
(here should be a picture picture of morons (OR NOT v.i p.S) that refuse upload of game breaking content)

Awesum, the “PLAY 3 games” quests have been working for me, even when I lose. I just lost a Friendly game earlier today and it still progressed my quest. Some have said that Conceding negates the progress though. Any chance that you conceded right before you lost? I haven’t confirmed this yet, just wanted to pass that idea on in case you hadn’t seen others report this possible concede glitch.