Unable to log in on android

Since last weeks patch. Stuck in log in loop on sign in page. Uninstalled, re-installed, granted game permission to access storage, no go. Attempted to open web ticket multiple times received error msg each x to try again later.

This is because I downloaded patch on my mac, but I’ve heard issue has been resolved
…but not for me. Thats time I’ll never get back, perhaps its the universe telling me something…

Is there anything I can do other than playing exclusively on mac?

Also, I attempted to sign in as a new user(this worked for me before another time when I experienced similar difficulties after patch), but theres no longer an option to quit and re sign in.

Any advice appreciated. 100% frustrating

6 Likes

Echoing this problem. Someone from support give us some info on this.

I suspect this is affecting many android users. I’m afraid to sign out of the desktop client and possibly ‘losing my collection’ that I spend a few years building.

My minds goes to conspiratorial places sometimes.

1 Like

I have the same problem on my Android devices. I can only play on my computer.

1 Like

Not seeing any current widespread reports of this however I have seen the occasional report come in and be attributed to a couple of potential causes.

The best thing we can do here is see what everybody is experiencing the issue with.

Make/Model of the device:
Cellular Provider:
Version of Android running:
Logging in using battle.net login or google credentials:
Using Wifi or Cellular network to login?

There aren’t many reports again atm so the more of you in this thread that can provide the above info, the more likely we will be able to pinpoint the source of the issue and a solution.

android galaxy a02s, sm-A025U
metro/tmobile
login w/battle.net, google, faceboook
wifi and cellular
authenticator enablebled

That happens to me too. I was playing battlegrounds. Got dc. Then that login loop happened. I tried change password. Unlock account. Clear cache. Non of these worked.
Using wi-fi/cellular. Redmi note 9s. Auth enabled.

2 Likes

I have the same issue. I was going to purchase the preorder on android because it’s cheaper for my country but I can’t login. I tried on 2 different Samsung devices. It keeps opening sign-up page even though I correctly enter my password.

I solved it by connecting with Google. I added my battle.net account to Google and login with it. It worked.

Hey all,

Hattat, I am glad to see that changing login methods worked for you. That does seem to be the most common solution whenever we see a report of this pop up.

Markovic, did you trying switching login methods between facebook, google and battle.net credentials?

Grumpymonk, I can’t say if this is your issue but a while back there was an issue with sprint/tmobile users that caused similar but not exactly this issue. If you tried all three log in options something else you can try is to go into settings > connections > mobile networks > Access Point Names, select your mobile provider’s name, then scroll down to APN Protocol. Under that select IPV4. Save it, back out, restart the phone and retest. Try all three logon options.

If that works you can try switching back to ipv6 and retest.

My problem is similiar, I’m stuck on the first screen and get timed out. Thing is, that’s only on my mobile device, everything works just fine on PC. And the weirdest thing is that’s only if I connect through my home WiFi, so far I only tried through that and a hotspot from my gf’s smartphone and the the latter connection seemed to work fine. I have no idea what’s going on, it seems so specific.

1 Like

I am still in endless login loop too. Connected my google and battle.net accounts but it didn’t work. I use Bluestacks, until this HS version there wasn’t any problem at all.

1 Like

I have the same problem too. I have IPV4 in my settings. I’ve tried Wi-Fi and mobile network.

1 Like

Motorola G7 Play, AT&T, Android Version 10 QPYS30.85-23-3, logging in with battle.net credentials on WiFi with no success.

1 Like

Still experiencing the problem, can’t even log in through Facebook or google

4 Likes

Redmi Note 9
Xiaomi
Android 11, MIUI 12.5 E
Login with battle.net, google and facebook
Both wifi and cellular network

1 Like

Is this related to the sudden Unavailability of the Hearthstone app, on Android devices thru Google Play?

2 Likes

Samsung A02s
Cricket Wireless
11
Bnet
Have tried both to no avail

I have tried this but I am unable to alter those settings on my device. I can view them, but I believe my provider has locked them to be un-manipulatable

Today i changed my phone and started to get the same error. Poco x3 pro. İ tried changing the password but then i post it on my old phone Samsung s9+ too. The same loop on sign in Button. İn pc there is nothing wrong. İ tried both on wifi and mobile network. So if i have the same problem with my both phones its not a Hardware or model based i hile you Fox it quickly…

1 Like